UVA 673 括號的匹配——經典棧的應用
http://vjudge.net/contest/view.action?cid=50788#problem/A
You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
- (a)
- if it is the empty string
- (b)
- if A and B are correct, AB is correct,
- (c)
- if A is correct, (A ) and [A ] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses () and [], one string a line.
Output
A sequence of Yes or No on the output file.
Sample Input
3 ([]) (([()]))) ([()[]()])()
Sample Output
Yes No Yes
題目大意:給出你一串由[ ] ( )四種字元組成的字串,判斷是否合法的字串。
大體思路:
方法一:
因為以前做過一道括號的最大匹配的題,我想著如果最大匹配正好和字串的長度是一致的時候我們可以確定該字串是合法的字串,不知道什麼會超時==
/*
==超時的程式碼==
*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
char a[130];
int dp[130][130];
int main()
{
int T;
scanf("%d%*c",&T);
while(T--)
{
scanf("%s",a+1);
memset(dp,0,sizeof(dp));
int n=strlen(a+1);
if(n%2)
{
printf("No\n");
continue;
}
/* for(int i=1;i<=n;i++)
cout <<a[i];
cout <<"**"<<endl;*/
for(int i=n-1; i>=0; i--)
for(int j=i+1; j<=n; j++)
{
dp[i][j]=dp[i+1][j];
for(int k=i+1; k<=j; k++)
if((a[i]=='('&&a[k]==')')||(a[i]=='['&&a[k]==']'))
dp[i][j]=max(dp[i][j],dp[i+1][k-1]+dp[k+1][j]+2);
}
/*for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
printf("%d ",dp[i][j]);
printf("\n");
}*/
if(dp[1][n]==n)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}
方法二:
利用棧的特殊進出順序。詳見程式碼
#include<cstdio>
#include<cstring>
#include<stack>
using namespace std;
stack<char> s;
char str[130];
int main(void)
{
int t;
scanf("%d", &t);
getchar();
while (t--)
{
gets(str);
int len = strlen(str);
if (len & 1)
puts("No");
else
{
if (!s.empty())
s.pop();
s.push('0');
for (int i = 0; i < len; ++i)
{
if (str[i] == '(' || str[i] == '[')
s.push(str[i]);
else if (str[i] == ')')
{
if (s.top() == '(')
s.pop();
else
{
s.push('1');
break;
}
}
else
{
if (s.top() == '[')
s.pop();
else
{
s.push('1');
break;
}
}
}
puts(s.top() == '0' ? "Yes" : "No");
}
}
return 0;
}
相關文章
- 【棧】括號匹配
- 棧和括號匹配,一文搞懂
- 【LeetCode-棧】有效的括號LeetCode
- 括號匹配的檢驗問題(C++)C++
- LeetCode-20. 有效的括號(棧模擬)LeetCode
- Leetcode 20 有效的括號valid-parentheses(棧)LeetCode
- JavaScript 解構賦值小括號的應用JavaScript賦值
- LeetCode 3: PairsOfParentheses (括號匹配問題)LeetCodeAI
- HDU 5831 Rikka with Parenthesis II (括號匹配)
- 資料結構括號匹配問題資料結構
- 理解正規表示式中的括號 (),方括號 [] 和大括號 {}
- [Go 演算法]20:有效括號(棧)Go演算法
- 有效的括號
- UVA 11020 Efficient Solutions+multiset的應用
- {} 花括號的用法
- [leetcode]有效的括號LeetCode
- 棧的應用
- .net core 中的經典設計模式的應用設計模式
- 正規表示式(匹配第一個花括號)
- c++物件建立帶括號與無括號的區別C++物件
- LeetCode有效的括號(Python)LeetCodePython
- 20. 有效的括號
- 【leetcode】32. Longest Valid Parentheses 最長的有效匹配括號子串長度LeetCode
- Leetcode——20. 有效的括號LeetCode
- Leetcode20. 有效的括號LeetCode
- 【LeetCode】 20.有效的括號LeetCode
- LeetCode 20. 有效的括號LeetCode
- 使用Python實現一個棧, 判斷括號是否平衡Python
- 訊息佇列的七種經典應用場景佇列
- 棧的原理與應用
- 棧的實際應用
- 並查集經典應用場景並查集
- 經典資料分析應用介紹
- 把經典的ABAP webdynpro應用配置到SAP Fiori Launchpad裡Web
- 萬用字元 and [] 中括號的用法字元
- 最長有效括號的問題
- 每日一練(36):有效的括號
- latex 中乘號、恆等號、花括號的寫法
- 棧的應用和實現