詳述 IntelliJ IDEA 遇到 java -source 1.3 中不支援某某操作的解決方法

macw77發表於2024-01-05

在一個新的 Mac Pro 電腦中,安裝 IntelliJ IDEA,並且配置了 JDK 1.8,開啟測試專案,執行後,報出如下問題:

IntelliJ IDEA 中文版破解下載

詳述 IntelliJ IDEA 遇到 java -source 1.3 中不支援某某操作的解決方法

透過問題描述,顯然 IDEA 並沒有使用我配置的 JDK 1.8,而是使用了 JDK 1.3,這是為什麼呢?

實際上,IDEA 預設是使用 JDK 1.3 進行編譯,而在配置 JDK 的時候,我們有可能忽然了該配置。

解決方法

方法一

File -> Project Structure -> Modules

詳述 IntelliJ IDEA 遇到 java -source 1.3 中不支援某某操作的解決方法

如上圖所示,進入該目錄,修改當前模組的Language level,預設為1.3,修改為8即可。

方法二

File -> Project Structure -> Project

詳述 IntelliJ IDEA 遇到 java -source 1.3 中不支援某某操作的解決方法

如上圖所示,進入該目錄,修改當前專案的Language level,預設為1.3,修改為8即可。

無論是 方法一 還是 方法二,都是修改預設的Language level,其區別就是一個是對當前模組生效,一個是對當前專案生效。而有時,因為某種需要,我們可能會在一個專案裡面建立多個模組,當然,常見的還是單模組專案。


來自 “ ITPUB部落格 ” ,連結:https://blog.itpub.net/69984513/viewspace-3002802/,如需轉載,請註明出處,否則將追究法律責任。