字串-大小寫轉換

HowieLee59發表於2019-03-18

Problem Description

X現在要學習英文以及各種稀奇古怪的字元的了。現在他想把一串字元中的小寫字母變成大寫字元,大寫字母變成小寫字母,其他的保持不變。

Input

 輸入有多組。

每組輸入一個字串,長度不大於80,不包含空格。

Output

 輸出轉換後的字串

Sample Input

A*
B+

Sample Output

a*
b+
#include<stdio.h>
#include<stdlib.h>
#include<string.h>

int main(){
    char str[1001];
    while(gets(str)){
        int len = strlen(str);
        for(int i = 0 ; i < len ; i++){
            if((str[i] >= 'a' && str[i] <= 'z')){
                str[i] = str[i] - 32;
            }else if(str[i] >= 'A' && str[i] <= 'Z'){
                str[i] = str[i] + 32;
            }
            printf("%c",str[i]);
        }
        printf("\n");
    }
    return 0;
}

 

相關文章