字串-大小寫轉換
Problem Description
X現在要學習英文以及各種稀奇古怪的字元的了。現在他想把一串字元中的小寫字母變成大寫字元,大寫字母變成小寫字母,其他的保持不變。
Input
輸入有多組。
每組輸入一個字串,長度不大於80,不包含空格。
Output
輸出轉換後的字串
Sample Input
A* B+
Sample Output
a* b+
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main(){
char str[1001];
while(gets(str)){
int len = strlen(str);
for(int i = 0 ; i < len ; i++){
if((str[i] >= 'a' && str[i] <= 'z')){
str[i] = str[i] - 32;
}else if(str[i] >= 'A' && str[i] <= 'Z'){
str[i] = str[i] + 32;
}
printf("%c",str[i]);
}
printf("\n");
}
return 0;
}
相關文章
- JavaScript字串大小寫轉換JavaScript字串
- javascript字串大小寫轉換效果JavaScript字串
- MySQL字串函式 字串大小寫轉換MySql字串函式
- 字串大小寫轉換和字串的比較字串
- 字串中大小寫轉換輸出字串
- python 中字串大小寫轉換薦Python字串
- 大小寫互換-"數字字串"轉換成數字字串
- Python中怎麼轉換字串大小寫Python字串
- (C++字串大小寫轉換)相似的句子C++字串
- JavaScript字母大小寫轉換JavaScript
- 英文大小寫轉換
- 使用正則 轉換大小寫
- 金額大小寫轉換(3)
- js 轉換大小寫的方法JS
- 在LoadRunner中轉換字串大小寫的C語言函式字串C語言函式
- Notepad++ 大小寫轉換
- string大小寫轉換函式函式
- linux命令列大小寫轉換Linux命令列
- PowerDesigner表名、列名大小寫轉換
- 【編測編學】零基礎學python_02_字串(大小寫轉換)Python字串
- Swift3.0語言教程字串大小寫轉化Swift字串
- 在 Linux 命令列中轉換大小寫Linux命令列
- MySQL-資料記錄大小寫轉換MySql
- CSS text-transform字元大小寫轉換CSSORM字元
- js如何進行字元大小寫轉換JS字元
- 大小寫轉換函式(財務應用)函式
- VB作業之字母大小寫的轉換
- VS Code 如何設定大小寫轉換快捷鍵
- DM8 字串大小寫敏感字串
- 電腦鍵盤大小寫字母怎麼切換 轉換英文字母大小寫是哪個鍵
- 字串轉換字串
- 13:將字串中的小寫字母轉換成大寫字母字串
- 在Linux行內直接進行大小寫轉換Linux
- ARM彙編解決階乘以及大小寫轉換
- 初學 Delphi 嵌入彙編[26] - 大小寫字母轉換
- mysql字串之大小寫匹配查詢MySql字串
- 轉化某個字母字串為反向大小寫儲存過程字串儲存過程
- python開發_大小寫轉換,首字母大寫,去除特殊字元Python字元