[PAT]1028. List Sorting (25)@Java實現
1028. List Sorting (25)
Excel can sort records according to any column. Now you are supposed to imitate this function.
Input
Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).
Output
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
Sample Input 13 1 000007 James 85 000010 Amy 90 000001 Zoe 60Sample Output 1
000001 Zoe 60 000007 James 85 000010 Amy 90Sample Input 2
4 2 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 98Sample Output 2
000010 Amy 90 000002 James 98 000007 James 85 000001 Zoe 60Sample Input 3
4 3 000007 James 85 000010 Amy 90 000001 Zoe 60 000002 James 90Sample Output 3
000001 Zoe 60 000007 James 85 000002 James 90 000010 Amy 90
package go.jacob.day1026;
import java.util.ArrayList;
import java.util.Collections;
import java.util.Scanner;
public class Demo2 {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt(), c = sc.nextInt();
ArrayList<Stu> list = new ArrayList<Stu>();
for (int i = 0; i < n; i++) {
list.add(new Stu(sc.next(), sc.next(), sc.nextInt(), c));
}
Collections.sort(list);
for (Stu s : list)
System.out.println(s);
}
}
class Stu implements Comparable<Stu> {
String ID;
String name;
int score;
int column;
public Stu(String iD, String name, int score, int column) {
super();
ID = iD;
this.name = name;
this.score = score;
this.column=column;
}
@Override
public int compareTo(Stu s) {
if (column == 1) {
return ID.compareTo(s.ID);
} else if (column == 2) {
if (name.equals(s.name))
return ID.compareTo(s.ID);
return name.compareTo(s.name);
} else {
if (score == s.score)
return ID.compareTo(s.ID);
return score - s.score;
}
}
// 直接重寫toStirng比較好
@Override
public String toString() {
return ID + " " + name + " " + score;
}
}
相關文章
- PAT-A Java實現Java
- PAT甲級1122 Hamiltonian Cycle (25分)|C++實現C++
- PAT甲級1154 Vertex Coloring (25分)|C++實現C++
- PAT甲級1110 Complete Binary Tree (25分)|C++實現C++
- PAT1076 WiFi密碼(java實現)WiFi密碼Java
- PAT乙級——1093(字串匹配)Java實現字串匹配Java
- PAT1044火星數字(java實現)Java
- PAT1004成績排名(java實現)Java
- PAT1043 輸出PATest(java實現)Java
- PAT1048數字加密(java實現)加密Java
- PAT1019 數字黑洞(java實現)Java
- PAT1029 舊鍵盤(java實現)Java
- PAT1033 舊鍵盤打字(java實現)Java
- PAT1077互評成績計算(java實現)Java
- PAT:1020. Tree Traversals (25) AC
- PAT乙級——1092(陣列排序 自定義sort)Java實現陣列排序Java
- PAT1008 陣列元素迴圈右移問題(java實現)陣列Java
- PAT1078字串壓縮與解壓(java實現)字串Java
- PHP FFI 實現listPHP
- PAT 1033 To Fill or Not to Fill (25分) 貪心思想
- java多現場讀取listJava
- 簡單的list介面和edit介面使用java swing實現Java
- Sorting with Twos
- PAT (Advanced Level) Practice 1149 Dangerous Goods Packaging (25分)Go
- PAT甲級1126~1130|C++實現C++
- Java入門系列-25-NIO(實現非阻塞網路通訊)Java
- java集合-ListJava
- List介面及其主要實現類
- Sorting arrays in NumPy by column
- 19年春季第二題 PAT甲級 1157 Anniversary(25 分)
- java解析json listJavaJSON
- Homework record-Simple sorting
- Java - 25 main方法JavaAI
- java原始碼-java.util.ListJava原始碼
- Python 通過List 實現佇列的操作Python佇列
- Redis 竟然能用 List 實現訊息佇列Redis佇列
- List,DataTable實現行轉列的通用方案
- 02-線性結構3 Reversing Linked List (25分)
- Java筆記——【List、Set】Java筆記