[PAT]1028. List Sorting (25)@Java實現

JacobGo發表於2017-10-26

1028. List Sorting (25)

時間限制
200 ms
記憶體限制
65536 kB
程式碼長度限制
16000 B
判題程式
Standard
作者
CHEN, Yue

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90


package go.jacob.day1026;

import java.util.ArrayList;
import java.util.Collections;
import java.util.Scanner;

public class Demo2 {
	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		int n = sc.nextInt(), c = sc.nextInt();
		ArrayList<Stu> list = new ArrayList<Stu>();
		for (int i = 0; i < n; i++) {
			list.add(new Stu(sc.next(), sc.next(), sc.nextInt(), c));
		}
		Collections.sort(list);
		for (Stu s : list)
			System.out.println(s);

	}
}

class Stu implements Comparable<Stu> {
	String ID;
	String name;
	int score;
	int column;

	public Stu(String iD, String name, int score, int column) {
		super();
		ID = iD;
		this.name = name;
		this.score = score;
		this.column=column;
	}

	@Override
	public int compareTo(Stu s) {
		if (column == 1) {
			return ID.compareTo(s.ID);
		} else if (column == 2) {
			if (name.equals(s.name))
				return ID.compareTo(s.ID);
			return name.compareTo(s.name);
		} else {
			if (score == s.score)
				return ID.compareTo(s.ID);
			return score - s.score;
		}
	}

	// 直接重寫toStirng比較好
	@Override
	public String toString() {
		return ID + " " + name + " " + score;
	}

}



相關文章