排名——採用結構體排序

韓小妹發表於2018-08-10

Problem Description

今天的上機考試雖然有實時的Ranklist,但上面的排名只是根據完成的題數排序,沒有考慮
每題的分值,所以並不是最後的排名。給定錄取分數線,請你寫程式找出最後通過分數線的
考生,並將他們的成績按降序列印。

 

 

Input

測試輸入包含若干場考試的資訊。每場考試資訊的第1行給出考生人數N ( 0 < N
< 1000 )、考題數M ( 0 < M < = 10 )、分數線(正整數)G;第2行排序給出第1題至第M題的正整數分值;以下N行,每行給出一
名考生的准考證號(長度不超過20的字串)、該生解決的題目總數m、以及這m道題的題號
(題目號由1到M)。
當讀入的考生人數為0時,輸入結束,該場考試不予處理。

 

 

Output

對每場考試,首先在第1行輸出不低於分數線的考生人數n,隨後n行按分數從高
到低輸出上線考生的考號與分數,其間用1空格分隔。若有多名考生分數相同,則按他們考
號的升序輸出。

 

 

Sample Input


 

4 5 25 10 10 12 13 15 CS004 3 5 1 3 CS003 5 2 4 1 3 5 CS002 2 1 2 CS001 3 2 3 5 1 2 40 10 30 CS001 1 2 2 3 20 10 10 10 CS000000000000000001 0 CS000000000000000002 2 1 2 0

 

 

Sample Output


 

3 CS003 60 CS001 37 CS004 37 0 1 CS000000000000000002 20

AC碼:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAX=22;
const int MAXN=11;
int point[MAXN];
struct node{
	char num[MAX];//准考證號 
	int por_num[MAXN];//做出來的題目
	int pnt;//總得分 
}s[1001]; 
bool cmp(node &x,node &y)
{
	if(x.pnt ==y.pnt )//總得分相同時,按照考號升序 
	return strcmp(x.num ,y.num )<0?1:2;
	else
	return x.pnt >y.pnt ;//總得分按照升序排序 
}
int main()
{
	int N,sum;
	while(~scanf("%d",&N))
	{//N名同學 
		sum=0;
		if(N==0)
		break;
		int M,G;//M道題 G為分數線
		scanf("%d %d",&M,&G);
		int i,max;
		for(i=0;i<M;i++)
		scanf("%d",&point[i]); //每道題的滿分情況
		for(i=0;i<N;i++)
		{
			scanf("%s",s[i].num );//輸入考生號 
			s[i].pnt =0;
			int slv,j;
			scanf("%d",&slv);//該考生答對的題目的數量 
			for(j=0;j<slv;j++)
			{
				scanf("%d",&s[i].por_num [j]);
				s[i].pnt +=point[s[i].por_num [j]-1];
			}
		}
		for(i=0;i<N;i++)
		if(s[i].pnt >=G)
		sum++;//超過分數線的總人數 
		printf("%d\n",sum);
		sort(s,s+N,cmp);//按要求排序 
		for(i=0;i<sum;i++)//將超過分數線的學生資訊輸出 
		printf("%s %d\n",s[i].num ,s[i].pnt );
	}
	return 0;
}

 

相關文章