POJ 2431 Expedition

wxyfennie發表於2016-05-07

Expedition
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 11518   Accepted: 3328

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

優先佇列應用

1、根據車子行駛過程,判斷下一次要行駛到的距離 與 油量的關係

2、如果下一次行駛到的距離 > 油量,則可以行駛,並且將下一次到站

3、否則,

3.1  佇列是不是為空,若為空則輸出-1

3.2 將佇列中最大的加油量加入現有的油量

3.3 如果油量足夠到下一站,則可以

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
priority_queue<int>pq;
struct town
{
    int a;
    int b;
};
town t[10005];
bool cmp(struct town x,struct town y)
{
    return x.a < y.a;
}
int main()
{
    int n,l,p;
    cin>>n;
    for(int i = 0; i < n ;i++)
    {
        scanf("%d %d",&t[i].a,&t[i].b);
    }
    cin>>l>>p;
    for(int i = 0; i < n ;i++)
    {
        t[i].a = l-t[i].a;
    }
    sort(t,t+n,cmp);
    int ans = 0;
    t[n].a=l;
    int flag = 0;
    for(int i = 0; i<=n; i++)
    {
        //cout<<"size : "<<pq.size()<<endl;
        while(t[i].a > p)
        {
            if(pq.empty())
            {
                cout<<-1<<endl;
                flag = 1;
                break;
            }
            //cout<<pq.top();
            p += pq.top();
           // cout<<p;
            pq.pop();
            ans++;
        }
        pq.push(t[i].b);
        if(flag)
            break;
    }
    if(!flag)
        cout<<ans<<endl;
    return 0;
}






相關文章