POJ 2431 Expedition
Expedition
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 11518 | Accepted: 3328 |
Description
A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck's fuel tank. The truck now leaks one unit of fuel every unit of distance
it travels.
To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).
The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).
Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop).
The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000).
Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all.
Input
* Line 1: A single integer, N
* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.
* Line N+2: Two space-separated integers, L and P
* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop.
* Line N+2: Two space-separated integers, L and P
Output
* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.
Sample Input
4 4 4 5 2 11 5 15 10 25 10
Sample Output
2
優先佇列應用
1、根據車子行駛過程,判斷下一次要行駛到的距離 與 油量的關係
2、如果下一次行駛到的距離 > 油量,則可以行駛,並且將下一次到站
3、否則,
3.1 佇列是不是為空,若為空則輸出-1
3.2 將佇列中最大的加油量加入現有的油量
3.3 如果油量足夠到下一站,則可以
#include <stdio.h>
#include <stdlib.h>
#include<string.h>
#include<algorithm>
#include<iostream>
#include<queue>
using namespace std;
priority_queue<int>pq;
struct town
{
int a;
int b;
};
town t[10005];
bool cmp(struct town x,struct town y)
{
return x.a < y.a;
}
int main()
{
int n,l,p;
cin>>n;
for(int i = 0; i < n ;i++)
{
scanf("%d %d",&t[i].a,&t[i].b);
}
cin>>l>>p;
for(int i = 0; i < n ;i++)
{
t[i].a = l-t[i].a;
}
sort(t,t+n,cmp);
int ans = 0;
t[n].a=l;
int flag = 0;
for(int i = 0; i<=n; i++)
{
//cout<<"size : "<<pq.size()<<endl;
while(t[i].a > p)
{
if(pq.empty())
{
cout<<-1<<endl;
flag = 1;
break;
}
//cout<<pq.top();
p += pq.top();
// cout<<p;
pq.pop();
ans++;
}
pq.push(t[i].b);
if(flag)
break;
}
if(!flag)
cout<<ans<<endl;
return 0;
}
相關文章
- POJ2431 Expedition (優先佇列)佇列
- 優先佇列的學習記錄--例題:Expedition(POJ2431)佇列
- POJ 3461 kmpKMP
- poj3417
- Flip Game(POJ 1753)GAM
- POJ 3414 Pots
- POJ3259-WormholesWorm
- POJ 1562 Oil Deposits
- poj 2478 尤拉函式函式
- POJ 2524 Ubiquitous ReligionsUI
- POJ 3981 字串替換字串
- poj 1276 Cash MachineMac
- POJ 基本演算法演算法
- POJ 1089 Intervals
- POJ3414-Pots
- POJ 2799 IP Networks
- POJ 2891 Strange Way to Express IntegersExpress
- Dungeon Master(POJ-2251)AST
- 【poj3468】A Simple Problem with Integers
- POJ 3321 Apple TreeAPP
- POJ 1160 Post Office
- POJ-2251 Dungeon MasterAST
- poj 2481 樹狀陣列陣列
- POJ-1664 放蘋果蘋果
- POJ2251 Dungeon MasterAST
- POJ 1850 Code/POJ 1496 Word Index(組合數學-字母串序號)Index
- Apple Catching POJ - 2385APP
- POJ 2355 Railway Ticket problemAI
- POJ 1611 The Suspects 圖論圖論
- POJ 2240 Arbitrage(Floyd最短路)
- 【個人訓練】(POJ3279)Fliptile
- POJ 2503-Babelfish(STL-map)Babel
- POJ1745Divisibility(dp)
- 矩陣類 poj3420矩陣
- POJ 2823 單調佇列佇列
- POJ2955 Brackets (區間DP)Racket
- POJ1247-Magnificent MeatballsNifi
- poj 1426Find The Multiple