動態規劃 hdu 1500 Chopsticks
Problem Description
In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick
to get some big food by piercing it through the food. As you may guess, the length of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it's the longest. To make things clearer, for the
set of chopsticks with lengths A,B,C(A<=B<=C), (A-B)^2 is called the 'badness' of the set.
It's December 2nd, Mr.L's birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his little son, little daughter, his mother, father,
mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of all the sets is minimized.
Input
The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number of chopsticks. There are N positive integers
Li on the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).
Output
For each test case in the input, print a line containing the minimal total badness of all the sets.
Sample Input
1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164
Sample Output
23
Note
For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160
Solution
#include <iostream>
using namespace std;
#define min(a,b) (a)<(b)?(a):(b)
#define sqr(a) (a)*(a)
#define MAXK 1100
#define MAXN 5100
int t,T,i,j,k,n,a[MAXN],f[MAXN][MAXK],temp;
int main()
{
cin>>T;
for (t=1;t<=T;t++)
{
cin>>k>>n;
for (i=1;i<=n;i++) cin>>a[i];
for (i=1;i<=n/2;i++)
{
temp=a[n+1-i];a[n+1-i]=a[i];a[i]=temp;
}
for (i=0;i<=n;i++) f[i][0]=0;
for (j=1;j<=k+8;j++)
{
f[j*3][j]=f[j*3-2][j-1]+sqr(a[j*3]-a[j*3-1]);
for (i=j*3+1;i<=n;i++)
f[i][j]=min(f[i-1][j],f[i-2][j-1]+sqr(a[i]-a[i-1]));
}
cout<<f[n][k+8]<<endl;
}
return 0;
}
相關文章
- HDU4689Derangement (動態規劃)動態規劃
- 動態規劃位置hdu 4540 威威貓系列故事——打地鼠(動態規劃)動態規劃
- 動態規劃 hdu 1260 Tickets動態規劃
- 動態規劃 hdu 1421 搬寢室動態規劃
- 動態規劃 hdu 1978 How many ways動態規劃
- hdu 1176 免費餡餅(動態規劃)動態規劃
- hdu1074動態規劃狀態壓縮動態規劃
- 【動態規劃(一)】動態規劃基礎動態規劃
- 動態規劃動態規劃
- 動態規劃分析動態規劃
- 動態規劃(DP)動態規劃
- 動態規劃初步動態規劃
- 模板 - 動態規劃動態規劃
- 動態規劃法動態規劃
- 演算法系列-動態規劃(1):初識動態規劃演算法動態規劃
- 淺談動態規劃動態規劃
- 有關動態規劃動態規劃
- 動態規劃小結動態規劃
- 動態規劃初級動態規劃
- 動態規劃講義動態規劃
- 好題——動態規劃動態規劃
- 3.動態規劃動態規劃
- 動態規劃-----線性動態規劃
- 動態規劃專題動態規劃
- 區間動態規劃動態規劃
- 動態規劃題單動態規劃
- 雙序列動態規劃動態規劃
- 動態規劃 總結動態規劃
- 動態規劃方法論動態規劃
- 動態規劃之數的劃分動態規劃
- 禮物的最大價值(一維動態規劃&二維動態規劃)動態規劃
- HDU 5375 Gray code(2015年多校聯合 動態規劃)動態規劃
- [leetcode] 動態規劃(Ⅰ)LeetCode動態規劃
- 動態規劃練習題動態規劃
- 關於動態規劃法動態規劃
- 動態規劃之理論分析動態規劃
- 斜率優化動態規劃優化動態規劃
- 【動態規劃】買賣股票動態規劃