HDU 5973-Game of Taking Stones(威佐夫博弈-JAVA BigDecimal)

kewlgrl發表於2017-05-02

Game of Taking Stones

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 459    Accepted Submission(s): 176


Problem Description
Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?
 

Input
Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.
 

Output
For each test data,output answer on one line.1 means you are the winner,otherwise output 0.
 

Sample Input
2 1 8 4 4 7
 

Sample Output
0 1 0
 

Source

威佐夫博弈的裸題,就是咳咳咳…資料量巨大,JAVA BigDecimal 可搞。

 要精確到小數點後100位,精度要求太高了∑(っ °Д °;)っ

這個黃金分割數×(b-a)後如果等於a,那麼為0,否則為1。(預設a<b)


import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;

public class Main
{

    public static BigDecimal setScaleRoundDown(int newScale, BigDecimal b)
    {
        return b.setScale(newScale, BigDecimal.ROUND_DOWN);
    }

    public static void main(String[] args)
    {
        Scanner cin=new Scanner(System.in);
        BigDecimal a,b,tmp,yi,er,x,tp,l;
        while(cin.hasNextBigDecimal())
        {
            a=cin.nextBigDecimal();
            b=cin.nextBigDecimal();
            l= new BigDecimal(String.valueOf("0"));
            if(a.compareTo(l)==0)
            {
                if(b.compareTo(l)==0)
                {
                    System.out.println("0");
                    continue;
                }
            }
            if(a.compareTo(b)==0)
            {
                System.out.println("1");
                continue;
            }
            if(a.compareTo(b)>0)
            {
                tp=a;
                a=b;
                b=tp;
            }
            x=b.subtract(a);
            tmp = new BigDecimal(String.valueOf("1.61803398874989484820458683436563811772030917980576286213544862270526046281890244970720720418939113748475408807"));
            tmp=tmp.multiply(x);
            //System.out.println(tmp);
            //tmp.setScale(0,BigDecimal.ROUND_DOWN);
            //System.out.println(setScaleRoundDown(0, tmp));
            if(setScaleRoundDown(0, tmp).compareTo((a))==0)
                System.out.println("0");
            else
            {
                System.out.println("1");
            }
        }
    }
}

 


相關文章