POJ 2774-Long Long Message(字尾陣列+高度陣列-最大公共子串長度)

kewlgrl發表於2017-04-22

Long Long Message
Time Limit: 4000MS   Memory Limit: 131072K
Total Submissions: 30192   Accepted: 12244
Case Time Limit: 1000MS

Description

The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother. 

The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon found out: 

1. All characters in messages are lowercase Latin letters, without punctuations and spaces. 
2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long. 
3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer. 
E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc. 
4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different. 

You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat. 

Background: 
The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be. 

Why ask you to write a program? There are four resions: 
1. The little cat is so busy these days with physics lessons; 
2. The little cat wants to keep what he said to his mother seceret; 
3. POJ is such a great Online Judge; 
4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :( 

Input

Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.

Output

A single line with a single integer number – what is the maximum length of the original text written by the little cat.

Sample Input

yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
yeaphowmuchiloveyoumydearmother

Sample Output

27

Source

POJ Monthly--2006.03.26,Zeyuan Zhu,"Dedicate to my great beloved mother."

題目意思:

計算兩個字串的最大公共子串長度。


解題思路:

字尾陣列+高度陣列模板題。

在兩個串之間插入一個不會再串中出現的字元拼接成一個新串S',計算高度陣列並求出其分屬於兩個不同串S和T時的最大值。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
typedef long long ll;
#define MAXN 200100
int n,k;
string s,t;
int sa[MAXN],lcp[MAXN];
int rank[MAXN*2],tmp[MAXN*2];
void construct_lcp(string s,int sa[],int lcp[])//計算高度陣列
{
    int n=s.length();
    for(int i=0; i<=n; ++i)
        rank[sa[i]]=i;
    int h=0;
    lcp[0]=0;
    for(int i=0; i<n; ++i)
    {
        int j=sa[rank[i]-1];
        if(h>0) --h;//先減去首字母的長度
        for(; j+h<n&&i+h<n; ++h)
            if(s[j+h]!=s[i+h]) break;//保證字首相同的前提下不斷增加
        lcp[rank[i]-1]=h;
    }
}
bool compare_sa(int i,int j)//倍增法,比較rank
{
    if(rank[i]!=rank[j]) return rank[i]<rank[j];
    else
    {
        int ri=i+k<=n?rank[i+k] :-1;
        int rj=j+k<=n?rank[j+k] :-1;
        return ri<rj;
    }
}

void construct_sa(string s,int sa[])//計算s的字尾陣列
{
    for(int i=0; i<=n; ++i)//初始長度為1,rank為字元編碼
    {
        sa[i]=i;
        rank[i]=i<n?s[i] :-1;
    }
    for(k=1; k<=n; k*=2)//倍增法求字尾陣列
    {
        sort(sa,sa+n+1,compare_sa);
        tmp[sa[0]]=0;
        for(int i=1; i<=n; ++i)
            tmp[sa[i]]=tmp[sa[i-1]]+(compare_sa(sa[i-1],sa[i])?1:0);
        for(int i=0; i<=n; ++i)
            rank[i]=tmp[i];
    }
}
bool contain(string s,int sa[],string t)
{
    int a=0,b=s.length();
    while(b-a>1)
    {
        int c=(a+b)/2;
        if(s.compare(sa[c],t.length(),t)<0) a=c;
        else b=c;
    }
    return s.compare(sa[b],t.length(),t)==0;
}
void solve()
{
    int sl=s.length();//原始串S的長度
    s+='\0'+t;//t串加入s串中
    n=s.length();
    construct_sa(s,sa);//計算字尾陣列
    construct_lcp(s,sa,lcp);//計算高度陣列
    int ans=0;
    for(int i=0; i<s.length(); ++i)//計算高度陣列的最大值
        if((sa[i]<sl)!=(sa[i+1]<sl))//注意判斷是否分屬於兩個不同字串
            ans=max(ans,lcp[i]);
    cout<<ans<<endl;
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    ios::sync_with_stdio(false);
    cin.tie(0);
    cin>>s;
    cin>>t;
    solve();
    return 0;
}


相關文章