POJ 3368-Frequent values(RMQ+離散化-最頻繁的元素)
Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 18533 | Accepted: 6692 |
Description
You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.
Input
The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an(-100000
≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two
integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the
query.
The last test case is followed by a line containing a single 0.
Output
For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.
Sample Input
10 3 -1 -1 1 1 1 1 3 10 10 10 2 3 1 10 5 10 0
Sample Output
1 4 3
Source
題目意思:
解題思路:
#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 100010
int r[MAXN];//元素個數
int dp[MAXN][20];
int n,q;
struct node
{
int x;//元素值
int pos;//離散化之後的元素位置
} a[MAXN];
void rmq()
{
int temp=(int)(log((double)n)/log(2.0));
for(int i=0; i<n; i++)
dp[i][0]=r[i];
for(int j=1; j<=temp; j++)
for(int i=0; i<=n-(1<<j); i++)
dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
}
int Maxmum(int s,int e)//計算s~e之間的最大元素
{
int k=(int)(log((double)e-s+1)/log(2.0));
return max(dp[s][k],dp[e-(1<<k)+1][k]);
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("G:/cbx/read.txt","r",stdin);
//freopen("G:/cbx/out.txt","w",stdout);
#endif
/*ios::sync_with_stdio(false);
cin.tie(0);
*/
while(cin>>n>>q)
{
if(n==0) break;
memset(a,0,sizeof(a));
memset(r,0,sizeof(r));
memset(dp,0,sizeof(dp));
scanf("%d",&a[0].x);
r[0]=1;
int cnt=0;//離散化的位置下標
for(int i=1; i<n; ++i)//下標0-n-1
{
scanf("%d",&a[i].x);
if(a[i].x==a[i-1].x)
{
r[i]=r[i-1]+1;//統計當前位置上的數出現了多少次
a[i].pos=cnt;//離散化
}
else
{
r[i]=1;
++cnt;//位置下標更新
a[i].pos=cnt;
}
}
rmq();//dp預處理
for(int i=0; i<q; ++i)
{
int s,e;
scanf("%d%d",&s,&e);
--s,--e;
if(a[s].pos==a[e].pos) printf("%d\n",e-s+1);//同一區間
else if(abs(a[s].pos-a[e].pos)==1)//相鄰區間
{
int t=s;
while(t<=e)//找到間隔點
{
if(a[t].pos!=a[t+1].pos) break;
++t;
}
printf("%d\n",max((t-s+1),r[e]));
}
else if(abs(a[s].pos-a[e].pos)>1)//不相鄰區間
{
int t=s;
while(t<=e)//找到最前面的一個區間的間隔點
{
if(a[t].pos!=a[t+1].pos) break;
++t;
}
printf("%d\n",max(t-s+1,Maxmum(t+1,e)));
}
}
}
return 0;
}
相關文章
- POJ 1418 圓的基本操作以及 圓弧離散化
- 離散化
- POJ 2528 Mayor's posters (線段樹 區間更新+離散化)
- POJ 2582 Mayor's posters 線段樹入門題+離散化
- POJ 2528 Mayor's posters (線段樹區間更新 + 離散化)
- [訊號處理小結系列4]最頻繁…
- 開發小程式被問到最頻繁的問題(上)
- 【離散優化】覆蓋問題優化
- 二維座標離散化模板
- 連續特徵離散化和歸一化特徵
- 【dp+離散化+線段樹優化】Paint優化AI
- 離散化的一道很經典的題
- 離散請求
- hdu4325 樹狀陣列+離散化陣列
- 出海遊戲頻繁衝入日韓前十 樂元素日本再突破遊戲
- 如何處理頻繁建立物件然後丟棄導致頻繁GC的情況物件GC
- 離散傅立葉變換的衍生,負頻率、fftshift、實訊號、共軛對稱FFT
- IT頻繁跳槽不是錯薦
- POJ 3368 Frequent values (UVA 11235)(RMQ)MQ
- 二維字首和與差分、離散化技巧
- 離散傅立葉變換
- 運籌優化(十四)--離散優化的啟發式演算法優化演算法
- ORACLE中seq$表更新頻繁的分析Oracle
- 【scikit-learn基礎】--『預處理』之 離散化
- OpenCV 離散傅立葉變換OpenCV
- Shiro效能優化:解決Session頻繁讀寫問題優化Session
- 離散數學——4.命題邏輯公式的正規化公式
- 禁止頻繁請求的ip訪問nginxNginx
- BZOJ 4195 程式自動分析【並查集+離散化】並查集
- WPF頻繁更新UI卡頓問題UI
- 域賬戶頻繁鎖定排查
- 離散傅立葉變換DFT的應用
- Trustwave:研究稱電子郵件病毒木馬在早晨活動最為頻繁Rust
- 離散漸進模型(轉載)模型
- 與遊戲頻繁掛鉤的SCP是什麼?遊戲
- windows7 頻繁當機的解決方法Windows
- 列表分割槽ADD VALUES或DROP VALUES包含資料變化的情況
- REDIS主從頻繁切換事件排查Redis事件