POJ 3368-Frequent values(RMQ+離散化-最頻繁的元素)

kewlgrl發表於2017-04-12
Frequent values
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 18533   Accepted: 6692

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an(-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source


題目意思:

有N個升序排列好的元素,Q個查詢,計算區間下標S~E之間出現最頻繁的元素出現的次數。

解題思路:

分類在RMQ下面,有點懵,參考了大神的題解之後才明白……
首先用結構體儲存元素值X,根據元素值的不同,將同一個值用一個POS下標記錄:
-1 -1 1 1 1 1 3 10 10 10 就被記錄為 0 0 1 1 1 1 2 3 3 3 

然後對元素進行離散化,用一個新的陣列R記錄每個元素當前出現的次數:
-1 -1 1 1 1 1 3 10 10 10 就被記錄為 1 2 1 2 3 4 1 1 2 3 

對於查詢區間S~E分三種情況討論:
①同一區間:
POS相同即為同一區間,此時S~E區間內的元素個數e-s+1就是最大次數。
②相鄰區間:
POS相差為1即為相鄰區間,此時需要先找到兩個區間的分隔點T(包含在前一區間內),對第一個區間來說,區間內的元素個數T-S+1是最大次數;對第二個區間來說,最後一個元素出現的次數R[e]就是最大次數;對這兩個值取MAX。
③不相鄰區間(用到RMQ):
與相鄰區間相似,因為除了第一個區間以外,對於後面所有元素來說,使用RMQ處理R陣列,則Maxmum(T+1,E)就是後面區間的最大次數;然後再按②的方法單獨處理第一個區間求出最大次數T-S+1,對這兩個值取MAX。

#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 100010
int r[MAXN];//元素個數
int dp[MAXN][20];
int n,q;
struct node
{
    int x;//元素值
    int pos;//離散化之後的元素位置
} a[MAXN];
void rmq()
{
    int temp=(int)(log((double)n)/log(2.0));
    for(int i=0; i<n; i++)
        dp[i][0]=r[i];
    for(int j=1; j<=temp; j++)
        for(int i=0; i<=n-(1<<j); i++)
            dp[i][j]=max(dp[i][j-1],dp[i+(1<<(j-1))][j-1]);
}

int Maxmum(int s,int e)//計算s~e之間的最大元素
{
    int k=(int)(log((double)e-s+1)/log(2.0));
    return max(dp[s][k],dp[e-(1<<k)+1][k]);
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
    //freopen("G:/cbx/out.txt","w",stdout);
#endif
    /*ios::sync_with_stdio(false);
    cin.tie(0);
    */
    while(cin>>n>>q)
    {
        if(n==0) break;
        memset(a,0,sizeof(a));
        memset(r,0,sizeof(r));
        memset(dp,0,sizeof(dp));
        scanf("%d",&a[0].x);
        r[0]=1;
        int cnt=0;//離散化的位置下標
        for(int i=1; i<n; ++i)//下標0-n-1
        {
            scanf("%d",&a[i].x);
            if(a[i].x==a[i-1].x)
            {
                r[i]=r[i-1]+1;//統計當前位置上的數出現了多少次
                a[i].pos=cnt;//離散化
            }
            else
            {
                r[i]=1;
                ++cnt;//位置下標更新
                a[i].pos=cnt;
            }
        }
        rmq();//dp預處理
        for(int i=0; i<q; ++i)
        {
            int s,e;
            scanf("%d%d",&s,&e);
            --s,--e;
            if(a[s].pos==a[e].pos)  printf("%d\n",e-s+1);//同一區間
            else if(abs(a[s].pos-a[e].pos)==1)//相鄰區間
            {
                int t=s;
                while(t<=e)//找到間隔點
                {
                    if(a[t].pos!=a[t+1].pos) break;
                    ++t;
                }
                printf("%d\n",max((t-s+1),r[e]));
            }
            else if(abs(a[s].pos-a[e].pos)>1)//不相鄰區間
            {
                int t=s;
                while(t<=e)//找到最前面的一個區間的間隔點
                {
                    if(a[t].pos!=a[t+1].pos) break;
                    ++t;
                }
                printf("%d\n",max(t-s+1,Maxmum(t+1,e)));
            }
        }
    }
    return 0;
}



相關文章