POJ 3684-Labeling Balls(反向拓撲排序-按條件排序輸出重量)

kewlgrl發表於2017-03-31
Labeling Balls
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 14408   Accepted: 4213

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source


題目意思:

N個瓶子重量為1~N,給它們貼上1~N的標籤(隨機,未按重量貼標籤),給出M個條件A B指出標籤為A的瓶子重量小於標籤為B的瓶子,計算按順序並給出1~N號瓶子的重量。

解題思路:

優先佇列+反向拓撲+逆序輸出,建議先搞一搞HDU 4857
這題的坑點就是要輸出的不是重量由小到大瓶子的標籤號,而是按順序並給出1~N號瓶子的重量,所以在計算出重量順序後再用一個陣列記錄1~N的重量後輸出。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<set>
#include<cstdlib>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
#define MAXN 100010
#define INF 0x3f3f3f3f
int n,m;
int indegree[MAXN];
vector<int> v[MAXN];
struct cmp
{
    bool operator()(const int &a,const int &b)
    {
        return a<b;//從大到小
    }
};

void Topsort()//拓撲排序
{
    priority_queue<int,vector<int>,cmp> q;
    int p[MAXN];
    int ip=0;
    memset(p,0,sizeof(p));
    for(int i=0; i<n; i++)
        if(indegree[i]==0)
            q.push(i);
    while(!q.empty())
    {
        int temp=q.top();
        p[++ip]=temp;
        q.pop();
        for(int i=0; i<v[temp].size(); i++)
        {
            indegree[v[temp][i]]--;
            if(indegree[v[temp][i]]==0)
                q.push(v[temp][i]);
        }
    }
    int ans[MAXN];
    if(ip<n) printf("-1\n");
    else
    {
        int cnt=1;
        for(int i=ip; i>=1; --i)//重量大小應當逆向輸出
            ans[p[i]+1]=cnt++;//記錄1~N的重量
        for(int i=1; i<cnt-1; ++i)
            printf("%d ",ans[i]);
        printf("%d\n",ans[cnt-1]);
    }
}
int main()
{
#ifdef ONLINE_JUDGE
#else
    freopen("G:/cbx/read.txt","r",stdin);
//freopen("G:/cbx/out.txt","w",stdout);
#endif
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        for(int i=0; i<=n; i++) v[i].clear();//注意初始化清空
        memset(indegree,0,sizeof(indegree));
        for(int i=0; i<m; ++i)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            --a,--b;
            v[b].push_back(a);//逆向建圖
            ++indegree[a];
        }
        Topsort();
    }
    return 0;
}


相關文章