POJ 1850 Code/POJ 1496 Word Index(組合數學-字母串序號)
Code
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 9645 | Accepted: 4617 |
Description
Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made
only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character).
The coding system works like this:
• The words are arranged in the increasing order of their length.
• The words with the same length are arranged in lexicographical order (the order from the dictionary).
• We codify these words by their numbering, starting with a, as follows:
a - 1
b - 2
...
z - 26
ab - 27
...
az - 51
bc - 52
...
vwxyz - 83681
...
Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.
The coding system works like this:
• The words are arranged in the increasing order of their length.
• The words with the same length are arranged in lexicographical order (the order from the dictionary).
• We codify these words by their numbering, starting with a, as follows:
a - 1
b - 2
...
z - 26
ab - 27
...
az - 51
bc - 52
...
vwxyz - 83681
...
Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code.
Input
The only line contains a word. There are some constraints:
• The word is maximum 10 letters length
• The English alphabet has 26 characters.
• The word is maximum 10 letters length
• The English alphabet has 26 characters.
Output
The output will contain the code of the given word, or 0 if the word can not be codified.
Sample Input
bf
Sample Output
55
Source
題目意思:
有一個使用26個小寫字母a~z的編碼系統的工作原理如下:
•單詞按其長度的遞增順序排列。
•具有相同長度的詞按詞典順序排列(來自字典的順序)。
•我們通過編號將這些詞編碼,從a開始,如下:
a-1
b-2
... ...
z-26
ab-27
... ...
az-51
bc-52
... ...
vwxyz - 83681
... ...
如果可以根據該編碼系統編碼,則輸出給定字及其程式碼,否則輸出0。
•單詞按其長度的遞增順序排列。
•具有相同長度的詞按詞典順序排列(來自字典的順序)。
•我們通過編號將這些詞編碼,從a開始,如下:
a-1
b-2
... ...
z-26
ab-27
... ...
az-51
bc-52
... ...
vwxyz - 83681
... ...
如果可以根據該編碼系統編碼,則輸出給定字及其程式碼,否則輸出0。
解題思路:
規律是:n位字串的所有情況是C(26,n)。
對於給出的n位字串,先利用規律求出其n-1位的編碼,然後遍歷字串每一位累加計算編碼。
#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
#include<vector>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f
#define MAXN 30
int vis[MAXN][MAXN];//用於記憶化搜尋,vis[i][j]表示組合數C(i,j)的值
string s;//輸入串
int len;//串的長度
int c(int x,int y)//計算組合數C(x,y)
{
int s=1,i,j;
for (i=y+1, j=1; i<=x; i++,j++)
s=s*i/j;
return s;
}
void solve()
{
memset(vis,-1,sizeof(vis));
int ans=0;
for(int i=1; i<=len-1; ++i)//計算len-1位的大小
{
if(vis[26][i]!=-1)//已經計算過
ans+=vis[26][i];
else//未計算
{
vis[26][i]=c(26,i);
ans+=vis[26][i];
}
}
for(int i=0; i<len; ++i)//計算len位中當前串的大小
{
char t;
if(i==0) t='a';//首字元從a開始計算
else t=s[i-1]+1;//後面的字元從前一個字元的後一位開始計算
while(t<s[i])//一直計算到當前字元
{
if(vis['z'-t][len-1-i]!=-1)
ans+=vis['z'-t][len-1-i];
else
{
vis['z'-t][len-1-i]=c('z'-t,len-1-i);
ans+=vis['z'-t][len-1-i];
}
++t;//後一個字母
}
}
cout<<++ans<<endl;
}
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
while(cin>>s)
{
bool flag=false;//是否升序
len=s.size();
for(int i=1; i<len; ++i)
if(s[i-1]>s[i])
{
flag=true;//存在降序
break;
}
if(flag) cout<<"0"<<endl;//字串非法
else solve();//字串合法
}
return 0;
}
相關文章
- 【POJ 2249】 Binomial Showdown 組合數學 排列組合計算
- POJ-2136 Vertical Histogram-用*號統計字母個數Histogram
- POJ 1664 放蘋果 (基礎組合dp)蘋果
- POJ-1961 Period-KMP字首串重複次數KMP
- leetcode日記17. 電話號碼的字母組合LeetCode
- 【leetcode】22. Generate Parentheses 合法括號串的所有組合LeetCode
- 17_電話號碼的字母組合
- 【數學】組合數學 - 排列組合
- 演算法學習之路|POJ-2479最大子串和(簡單dp)演算法
- poj3080-kmp+列舉子串 求最長公共子串KMP
- 17. 電話號碼的字母組合-c++C++
- POJ 3294 Life Forms(字尾陣列求k個串的最長子串)ORM陣列
- POJ 1068-Parencodings(模擬-包含括號個數)Encoding
- [LeetCode] Letter Combinations of a Phone Number 電話號碼的字母組合LeetCode
- 組合數學
- POJ-2192 Zipper-順序合成串匹配
- POJ 2955-Brackets(括號匹配-區間DP)Racket
- JS對錶格排序(支援對序號,數字,字母,日期)JS排序
- POJ 3461 kmpKMP
- poj3417
- 《小 學 組 合 數 學》
- POJ 1113 Wall(思維 計算幾何 數學)
- POJ1019 NumberSequence 【數學公式轉化題】公式
- 2951 星號組成字母E
- Python識別字母數字組合驗證碼Python
- JavaScript數字和字母組合驗證碼詳解JavaScript
- [CareerCup] 9.3 Magic Index 魔法序號Index
- 【數學】組合數學 - 卡特蘭數
- 組合數學筆記-排列與組合筆記
- pair 和 map結合應用——POJ 3096AI
- POJ3321 Apple Tree(DFS序 + 樹狀陣列)APP陣列
- Flip Game(POJ 1753)GAM
- POJ 2431 Expedition
- POJ3259-WormholesWorm
- POJ 3414 Pots
- POJ 3904 Sky Code (容斥+莫比烏斯反演)
- 【組合數學】組合數學簡介 ( 組合思想 2 : 數學歸納法 | 數學歸納法推廣 | 多重歸納思想 )
- CodeForces571A. Lengthening Sticks(組合數學-容斥)