POJ 1276-Cash Machine(多重部分和-dp)
Cash Machine
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 34117 | Accepted: 12362 |
Description
A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply
of nk bills. For example,
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10
means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.
Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.
Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:
cash N n1 D1 n2 D2 ... nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
cash N n1 D1 n2 D2 ... nN DN
where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3 4 125 6 5 3 350 633 4 500 30 6 100 1 5 0 1 735 0 0 3 10 100 10 50 10 10
Sample Output
735 630 0 0
Hint
The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.
In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.
Source
題目意思:
現金cash元,有N種零錢,依次給出數量及其面值。求出用這些零錢能夠換零的不超過cash的最大金額。
解題思路:
多重部分和的模板,dp[i]儲存的是能否得到金額i,不小於零時表示能夠得到。然後從cash往下列舉dp陣列,一旦滿足就輸出i。
因為用二維dp陣列過大,所以使用一維重複利用。
#include<iostream>
#include<cstdio>
#include<iomanip>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<map>
#include<algorithm>
using namespace std;
#define INF 0xfffffff
#define MAXN 100005
int a[MAXN],m[MAXN];
int cash,n;
void init()
{
memset(dp,-1,sizeof(dp));
memset(a,0,sizeof(a));
memset(m,0,sizeof(m));
}
int dp[MAXN];
void solve()
{
dp[0]=0;
int i,j;
for(i=0; i<n; ++i)
for(j=0; j<=cash; ++j)
{
if(dp[j]>=0) dp[j]=m[i];
else if(j<a[i]||dp[j-a[i]]<=0) dp[j]=-1;
else dp[j]=dp[j-a[i]]-1;
}
for(int i=cash; i>=0; --i)//從cash往下列舉
if(dp[i]>=0)
{
cout<<i<<endl;
break;
}
}
int main()
{
#ifdef ONLINE_JUDGE
#else
freopen("F:/cb/read.txt","r",stdin);
//freopen("F:/cb/out.txt","w",stdout);
#endif
while(~scanf("%d%d",&cash,&n))
{
init();
for(int i=0; i<n; ++i)
cin>>m[i]>>a[i];
solve();
}
return 0;
}
/*
735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10
*/
相關文章
- POJ1276Cash Machine[多重揹包可行性]Mac
- poj 1276 Cash MachineMac
- POJ1745Divisibility(dp)
- POJ2955 Brackets (區間DP)Racket
- 【BZOJ 5003】與鏈 (多重揹包 dp)
- POJ 2486 Apple Tree(樹形dp)APP
- POJ 1925 Spiderman(線性dp)IDE
- POJ 3744 概率dp+矩陣矩陣
- HDU 5067 Harry And Dig Machine(狀壓dp)Mac
- POJ1160 Post Office[序列DP]
- 【dp】POJ 1015 Jury CompromisePromise
- POJ 3249-Test for Job(拓撲排序&&DP)排序
- POJ 3107 Godfather(樹形dp)Go
- POJ 3017 單調佇列dp佇列
- POJ 3691 DNA repair (AC自動機 + dp)AI
- 【樹形dp】poj 1947 Rebuilding RoadsRebuild
- poj 1180 dp的斜率優化優化
- POJ 1664 放蘋果 (基礎組合dp)蘋果
- POJ 2955-Brackets(括號匹配-區間DP)Racket
- poj3017 dp+單調佇列佇列
- POJ2184 Cow Exhibition[DP 狀態負值]
- POJ 3254 Corn Fields:網格密鋪類 狀壓dp
- POJ 1141 Brackets Sequence(記錄路徑的dp)Racket
- POJ 1325-Machine Schedule(二分圖匹配-匈牙利演算法)Mac演算法
- 藍橋杯,推導部分和
- 「暑期訓練」「基礎DP」 Common Subsequence (POJ-1458)
- POJ3107Godfather[樹形DP 樹的重心]Go
- POJ 1947 Rebuilding Roads(基礎的樹形dp)Rebuild
- POJ3744 Scout YYF I (概率DP + 矩陣優化)矩陣優化
- NOIP2012pj擺花[DP 多重揹包方案數]
- poj1276 多重揹包問題(二進位制解決方案)
- POJ 2411 Mondriaan's Dream:網格密鋪類 狀壓dp
- POJ1141 ZOJ1463 Brackets Sequence【區間dp】Racket
- POJ 3373 Changing Digits(記錄路徑的dp)Git
- POJ 3034 Whac-a-Mole(三維dp+處理小技巧)
- 演算法學習之路|POJ-2479最大子串和(簡單dp)演算法
- dp 套 dp(dp of dp)小記
- poj1179 區間dp(記憶化搜尋寫法)有巨坑!