POJ 1442-Black Box(動態區間第K小-優先佇列)
Black Box
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 12404 | Accepted: 5088 |
Description
Our Black Box represents a primitive database. It can save an integer array and has a special i variable. At the initial moment Black Box is empty and i equals 0. This Black Box processes a sequence of commands (transactions). There are two types of transactions:
ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.
Let us examine a possible sequence of 11 transactions:
Example 1
It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.
Let us describe the sequence of transactions by two integer arrays:
1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).
2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).
The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.
ADD (x): put element x into Black Box;
GET: increase i by 1 and give an i-minimum out of all integers containing in the Black Box. Keep in mind that i-minimum is a number located at i-th place after Black Box elements sorting by non- descending.
Let us examine a possible sequence of 11 transactions:
Example 1
N Transaction i Black Box contents after transaction Answer (elements are arranged by non-descending) 1 ADD(3) 0 3 2 GET 1 3 3 3 ADD(1) 1 1, 3 4 GET 2 1, 3 3 5 ADD(-4) 2 -4, 1, 3 6 ADD(2) 2 -4, 1, 2, 3 7 ADD(8) 2 -4, 1, 2, 3, 8 8 ADD(-1000) 2 -1000, -4, 1, 2, 3, 8 9 GET 3 -1000, -4, 1, 2, 3, 8 1 10 GET 4 -1000, -4, 1, 2, 3, 8 2 11 ADD(2) 4 -1000, -4, 1, 2, 2, 3, 8
It is required to work out an efficient algorithm which treats a given sequence of transactions. The maximum number of ADD and GET transactions: 30000 of each type.
Let us describe the sequence of transactions by two integer arrays:
1. A(1), A(2), ..., A(M): a sequence of elements which are being included into Black Box. A values are integers not exceeding 2 000 000 000 by their absolute value, M <= 30000. For the Example we have A=(3, 1, -4, 2, 8, -1000, 2).
2. u(1), u(2), ..., u(N): a sequence setting a number of elements which are being included into Black Box at the moment of first, second, ... and N-transaction GET. For the Example we have u=(1, 2, 6, 6).
The Black Box algorithm supposes that natural number sequence u(1), u(2), ..., u(N) is sorted in non-descending order, N <= M and for each p (1 <= p <= N) an inequality p <= u(p) <= M is valid. It follows from the fact that for the p-element of our u sequence we perform a GET transaction giving p-minimum number from our A(1), A(2), ..., A(u(p)) sequence.
Input
Input contains (in given order): M, N, A(1), A(2), ..., A(M), u(1), u(2), ..., u(N). All numbers are divided by spaces and (or) carriage return characters.
Output
Write to the output Black Box answers sequence for a given sequence of transactions, one number each line.
Sample Input
7 4 3 1 -4 2 8 -1000 2 1 2 6 6
Sample Output
3 3 1 2
Source
題目意思:
初始情況下,序列中沒有任何元素(題中序列第一個元素K表示要GET的第K小元素,不算是序列中的元素)。
ADD(X)是將元素X加入序列中;GET是將K加一後,從序列中取出第K小元素。
給出M個A陣列中的元素,表示ADD中的X;N個U陣列中的元素,表示當前序列中的元素總個數。
要求出每次GET從序列中取出第K小元素。
解題思路:
q是最大堆的優先佇列,儲存序列的最小元素到序列的第K小元素;
p是最小堆的優先佇列,儲存序列的第K+1小元素到序列的最大元素。
壓入元素:
遍歷U陣列,確定當前A陣列中要壓入佇列的元素個數,分情況討論:
①q中元素不足k個
注意這裡不是直接將元素壓入q,而是先將元素壓入p,再從q裡取出最小值壓入q。
②q中元素大於等於k個
1’:當前要壓入的元素比q的最大值小,q的最大值壓入p後出隊,當前元素壓入q;
2’:當前要壓入的元素比q的最大值大(或等於),直接將當前元素壓入q。
輸出元素:
如果q陣列中元素個數小於k,依次將p的隊首元素壓入q,直到q陣列中元素個數等於k。
否則直接輸出q的隊首元素。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
const int MAXN=30030;
int a[MAXN],u[MAXN];
using namespace std;
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
int m,n;
cin>>m>>n;
for(int i=0; i<m; ++i)
cin>>a[i];
for(int i=0; i<n; ++i)
cin>>u[i];
priority_queue<int,vector<int>,greater<int> >p;//最小值優先
priority_queue<int>q;//最大值優先
int k=0,ac=0;//第k小、a陣列中的指標
for(int i=0; i<n; ++i)//遍歷u陣列
{
++k;
int ps=p.size(),qs=q.size();
for(int j=0; j<u[i]-ps-qs; ++j)//向佇列中壓入的a陣列的元素個數
{
if(q.size()<k)//q中元素不足k個
{
//先將元素壓入p,再從q裡取出最小值壓入q
p.push(a[ac]);
q.push(p.top());
p.pop();
++ac;
}
else//q中元素大於k個
{
if(q.top()>a[ac])//當前要壓入的元素比q的最大值小
{
//q的最大值壓入p後出隊,當前元素壓入q
p.push(q.top());
q.pop();
q.push(a[ac]);
++ac;
}
else//當前要壓入的元素比q的最大值大
{
//直接將當前元素壓入q
p.push(a[ac]);
++ac;
}
}
}
if(q.size()<k)//如果q陣列中元素個數小於k
{
//依次將p的隊首元素壓入q,直到q陣列中元素個數等於k
int temp=k-q.size();//需要壓入q的元素個數
for(int j=0; j<temp; ++j)
{
q.push(p.top());
p.pop();
}
}
cout<<q.top()<<endl;
}
return 0;
}
/*
7 4
3 1 -4 2 8 -1000 2
1 2 6 6
*/
相關文章
- POJ 3253 Fence Repair 優先佇列AI佇列
- POJ 1724 ROADS(優先佇列+spfa)佇列
- POJ2431 Expedition (優先佇列)佇列
- POJ 2051(最小堆/優先佇列)佇列
- hdu 4546 優先佇列 數列組合和第m小佇列
- POJ 3253Fence Repair(哈夫曼&優先佇列)AI佇列
- 找最小的k個數(優先佇列)佇列
- Sunscreen POJ - 3614(防曬油) 貪心-優先佇列佇列
- PHP優先佇列PHP佇列
- 堆--優先佇列佇列
- 優先佇列 (轉)佇列
- 淺談優先佇列佇列
- STL 優先佇列 用法佇列
- 堆與優先佇列佇列
- 堆和優先佇列佇列
- 優先佇列的學習記錄--例題:Expedition(POJ2431)佇列
- POJ 3253-Fence Repair(哈夫曼樹-最小值優先佇列)AI佇列
- 優先佇列和堆排序佇列排序
- 堆排序與優先佇列排序佇列
- Java優先佇列(PriorityQueue)示例Java佇列
- 01揹包優先佇列優化佇列優化
- 棧,佇列,優先順序佇列簡單介面使用佇列
- Redis實現任務佇列、優先順序佇列Redis佇列
- NO GAME NO LIFE(優先佇列/最小堆)GAM佇列
- 優先佇列的比較器佇列
- 封裝優先順序佇列封裝佇列
- 二叉堆優先佇列佇列
- 堆——神奇的優先佇列(上)佇列
- 優先佇列的效能測試佇列
- hdu5040 優先佇列+bfs佇列
- 佇列 優先順序佇列 python 程式碼實現佇列Python
- 演算法面試(三) 優先佇列演算法面試佇列
- STL優先佇列最小堆最大堆佇列
- STL醜數(set+優先佇列)佇列
- 【圖論】拓撲排序+優先佇列圖論排序佇列
- 1007(優先佇列)佇列
- 三、資料結構演算法-棧、佇列、優先佇列、雙端佇列資料結構演算法佇列
- .NET 6 優先佇列 PriorityQueue 實現分析佇列