POJ 3253-Fence Repair(哈夫曼樹-最小值優先佇列)

kewlgrl發表於2017-01-28
Fence Repair
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 44152   Accepted: 14405

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

Source


題目意思:

給出一塊木板上的N個切口將木板分割的大小,切割的費用是將木板分成兩段後這兩段的長度之和。
求最小費用。

解題思路:

哈夫曼樹,每次取兩個最小的,直到剩下最後一個元素。
使用最小堆的優先佇列最方便,也可以暴力解決。

priority_queue呼叫 STL裡面的 make_heap(), pop_heap(), push_heap() 演算法實現,也算是堆的另外一種形式。先寫一個用 STL 裡面堆演算法實現的與真正的STL裡面的 priority_queue用法相似的priority_queue, 以加深對 priority_queue 的理解

#include <iostream>
#include <algorithm>
#include <vector>
 
using namespace std;
 
class priority_queue
{
    private:
        vector<int> data;
         
    public:
        void push( int t ){
            data.push_back(t);
            push_heap( data.begin(), data.end());
        }
         
        void pop(){
            pop_heap( data.begin(), data.end() );
            data.pop_back();
        }
         
        int top() { return data.front(); }
        int size() { return data.size(); }
        bool empty() { return data.empty(); }
};
 
 
int main()
{
    priority_queue test;
    test.push( 3 );
    test.push( 5 );
    test.push( 2 );
    test.push( 4 );
     
    while( !test.empty() ){
        cout << test.top() << endl;
        test.pop(); }
         
    return 0;
 
}
 
STL裡面的 priority_queue 寫法與此相似,只是增加了模板及相關的迭代器什麼的。 

priority_queue 對於基本型別的使用方法相對簡單。他的模板宣告帶有三個引數:
priority_queue<Type, Container, Functional>

其中Type 為資料型別, Container 為儲存資料的容器,Functional 為元素比較方式。
Container 必須是用陣列實現的容器,比如 vector, deque 但不能用 list.
STL裡面預設用的是 vector. 比較方式預設用 operator< , 所以如果你把後面倆個引數預設的話,
優先佇列就是大頂堆,隊頭元素最大。
 
#include <iostream>
#include <queue>
 
using namespace std;
 
int main(){
    priority_queue<int> q;
     
    for( int i= 0; i< 10; ++i ) q.push( rand() );
    while( !q.empty() ){
        cout << q.top() << endl;
        q.pop();
    }
     
    getchar();
    return 0;
}
 
如果要用到小頂堆,則一般要把模板的三個引數都帶進去。
STL裡面定義了一個仿函式 greater<>,對於基本型別可以用這個仿函式宣告小頂堆
 
#include <iostream>
#include <queue>
 
using namespace std;
 
int main(){
    priority_queue<int, vector<int>, greater<int> > q;
     
    for( int i= 0; i< 10; ++i ) q.push( rand() );
    while( !q.empty() ){
        cout << q.top() << endl;
        q.pop();
    }
     
    getchar();
    return 0;
}

 

對於自定義型別,則必須自己過載 operator< 或者自己寫仿函式
 
#include <iostream>
#include <queue>
 
using namespace std;
 
struct Node{
    int x, y;
    Node( int a= 0, int b= 0 ):
        x(a), y(b) {}
};
 
bool operator<( Node a, Node b ){
    if( a.x== b.x ) return a.y> b.y;
    return a.x> b.x;
}
 
int main(){
    priority_queue<Node> q;
     
    for( int i= 0; i< 10; ++i )
    q.push( Node( rand(), rand() ) );
     
    while( !q.empty() ){
        cout << q.top().x << ' ' << q.top().y << endl;
        q.pop();
    }
     
    getchar();
    return 0;
}

自定義型別過載 operator< 後,宣告物件時就可以只帶一個模板引數。
但此時不能像基本型別這樣宣告
priority_queue<Node, vector<Node>, greater<Node> >;
原因是 greater<Node> 沒有定義,如果想用這種方法定義則可以按如下方式:
 
#include <iostream>
#include <queue>
 
using namespace std;
 
struct Node{
    int x, y;
    Node( int a= 0, int b= 0 ):
        x(a), y(b) {}
};
 
struct cmp{
    bool operator() ( Node a, Node b ){
        if( a.x== b.x ) return a.y> b.y;
         
        return a.x> b.x; }
};
 
int main(){
    priority_queue<Node, vector<Node>, cmp> q;
     
    for( int i= 0; i< 10; ++i )
    q.push( Node( rand(), rand() ) );
     
    while( !q.empty() ){
        cout << q.top().x << ' ' << q.top().y << endl;
        q.pop();
    }
     
    getchar();
    return 0;
}
 
 
//以上程式碼實現的是一個小頂堆

轉載:http://blog.chinaunix.net/space.php?uid=533684&do=blog&cuid=2615612

ps:如果過載operator > 可直接使用priority_queue<Node,vector<Node>,greater<Node>>


#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>

using namespace std;
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int n;
    while(cin>>n)
    {
        long long ans=0,a,b;//結果可能長達長整型
        int s;
        priority_queue<int,vector<int>,greater<int> >que;//最小值優先
        for(int i=0; i<n; ++i)
        {
            cin>>s;//讀取初值
            que.push(s);
        }
        if(que.size()==1)//特判只有1個元素的情況
            ans=que.top();
        else
            while(que.size()>1)
            {
                a=que.top();//取出最小的兩個值,然後將其出棧
                que.pop();
                b=que.top();
                que.pop();
                ans+=(a+b);
                que.push(a+b);//注意是兩值之和入棧而不是ans
            }
        cout<<ans<<endl;
    }
    return 0;
}
/*
3
8
5
8
*/


相關文章