POJ 1068-Parencodings(模擬-包含括號個數)

kewlgrl發表於2017-01-19
Parencodings
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 25510   Accepted: 15016

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source


題目意思:

S		(((()()())))  括號表示

P-sequence	4 5 6 6 6 6   每個右括號前面的左括號數目

W-sequence	1 1 1 4 5 6   每對括號所包含的括號對數(包括其自身)
給出P序列,求其W序列。

解題思路:

必須先提醒一句,這題的測試資料中,n肯定大於20(雖然給的範圍到20),一開始開到21,直接RE…Orz
首先根據P序列還原出S序列:P[i]-P[i-1]是當前應在一個右括號前面插入的左括號數;
然後從前往後掃出未匹配的第一個右括號,再從當前位置往前掃出未匹配的第一個左括號;
最後在當前匹配的左右括號之間掃描已經匹配的括號數目,依次++即可。


#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
struct N
{
    char c;//儲存'('或')'
    bool vis;//判斷是否被訪問
    int num;//c==')'時記錄其包含的括號數
} node[101];

int a[101];//坑爹測試資料,開21果斷RE…
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        memset(a,0,sizeof(a));
        cin>>a[0];
        int cnt=0;
        for(int i=0; i<a[0]; ++i)//根據輸入還原S(即括號表示)並初始化
        {
            node[cnt].c='(';
            node[cnt].vis=false;
            node[cnt++].num=0;
        }
        node[cnt].c=')';
        node[cnt].vis=false;
        node[cnt++].num=0;
        for(int i=1; i<n; ++i)
        {
            cin>>a[i];
            for(int j=0; j<a[i]-a[i-1]; ++j)
            {
                node[cnt].c='(';
                node[cnt].vis=false;
                node[cnt++].num=0;
            }
            node[cnt].c=')';
            node[cnt].vis=false;
            node[cnt++].num=0;
        }
        /*for(int i=0; i<cnt; ++i)//輸出S
            cout<<node[i].c<<" ";
        cout<<endl;*/
        bool flag=true;//判斷當前是否仍有未匹配的括號
        while(flag)
        {
            flag=false;
            for(int i=1; i<cnt; ++i)//右括號‘)’
                if(node[i].c==')'&&node[i].vis==false)
                    for(int j=i-1; j>=0; --j)//左括號‘(’
                        if(node[j].c=='('&&node[j].vis==false)
                        {
                            node[j].vis=node[i].vis=true;
                            node[i].num=1;
                            flag=true;
                            int k;
                            for(k=j; k<i; ++k)
                                if(node[k].c==')'&&node[k].vis==true)
                                    ++node[i].num;//計算包含的括號數
                            break;
                        }
        }
        for(int i=0; i<cnt; ++i)
            if(node[i].c==')')
                cout<<node[i].num<<" ";
        cout<<endl;
    }
    return 0;
}
/*
2
6
4 5 6 6 6 6
9
4 6 6 6 6 8 9 9 9
*/


相關文章