POJ 1113-Wall(凸包-Graham演算法)

kewlgrl發表於2016-09-21
Wall
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 35509   Accepted: 12107

Description

Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall. 

Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements. 

The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

Input

The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle. 

Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

Output

Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

Sample Input

9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200

Sample Output

1628

Hint

結果四捨五入就可以了

Source


題目意思:

給出國王的N個城堡的座標,圍牆裡城堡距離至少L,求最小的圍牆長度,使得能把所有城堡包圍起來。

解題思路:

求城堡的凸包。注意:凸包頂點拐角處是圓弧不是直角,所以每個頂點圓弧的長度之和為一整個圓的周長。
先兩兩點計算距離,再加上圓周長,最後四捨五入即可。

(因為沒注意到top比凸包點數多一光榮貢獻兩血……)
#include<cstdio>
#include<iostream>
#include<vector>
#include<cmath>
#include<cstring>
#include<queue>
#include<algorithm>
#include<set>
#include<queue>
#define INF 0xfffffff
const int MAXN = 1010;
using namespace std;
const double eps = 1e-8;
const double PI = acos(-1.0);
int sgn(double x)
{
    if(fabs(x) < eps)return 0;
    if(x < 0)return -1;
    else return 1;
}

struct Point
{
    double x,y;
    Point() {}  Point(double _x,double _y)
    {
        x = _x;
        y = _y;
    }
    Point operator -(const Point &b)const
    {
        return Point(x - b.x,y - b.y);
    }  //叉積
    double operator ^(const Point &b)const
    {
        return x*b.y - y*b.x;     //點積
    }
    double operator *(const Point &b)const
    {
        return x*b.x + y*b.y;     //繞原點旋轉角度B(弧度值),後x,y的變化
    }
    void transXY(double B)
    {
        double tx = x,ty = y;
        x = tx*cos(B) - ty*sin(B);
        y = tx*sin(B) + ty*cos(B);
    }
};
/*
* 求凸包,Graham演算法
* 點的編號0~n-1
* 返回凸包結果Stack[0~top-1]為凸包的編號
*/
Point list[MAXN];
int Stack[MAXN],top;
double dist(Point a,Point b)
{
    return sqrt((a-b)*(a-b));
}
//相對於list[0]的極角排序
bool _cmp(Point p1,Point p2)
{
    double tmp = (p1-list[0])^(p2-list[0]);
    if(sgn(tmp) > 0) return true;
    else if(sgn(tmp) == 0 && sgn(dist(p1,list[0]) - dist(p2,list[0])) <= 0)   return true;
    else return false;
}
void Graham(int n)
{
    Point p0;
    int k = 0;
    p0 = list[0];  //找最下邊的一個點
    for(int i = 1; i < n; i++)
    {
        if( (p0.y > list[i].y) || (p0.y == list[i].y && p0.x > list[i].x) )
        {
            p0 = list[i];
            k = i;
        }
    }
    swap(list[k],list[0]);
    sort(list+1,list+n,_cmp);//排序
    if(n == 1)
    {
        top = 1;
        Stack[0] = 0;
        return;
    }
    if(n == 2)
    {
        top = 2;
        Stack[0] = 0;
        Stack[1] = 1;
        return ;
    }
    Stack[0] = 0;
    Stack[1] = 1;
    top = 2;
    for(int i = 2; i < n; i++)
    {
        while(top > 1 && sgn((list[Stack[top-1]]-list[Stack[top-2]])^(list[i]-list[Stack[top-2]])) <= 0)
            top--;
        Stack[top++] = i;
    }
}
int main()
{
    int n,l;
    while(scanf("%d%d",&n,&l)!=EOF)
    {
        for(int i=0; i<n; ++i)
            scanf("%lf%lf",&list[i].x,&list[i].y);
        Graham(n);
        double ans=0;
        for(int i=0; i<top-1; ++i)
            ans+=fabs(dist(list[Stack[i]],list[Stack[i+1]]));
        ans+=fabs(dist(list[Stack[0]],list[Stack[top-1]]));
        ans+=PI*2*l;
        //cout<<ans<<endl;
        //ans=int(ans+0.5);//四捨五入
        printf("%d\n",int(ans+0.5));//不做四捨五入而直接寫成printf("%.0f\n",ans);也能AC

    }
    return 0;
}
/*
9 100
200 400
300 400
300 300
400 300
400 400
500 400
500 200
350 200
200 200
*/


相關文章