POJ 1469-COURSES(二分圖匹配入門-匈牙利演算法)
COURSES
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 21307 | Accepted: 8374 |
Description
Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:
- every student in the committee represents a different course (a student can represent a course if he/she visits that course)
- each course has a representative in the committee
Input
Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:
P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...
CountP StudentP 1 StudentP 2 ... StudentP CountP
The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.
P N
Count1 Student1 1 Student1 2 ... Student1 Count1
Count2 Student2 1 Student2 2 ... Student2 Count2
...
CountP StudentP 1 StudentP 2 ... StudentP CountP
The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.
Output
The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.
Sample Input
2 3 3 3 1 2 3 2 1 2 1 1 3 3 2 1 3 2 1 3 1 1
Sample Output
YES NO
Source
題目意思:
N個學生,P門課,每個學生學習P門課中的0~P門。
是判斷能否選出P個學生,組成一個委員會,滿足:
①委員會中每名學生代表一門不同的課程(學習了就能代表這門課);
②每門課在委員會中有一名代表。
解題思路:
二分圖匹配入門大水題,直接用匈牙利演算法切掉。注意用scanf,cin和cout會TLE…
P門課與N個學生之間以“是否學習”連邊建圖。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
#define maxn 1010
#define INF 0xfffffff
using namespace std;
int nx,ny;//X與Y集合中元素的個數
int g[maxn][maxn];//邊的鄰接矩陣
int cx[maxn],cy[maxn];//cx[i]表示最終求得的最大匹配中與Xi匹配的頂點,cy[i]同理
int mk[maxn];//mark,記錄頂點訪問狀態
int path(int u)
{
for(int v=1; v<=ny; ++v)
if(g[u][v]&&!mk[v])
{
mk[v]=1;
if(cy[v]==-1||path(cy[v]))
{
cx[u]=v;
cy[v]=u;
return 1;
}
}
return 0;
}
int MaxMatch()
{
int res=0;
memset(cx,-1,sizeof(cx));
memset(cy,-1,sizeof(cy));
for(int i=1; i<=nx; ++i)
if(cx[i]==-1)
{
memset(mk,0,sizeof(mk));
res+=path(i);
if(res==nx) break;
}
return res;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&nx,&ny);
memset(g,0,sizeof(g));
int num,i,j,x;
for(i=1; i<=nx; ++i)
{
scanf("%d",&num);
for(j=0; j<num; ++j)
{
scanf("%d",&x);
g[i][x]=1;
}
}
if(MaxMatch()==nx) puts("YES");
else puts("NO");
}
return 0;
}
/*
2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1
*/
相關文章
- POJ 1325-Machine Schedule(二分圖匹配-匈牙利演算法)Mac演算法
- 圖論-二分圖匹配匈牙利演算法圖論演算法
- 二分圖最大匹配(匈牙利演算法)演算法
- 匈牙利演算法--二分圖的最大匹配演算法
- 二分圖的最大匹配、完美匹配和匈牙利演算法演算法
- 詳解匈牙利演算法與二分圖匹配演算法
- 二分圖的最大匹配的匈牙利演算法演算法
- 二分圖最大匹配問題匈牙利演算法演算法
- 二分圖的最大匹配(匈牙利演算法)程式碼演算法
- POJ 3014:Asteroids(二分匹配,匈牙利演算法)AST演算法
- HDU 2063 匈牙利演算法二分圖的最大匹配演算法
- hdu5090 匈牙利演算法二分圖最大匹配問題演算法
- 匈牙利演算法模板(二分圖)演算法
- poj2400 KM演算法二分圖的完美匹配演算法
- 對匈牙利演算法理解——對二分圖進行最大匹配的演算法演算法
- 演算法學習之路|二分圖的最大匹配—匈牙利演算法(Dfs實現)演算法
- POJ - 3041 Asteroids 【二分圖匹配】AST
- POJ 3041-Asteroids(二分圖匹配)AST
- 求二部圖最大匹配的匈牙利演算法演算法
- BZOJ 1191 [HNOI2006]超級英雄Hero:二分圖匹配 匈牙利演算法演算法
- KM演算法——二分圖的最佳匹配演算法
- 二分圖匹配
- 《啊哈!演算法》我要做月老 ——二分圖最大匹配演算法
- 目標匹配:匈牙利演算法的python實現演算法Python
- 二分圖最大權完美匹配
- hdu2255 二分圖的最佳匹配 KM演算法演算法
- 二分圖最小點覆蓋等於二分圖最大匹配
- 匈牙利演算法演算法
- 前端技術分享:演算法入門之“二分演算法”前端演算法
- POJ 3565 Ants (最小權完美匹配 KM演算法)演算法
- Uva11383 二分圖的完美匹配(深入理解KM演算法)演算法
- 洛谷P7368 [USACO05NOV] Asteroids G 題解 二分圖最小點覆蓋 匈牙利演算法AST演算法
- POJ-3461 Oulipo-匹配的字元有幾個(KMP演算法)字元KMP演算法
- 推公式+二分--poj1759公式
- POJ-1363 Rails-堆疊入門AI
- 匈牙利演算法學習筆記演算法筆記
- 地圖匹配演算法實踐地圖演算法
- POJ 2524-Ubiquitous Religions(入門並查集)UI並查集