POJ 3169-Layout(差分約束系統-入門裸題)
Layout
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 10125 | Accepted: 4874 |
Description
Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they
can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).
Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.
Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.
Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input
Line 1: Three space-separated integers: N, ML, and MD.
Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.
Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.
Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1 1 3 10 2 4 20 2 3 3
Sample Output
27
Hint
Explanation of the sample:
There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.
The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.
The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
Source
題目意思:
有編號為1~N的N頭母牛,多個母牛的座標位置可能相同。
有ML對母牛相互喜歡,A對B的距離不能大於D;
有MD對母牛相互嫌棄,A對B的距離不能小於D;
求第1頭與第N頭母牛之間的最大距離;如果不存在,輸出“-1”;如果距離無約束,輸出“-2”。
解題思路:
紅果果的差分約束系統的裸題。
Db-Da≤d,則a~b權值為d;
Db-Da≥d,轉化成Da-Db≤-d,則b~a權值為-d。
建一個有向圖,喜歡那麼距離為正,嫌棄的話距離為負。
直接SPFA求解dist[n]即1~N奶牛的距離。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <iomanip>
#include <algorithm>
#define MAXN 10010
#define INF 0xfffffff
using namespace std;
struct ArcNode
{
int to;
int weight;
ArcNode *next;
};
queue<int> Q;//佇列中的節點為頂點序號
int n;//頂點個數
ArcNode * List[MAXN];//每個頂點的邊連結串列表頭指標
int inq[MAXN];//每個頂點是否在佇列中的標誌
int dist[MAXN],path[MAXN];
int cnt[MAXN];
bool SPFA(int src)
{
memset(cnt,0,sizeof(cnt));
memset(inq,0,sizeof(inq));
int i,u;//u為佇列頭頂點序號
ArcNode * temp;
for(i=1; i<=n; ++i)//初始化
{
dist[i]=INF;
path[i]=src;
inq[i]=0;
}
dist[src]=0;
path[src]=src;
++inq[src];
Q.push(src);
++cnt[src];
while(!Q.empty())
{
u=Q.front();
Q.pop();
--inq[u];
if(cnt[u]>n) return true;//存在負權迴路
temp=List[u];
while(temp!=NULL)
{
int v=temp->to;
if(dist[v]>dist[u]+temp->weight)
{
dist[v]=dist[u]+temp->weight;
if(!inq[v])
{
Q.push(v);
++inq[v];
++cnt[v];
}
}
temp=temp->next;
}
}
return false;
}
int main()
{
int a,b;
int u,v,w;
cin>>n>>a>>b;
memset(List,0,sizeof(List));
ArcNode *temp;
while(!Q.empty()) Q.pop();
while(a--)
{
cin>>u>>v>>w;
temp=new ArcNode;
temp->to=v;//構造鄰接表
temp->weight=w;
temp->next=NULL;
if(List[u]==NULL) List[u]=temp;
else
{
temp->next=List[u];
List[u]=temp;
}
}
while(b--)//負權路
{
cin>>u>>v>>w;
temp=new ArcNode;
temp->to=u;//構造鄰接表
temp->weight=-w;
temp->next=NULL;
if(List[v]==NULL) List[v]=temp;
else
{
temp->next=List[v];
List[v]=temp;
}
}
bool flag=SPFA(1);//求源點到其他頂點的最短路徑
/*for(i=0; i<=n; ++i)
cout<<dist[i]<<" ";
cout<<endl;*/
if(flag) puts("-1");//存在負環
else
{
if(dist[n]==INF) puts("-2");//1~N未更新說明木有約束
else cout<<dist[n]<<endl;
}
return 0;
}
/*
4 2 1
1 3 10
2 4 20
2 3 3
*/
相關文章
- POJ 2983-Is the Information Reliable?(差分約束系統)ORM
- POJ 1364-King(差分約束系統)
- 差分約束系統+poj1201
- 淺談差分約束系統
- 差分約束系統詳解
- POJ 3169(Bellman-Ford演算法,差分約束系統)演算法
- POJ 3159-Candies(差分約束系統-SPFA+鄰接表)
- 差分約束
- 演算法學習之路|差分約束系統演算法
- uva 11478 最短路徑問題(負環,差分約束系統)
- 差分約束學習筆記筆記
- Mysql入門【Mysql約束】MySql
- [演算法學習筆記] 差分約束演算法筆記
- 差分約束系統+SPFA/Bellman判斷負權迴路+uva515
- xml--概述,快速入門,約束XML
- Day2 尤拉路,拓撲排序和差分約束排序
- Oracle中的約束簡單入門試驗Oracle
- Android入門教程:ConstraintLayout約束佈局AndroidAI
- odoo 開發入門教程系列-約束(Constraints)OdooAI
- Javaweb-約束的分類JavaWeb
- 【SQL】15 SQL 約束(Constraints)、NOT NULL 約束、UNIQUE 約束、PRIMARY KEY 約束、FOREIGN KEY 約束、CHECK 約束、DEFAULT約束SQLAINull
- 通用漏洞評分系統 (CVSS)系統入門指南
- 無約束優化方法讀書筆記—入門篇優化筆記
- 時序分析:基礎知識整理(三)差分轉單端的約束等
- 系統入門課後習題1
- 維修上門預約系統
- mysql資料庫匯入外來鍵約束問題MySql資料庫
- POJ 2777 Count Color 線段樹入門題
- CMMI 入門 – 基本術語:約束、假設、依賴、風險、承諾薦
- eclipse匯入約束檔案Eclipse
- Javaweb-約束-外來鍵約束JavaWeb
- 資料庫系統之實體完整性約束資料庫
- 合約入門
- Oracle定義約束 外來鍵約束Oracle
- SQL約束SQL
- Oracle約束Oracle
- oracle 約束Oracle
- 03約束