POJ 1364-King(差分約束系統)

kewlgrl發表於2016-08-12
King
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12246   Accepted: 4452

Description

Once, in one kingdom, there was a queen and that queen was expecting a baby. The queen prayed: ``If my child was a son and if only he was a sound king.'' After nine months her child was born, and indeed, she gave birth to a nice son. 
Unfortunately, as it used to happen in royal families, the son was a little retarded. After many years of study he was able just to add integer numbers and to compare whether the result is greater or less than a given integer number. In addition, the numbers had to be written in a sequence and he was able to sum just continuous subsequences of the sequence. 

The old king was very unhappy of his son. But he was ready to make everything to enable his son to govern the kingdom after his death. With regards to his son's skills he decided that every problem the king had to decide about had to be presented in a form of a finite sequence of integer numbers and the decision about it would be done by stating an integer constraint (i.e. an upper or lower limit) for the sum of that sequence. In this way there was at least some hope that his son would be able to make some decisions. 

After the old king died, the young king began to reign. But very soon, a lot of people became very unsatisfied with his decisions and decided to dethrone him. They tried to do it by proving that his decisions were wrong. 

Therefore some conspirators presented to the young king a set of problems that he had to decide about. The set of problems was in the form of subsequences Si = {aSi, aSi+1, ..., aSi+ni} of a sequence S = {a1, a2, ..., an}. The king thought a minute and then decided, i.e. he set for the sum aSi + aSi+1 + ... + aSi+ni of each subsequence Si an integer constraint ki (i.e. aSi + aSi+1 + ... + aSi+ni < ki or aSi + aSi+1 + ... + aSi+ni > ki resp.) and declared these constraints as his decisions. 

After a while he realized that some of his decisions were wrong. He could not revoke the declared constraints but trying to save himself he decided to fake the sequence that he was given. He ordered to his advisors to find such a sequence S that would satisfy the constraints he set. Help the advisors of the king and write a program that decides whether such a sequence exists or not. 

Input

The input consists of blocks of lines. Each block except the last corresponds to one set of problems and king's decisions about them. In the first line of the block there are integers n, and m where 0 < n <= 100 is length of the sequence S and 0 < m <= 100 is the number of subsequences Si. Next m lines contain particular decisions coded in the form of quadruples si, ni, oi, ki, where oi represents operator > (coded as gt) or operator < (coded as lt) respectively. The symbols si, ni and ki have the meaning described above. The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the blocks in the input. A line contains text successful conspiracy when such a sequence does not exist. Otherwise it contains text lamentable kingdom. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0

Sample Output

lamentable kingdom
successful conspiracy

Source


題目意思:

N表示序列S中元素的個數,M表示從S中取出的子序列的個數。
從序列S={A1,A2,…An}中取出子序列Si={A[si],A[si+1],…A[si+ni]}。
對於每個子序列Si中的所有元素求和,對這個和設定一個約束,使之大於Ki或者小於Ki。
請問能否找出這樣一個長度為N的序列S,使得設定的約束成立。

解題思路:

差分約束系統。

使用前N項和的概念,將子序列[a,b]內所有元素求和表示成:Sum[b]-Sum[a-1]>K[i](或小於)。

那麼,Sum[b]-Sum[a-1]>K[i]可以改寫成Sum[a-1]-Sum[b]≤K[i],由此構建一個有向圖的邊b->(a-1),邊權為K[i]。

根據輸入可以構建多組這樣的邊,從源點0開始,如果存在負權值迴路,說明可以找到;反之不行。

要注意另設的這一個源點0,到其他所有點路徑都為0。在我的程式中,N在判斷時變成N+2。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <iomanip>
#include <algorithm>
#define MAXN 10010
#define INF 0xfffffff
using namespace std;

struct ArcNode
{
    int to;
    int weight;
    ArcNode *next;
};
queue<int> Q;//佇列中的節點為頂點序號
int n;//頂點個數
int m,W;
ArcNode * List[MAXN];//每個頂點的邊連結串列表頭指標
int inq[MAXN];//每個頂點是否在佇列中的標誌
int dist[MAXN],path[MAXN];
int cnt[MAXN];
bool SPFA(int src)
{
    memset(cnt,0,sizeof(cnt));
    memset(inq,0,sizeof(inq));
    int i,u;//u為佇列頭頂點序號
    ArcNode * temp;
    for(i=0; i<=n+2; ++i)//初始化
    {
        dist[i]=INF;
        path[i]=src;
        inq[i]=0;
    }
    dist[src]=0;
    path[src]=src;
    ++inq[src];
    Q.push(src);
    ++cnt[src];
    while(!Q.empty())
    {
        u=Q.front();
        Q.pop();
        --inq[u];
        if(cnt[u]>n+2) return true;//存在負權迴路
        temp=List[u];
        while(temp!=NULL)
        {
            int v=temp->to;
            if(dist[v]>dist[u]+temp->weight)
            {
                dist[v]=dist[u]+temp->weight;
                path[v]=u;
                if(!inq[v])
                {
                    Q.push(v);
                    ++inq[v];
                    ++cnt[v];
                }

            }
            temp=temp->next;
        }
    }
    return false;
}
int main()
{
    /*#ifdef ONLINE_JUDGE
    #else
        freopen("G:/x/read.txt","r",stdin);
        freopen("G:/x/out.txt","w",stdout);
    #endif*/
    while(cin>>n&&n)
    {
        cin>>m;
        int i;
        memset(List,0,sizeof(List));
        ArcNode *temp;
        while(!Q.empty()) Q.pop();
        while(m--)
        {
            int u,v;
            cin>>u>>v;
            char g,t;
            cin>>g>>t;
            int k;
            cin>>k;
            if(g=='g')//大於
            {
                temp=new ArcNode;
                temp->to=u;//構造鄰接表
                temp->weight=-k-1;
                temp->next=NULL;
                if(List[u+v+1]==NULL) List[u+v+1]=temp;
                else
                {
                    temp->next=List[u+v+1];
                    List[u+v+1]=temp;
                }
            }
            else if(g=='l')//小於
            {
                temp=new ArcNode;
                temp->to=u+v+1;//構造鄰接表
                temp->weight=k-1;
                temp->next=NULL;
                if(List[u]==NULL) List[u]=temp;
                else
                {
                    temp->next=List[u];
                    List[u]=temp;
                }
            }
        }
        for(i=0; i<=n; ++i)
        {
            temp=new ArcNode;
            temp->to=i;//構造鄰接表
            temp->weight=0;
            temp->next=NULL;
            if(List[0]==NULL) List[0]=temp;
            else
            {
                temp->next=List[0];
                List[0]=temp;
            }
        }
        if(SPFA(0)) puts("successful conspiracy");//求源點到其他頂點的最短路徑
        else puts("lamentable kingdom");
        for(i=0; i<=n; ++i)
        {
            temp=List[i];
            while(temp!=NULL)
            {
                List[i]=temp->next;
                delete temp;
                temp=List[i];
            }
        }
    }
    return 0;
}
/*
4 2
1 2 gt 0
2 2 lt 2
1 2
1 0 gt 0
1 0 lt 0
0
*/


相關文章