POJ 3370-Halloween treats(鴿巢原理)
Time Limit: 2000MS | Memory Limit: 65536K | |||
Total Submissions: 7985 | Accepted: 2905 | Special Judge |
Description
Every year there is the same problem at Halloween: Each neighbour is only willing to give a certain total number of sweets on that day, no matter how many children call on him, so it may happen that a child will get nothing if it is too late. To avoid conflicts, the children have decided they will put all sweets together and then divide them evenly among themselves. From last year's experience of Halloween they know how many sweets they get from each neighbour. Since they care more about justice than about the number of sweets they get, they want to select a subset of the neighbours to visit, so that in sharing every child receives the same number of sweets. They will not be satisfied if they have any sweets left which cannot be divided.
Your job is to help the children and present a solution.
Input
The input contains several test cases.
The first line of each test case contains two integers c and n (1 ≤ c ≤ n ≤ 100000), the number of children and the number of neighbours, respectively. The next line contains n space
separated integers a1 , ... , an (1 ≤ ai ≤ 100000 ), where ai represents the number of sweets the children get if they visit
neighbour i.
The last test case is followed by two zeros.
Output
For each test case output one line with the indices of the neighbours the children should select (here, index i corresponds to neighbour i who gives a total number of ai sweets). If there is no solution where each child gets at least one sweet print "no sweets" instead. Note that if there are several solutions where each child gets at least one sweet, you may print any of them.
Sample Input
4 5 1 2 3 7 5 3 6 7 11 2 5 13 17 0 0
Sample Output
3 5 2 3 4
Source
題目意思:
解題思路:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
using namespace std;
#define maxn 100010
int a[maxn];
struct Remnant
{
int h,r;//記錄前h個數和模上c後的餘數r
} re[maxn];
bool cmp(const Remnant &x,const Remnant &y)//結構體排序
{
if(x.r==y.r) return (x.h<y.h);
return (x.r<y.r);
}
int getint()//輸入外掛
{
char c=getchar();
int t=0;
while (c<'0' || c>'9')
{
c=getchar();
}
while (c>='0' && c<='9')
{
t=t*10+c-'0';
c=getchar();
}
return t;
}
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
int c,n;
while(cin>>c>>n,c||n)
{
//memset(a,0,sizeof(a));
// memset(re,0,sizeof(Remnant)*maxn);
int flag=-1,h;
long long sum=0;
for(int i=0; i<n; ++i)
{
a[i]=getint();//加了外掛之後1902ms險過…
sum+=a[i];//累加前i個數
re[i].r=sum%c;//儲存餘數
re[i].h=i+1;//儲存前h個數下標h
if(flag==-1&&re[i].r==0) flag=i;//當前存在數的和是c的倍數,即第一次掃描時糖果可分,並記錄位置
}
if(flag==-1)//第一次掃描糖果不可分
{
sort (re,re+n,cmp);//所有和的餘數遞增排序
for(int i=0; i<n-1; ++i)
if(flag==-1&&re[i].r==re[i+1].r)//若兩個餘數相等,說明它們原來的和是c的倍數
{
flag=re[i].h;//記錄開始位置
h=re[i+1].h;//記錄結束位置
}
if(flag==-1) puts("no sweets");//糖果不可分
else//第二次掃描發現糖果可分
{
for(int i=flag+1; i<h; ++i)
cout<<i<<" ";
cout<<h<<endl;
}
}
else//第一次掃描時糖果可分
{
for(int i=0; i<flag; ++i)
cout<<i+1<<" ";
cout<<flag+1<<endl;
}
}
return 0;
}
/**
4 5
1 2 3 7 5
3 6
7 11 2 5 13 17
0 0
**/
相關文章
- UVA11237 Halloween treats (鴿巢原理)
- CF 1994 D. Funny Game(*1900) 鴿巢原理+並查集GAM並查集
- CF 577 B. Modulo Sum 鴿巢原理/01揹包 (*1800)
- 飛鴿傳書實現原理
- HDU - 6003 Problem Buyer題解(貪心選擇演算法,鴿巢原理,優先佇列維護)演算法佇列
- MySQL Join原理分析(緩衝塊巢狀與索引巢狀迴圈)MySql巢狀索引
- 趣題:鴿籠原理的應用 IMO 2001 Problem #3
- ScrollView巢狀ListView解決辦法以及原理View巢狀
- POJ 3928-Ping pong(樹狀陣列+加/乘法原理)陣列
- 從原理上說說ScrollView巢狀ListView的問題View巢狀
- 用信鴿解釋httpsHTTP
- 不可思議的肉鴿遊戲遊戲
- 用信鴿來解釋 HTTPSHTTP
- 通過信鴿來解釋 HTTPSHTTP
- POJ 3461 kmpKMP
- poj3417
- 天鴿互動財報:2017年Q1天鴿互動營收2.44億元 同比增長61.0%營收
- 利用飛鴿協議實現通訊功能協議
- less巢狀巢狀
- Datalist巢狀巢狀
- Flip Game(POJ 1753)GAM
- POJ 2431 Expedition
- POJ3259-WormholesWorm
- POJ 3414 Pots
- 【Android】ScrollView巢狀ListView只顯示第一行問題原理分析AndroidView巢狀
- 隨時會鴿的 PHP 教程:環境安裝PHP
- 用信鴿來講解HTTPS的知識HTTP
- Linux中利用NFS實現飛鴿傳書LinuxNFS
- 集合框架-集合的巢狀遍歷(HashMap巢狀HashMap)框架巢狀HashMap
- 集合框架-集合的巢狀遍歷(HashMap巢狀ArrayList)框架巢狀HashMap
- 集合框架-集合的巢狀遍歷(ArrayList巢狀HashMap)框架巢狀HashMap
- 集合框架-集合的巢狀遍歷(多層巢狀)框架巢狀
- vue路由巢狀Vue路由巢狀
- angular 巢狀路由Angular巢狀路由
- 迴圈_巢狀巢狀
- 集合的巢狀巢狀
- 盒子的巢狀巢狀
- oracle巢狀表Oracle巢狀