HDU 1028-Ignatius and the Princess III(拆分整數-母函式-無限次)

kewlgrl發表於2016-08-04

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18862    Accepted Submission(s): 13247


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627
 

Author
Ignatius.L
 

Recommend
We have carefully selected several similar problems for you:  1171 1085 1398 2152 1709 

題目意思:

給定一個正整數N,將其分解成多個正整數相加的形式。

解題思路:

母函式,套個模板,可以看作是取數無限次,不像HDU 2082 是有限次取數。
#include <bits/stdc++.h>
using namespace std;
#define maxn 150

void solve(int n)
{
    int i,j,k;
    int a[maxn],b[maxn];
    memset(a,0,sizeof(a));//儲存各項的係數
    memset(b,0,sizeof(b));//計算用中間陣列
    a[0]=1;
    for(i=1; i<=n; ++i)
    {
        for(j=0; j<=n; ++j)//列舉多項式各項
            for(k=0; k*i+j<=n; ++k)
                b[k*i+j]+=a[j];//每一項的係數累加
        for(j=0; j<=n; ++j)
            a[j]=b[j],b[j]=0;//更新各項係數,並清空中間陣列方便下一輪計算
    }
    cout<<a[n]<<endl;
}

int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    int t;
    while(cin>>t)
    {
        solve(t);
    }
    return 0;
}

/**
4
10
20
**/


相關文章