POJ 1305-Fermat vs. Pythagoras(本原的畢達哥拉斯三元組+列舉)
Fermat vs. Pythagoras
Time Limit: 2000MS | Memory Limit: 10000K | |
Total Submissions: 1555 | Accepted: 908 |
Description
Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and current efforts in verification have succeeded
in verifying the translation of high-level code down to the chip level.
This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of a^n + b^n = c^n for n > 2.
Given a positive integer N, you are to write a program that computes two quantities regarding the solution of x^2 + y^2 = z^2, where x, y, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x < y < z, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values 0 < p <= N such that p is not part of any triple (not just relatively prime triples).
This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of a^n + b^n = c^n for n > 2.
Given a positive integer N, you are to write a program that computes two quantities regarding the solution of x^2 + y^2 = z^2, where x, y, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x < y < z, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values 0 < p <= N such that p is not part of any triple (not just relatively prime triples).
Input
The input consists of a sequence of positive integers, one per line. Each integer in the input file will be less than or equal to 1,000,000. Input is terminated by end-of-file
Output
For each integer N in the input file print two integers separated by a space. The first integer is the number of relatively prime triples (such that each component of the triple is <=N). The second number is the number of positive integers <=N that are not
part of any triple whose components are all <=N. There should be one output line for each input line.
Sample Input
10 25 100
Sample Output
1 4 4 9 16 27
Source
題目意思:
給出一個數N,求出所有小於N的X,Y,Z,使之滿足X^2+Y^2=Z^2。
輸出滿足條件的三元組的個數,以及小於N的範圍內三元組不涉及的數的個數。
解題思路:
列舉,且根據定義,本原畢達哥拉斯三元組滿足:
X=m^2-n^2;
Y=2*m*n;
Z=m^2+n^2.
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include <algorithm>
#define MAXN 1000010
typedef long long ll;
using namespace std;
int gcd(int a,int b)
{
return b==0?a:gcd(b,a%b);
}
void solve(int t)
{
int temp=sqrt(t);
int i,m,n,x,y,z,ans1=0,ans2=0;
bool flag[MAXN];//標識是否涉及該數
memset(flag,false,sizeof(flag));
for(n=1; n<=temp; ++n)//列舉
for(m=n+1; m<=temp; ++m)
{
if(m*m+n*n>t) break;
if(m%2!=n%2)
if(gcd(m,n)==1)
{
x=m*m-n*n;//求出三元組
y=2*m*n;
z=m*m+n*n;
++ans1;
//cout<<x<<" "<<y<<" "<<z<<endl;
for(i=1;; ++i)//滿足條件的三元組的整數倍也滿足
{
if(i*z>t) break;
flag[i*x]=true;
flag[i*y]=true;
flag[i*z]=true;
}
}
}
for(i=1; i<=t; ++i)
if(!flag[i])
++ans2;
cout<<ans1<<" "<<ans2<<endl;
}
int main()
{
ios::sync_with_stdio(false);
cin.tie(0);
int n;
while(cin>>n)
{
solve(n);
}
return 0;
}
/**
10
25
100
**/
相關文章
- POJ 1753-Flip Game(列舉&&DFS)GAM
- POJ 1753 Flip Game(列舉變元的高斯消元)GAM
- 在C#中對列舉進行位運算--列舉組合C#
- 陣列和廣義表的基本運算實現(三元組)陣列
- POJ 3080 Blue Jeans (KMP+暴力列舉)【模板】KMP
- UVALive 7410 && POJ 5583 Kingdom of Black and White (列舉)
- 列舉和列舉的取值範圍
- IV.18 列舉組合學與代陣列合學陣列
- poj3080-kmp+列舉子串 求最長公共子串KMP
- 分組(狀壓dp+技巧:快速列舉子集)
- Java 列舉、JPA 和 PostgreSQL 列舉JavaSQL
- 位元組碼層面深入分析Java列舉類Java
- Java列舉-通過值查詢對應的列舉Java
- Java enum列舉類詳解 列舉的常見用法Java
- iOS 列舉的巧用iOS
- delphi 裡的 列舉
- java中的列舉Java
- POJ 2718簡單列舉貪心演算法(好久沒寫程式碼了。。)演算法
- Java列舉Java
- Swift,列舉Swift
- C/C++列舉enum分別列印輸出列舉子和列舉值的方法C++
- Swift列舉的全用法Swift
- Java 列舉 switch的用法Java
- 列舉GCRoots的實現GC
- C# 中的“智慧列舉”:如何在列舉中增加行為C#
- c++11 實現列舉值到列舉名的轉換C++
- javascript組合繼承的基本原理JavaScript繼承
- poj 2481 樹狀陣列陣列
- C# 列舉與位列舉概述C#
- 列舉工具類
- TypeScript 列舉enumTypeScript
- Java 列舉(enum)Java
- Swift-列舉Swift
- 自定義列舉
- java列舉類Java
- TypeScript 列舉指南TypeScript
- Java列舉使用Java
- C#:列舉C#