POJ 1080-Human Gene Functions(LCS變形-最大得分)

kewlgrl發表於2016-05-19

Human Gene Functions

Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 18697   Accepted: 10386

Description

It is well known that a human gene can be considered as a sequence, consisting of four nucleotides, which are simply denoted by four letters, A, C, G, and T. Biologists have been interested in identifying human genes and determining their functions, because these can be used to diagnose human diseases and to design new drugs for them.

A human gene can be identified through a series of time-consuming biological experiments, often with the help of computer programs. Once a sequence of a gene is obtained, the next job is to determine its function.
One of the methods for biologists to use in determining the function of a new gene sequence that they have just identified is to search a database with the new gene as a query. The database to be searched stores many gene sequences and their functions – many researchers have been submitting their genes and functions to the database and the database is freely accessible through the Internet.

A database search will return a list of gene sequences from the database that are similar to the query gene.
Biologists assume that sequence similarity often implies functional similarity. So, the function of the new gene might be one of the functions that the genes from the list have. To exactly determine which one is the right one another series of biological experiments will be needed.

Your job is to make a program that compares two genes and determines their similarity as explained below. Your program may be used as a part of the database search if you can provide an efficient one.
Given two genes AGTGATG and GTTAG, how similar are they? One of the methods to measure the similarity
of two genes is called alignment. In an alignment, spaces are inserted, if necessary, in appropriate positions of
the genes to make them equally long and score the resulting genes according to a scoring matrix.

For example, one space is inserted into AGTGATG to result in AGTGAT-G, and three spaces are inserted into GTTAG to result in –GT--TAG. A space is denoted by a minus sign (-). The two genes are now of equal
length. These two strings are aligned:

AGTGAT-G
-GT--TAG

In this alignment, there are four matches, namely, G in the second position, T in the third, T in the sixth, and G in the eighth. Each pair of aligned characters is assigned a score according to the following scoring matrix.

denotes that a space-space match is not allowed. The score of the alignment above is (-3)+5+5+(-2)+(-3)+5+(-3)+5=9.

Of course, many other alignments are possible. One is shown below (a different number of spaces are inserted into different positions):

AGTGATG
-GTTA-G

This alignment gives a score of (-3)+5+5+(-2)+5+(-1) +5=14. So, this one is better than the previous one. As a matter of fact, this one is optimal since no other alignment can have a higher score. So, it is said that the
similarity of the two genes is 14.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input file. Each test case consists of two lines: each line contains an integer, the length of a gene, followed by a gene sequence. The length of each gene sequence is at least one and does not exceed 100.

Output

The output should print the similarity of each test case, one per line.

Sample Input

2 
7 AGTGATG 
5 GTTAG 
7 AGCTATT 
9 AGCTTTAAA 

Sample Output

14
21 

Source

Taejon 2001

題目意思:

每組資料給出長度和兩個字串,可以在它們之間加-,按照圖中的匹配得分原則,求最大得分。

解題思路:

dp[i][j]表示字串str1中長度為i的字首與字串str2中長度為j的字首對齊的最大得分。
將字元轉換成數字,存入新的陣列。
當i>0時,s1[i-1]與空格的最大得分:dp[i-1][j]+score[0][s1[i-1]];
當j>0時,s2[j-1]與空格的最大得分:dp[i][j-1]+score[0][s2[j-1]];
當i>0&&j>0時,s1[i-1]與s2[j-1]對齊的最大得分:dp[i-1][j-1]+score[s1[i-1]][s2[j-1]];
即:dp[i][j]=MAX(dp[i-1][j]+score[0][s1[i-1]],dp[i][j-1]+score[0][s2[j-1]],dp[i-1][j-1]+score[s1[i-1]][s2[j-1]]);
但是str1或str2的尾字元都有可能和空格匹配:
dp[m][n+1],dp[m+1][n]分別表示s1[m-1]和s2[n-1]與空格匹配的最大得分。
所以最終答案:int ans=MAX(dp[m][n],dp[m][n+1],dp[m+1][n]);

注意一下初始化
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define MAXN 1001
int score[5][5]= {0,-3,-4,-2,-1,
                  -3,5,-1,-2,-1,
                  -4,-1,5,-3,-2,
                  -2,-2,-3,5,-2,
                  -1,-1,-2,-2,5
                 };//評分矩陣
int dp[MAXN][MAXN];
char str1[MAXN],str2[MAXN];//原來的字串
int s1[MAXN],s2[MAXN];//後來轉換成的整數串
int MAX(int a,int b,int c)
{
    if(a>b&&a>c) return a;
    else if(b>a&&b>c) return b;
    else return c;
    return 0;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(dp,0,sizeof(dp));//初始化
        memset(s1,0,sizeof(s1));
        memset(s2,0,sizeof(s2));
        int m,n,i,j;
        cin>>m>>str1>>n>>str2;
        for(i=0; i<m; ++i)//把字元轉換成整數存入新的陣列中
        {
            if(str1[i]=='A')  s1[i]=1;
            else if(str1[i]=='C')  s1[i]=2;
            else if(str1[i]=='G')  s1[i]=3;
            else if(str1[i]=='T')  s1[i]=4;
            else s1[i]=0;
        }
        s1[m]=0;//末尾追加一位0
        for(i=0; i<n; ++i)
        {
            if(str2[i]=='A')  s2[i]=1;
            else if(str2[i]=='C')  s2[i]=2;
            else if(str2[i]=='G')  s2[i]=3;
            else if(str2[i]=='T')  s2[i]=4;
            else s2[i]=0;
        }
        s2[n]=0;//末尾追加一位0
        for(i=1; i<=m+1; ++i)//str1字串與str2字串首位的得分
            dp[i][0]=dp[i-1][0]+score[0][s1[i-1]];
        for(i=1; i<=n+1; ++i)//str2字串與str1字串首位的得分
            dp[0][i]=dp[0][i-1]+score[s2[i-1]][0];
        for(i=1; i<=m+1; ++i)
            for(j=1; j<=n+1; ++j)
                dp[i][j]=MAX(dp[i-1][j]+score[0][s1[i-1]],dp[i][j-1]+score[0][s2[j-1]],dp[i-1][j-1]+score[s1[i-1]][s2[j-1]]);
        int ans=MAX(dp[m][n],dp[m][n+1],dp[m+1][n]);
        cout<<ans<<endl;
    }
    return 0;
}
/*
2
7
AGTGATG
5
GTTAG
7
AGCTATT
9
AGCTTTAAA
*/


相關文章