HDU 1556-Color the ball(樹狀陣列-區間修改 單點查詢)

kewlgrl發表於2016-05-06

Color the ball

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 15491    Accepted Submission(s): 7731


Problem Description
N個氣球排成一排,從左到右依次編號為1,2,3....N.每次給定2個整數a b(a <= b),lele便為騎上他的“小飛鴿"牌電動車從氣球a開始到氣球b依次給每個氣球塗一次顏色。但是N次以後lele已經忘記了第I個氣球已經塗過幾次顏色了,你能幫他算出每個氣球被塗過幾次顏色嗎?
 

Input
每個測試例項第一行為一個整數N,(N <= 100000).接下來的N行,每行包括2個整數a b(1 <= a <= b <= N)。
當N = 0,輸入結束。
 

Output
每個測試例項輸出一行,包括N個整數,第I個數代表第I個氣球總共被塗色的次數。
 

Sample Input
3 1 1 2 2 3 3 3 1 1 1 2 1 3 0
 

Sample Output
1 1 1 3 2 1
 

Author
8600
 

Source
 

Recommend
LL   |   We have carefully selected several similar problems for you:  1542 1394 1698 1255 2795

題目意思很簡單,但是資料量不算小,直接暴力會超時,所以考慮用樹狀陣列。

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;
const int MAXN=100005;
int n;
int c[MAXN];

int lowbit(int x)
{
    return x&(-x);
}
void update(int i,int x)
{
    while(i)
    {
        c[i]+=x;
        i-=lowbit(i);
    }
}

int sum(int i)
{
    int res=0;
    while(i<=n)
    {
        res+=c[i];
        i+=lowbit(i);
    }
    return res;
}
int main()
{
    int a,b;
    while(scanf("%d",&n),n)
    {
        memset(c,0,sizeof(c));
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&a,&b);//c[a]~c[b]全部加1
            update(a-1,-1);//c[a]之前的全部減1
            update(b,1);//c[b]之前的全部加1
        }
        for(int i=1; i<n; i++)//輸出1-N
            printf("%d ",sum(i));
        printf("%d",sum(n));
        printf("\n");
    }
    return 0;
}

 順便附一下暴力超時的程式碼:
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>

using namespace std;
const int maxn=100005;
int s[maxn];

int main()
{
    int a,b,n;
    while(scanf("%d",&n),n)
    {
        memset(s,0,sizeof(s));
        for(int i=1; i<=n; i++)
        {
            scanf("%d%d",&a,&b);
            for(int j=a; j<=b; ++j)
                ++s[j];
        }
        for(int i=1; i<n; i++)
            printf("%d ",s[i]);
        printf("%d",s[n]);
        printf("\n");
    }
    return 0;
}


相關文章