POJ 2524-Ubiquitous Religions(入門並查集)

kewlgrl發表於2016-04-06

Ubiquitous Religions

Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 30241   Accepted: 14633

Description

There are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion.

Input

The input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0.

Output

For each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.

Sample Input

10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0

Sample Output

Case 1: 1
Case 2: 7

Hint

Huge input, scanf is recommended.

Source

Alberta Collegiate Programming Contest 2003.10.18

題目意思:
學校有n個人,編號1 到 n;
下面輸入 m 行,每行兩個人,兩個人在一個種族中;
如果有人不在這個學校中,即編號大於n,則忽略不計;

學校想給每個種族發一種東西,所以你要統計共有多少個種族,如果此人沒有出現,則可認為所有沒出現的一個人自信仰一個種族;

輸出共有多少個種族。

/* 
* Copyright (c) 2016, 煙臺大學計算機與控制工程學院 
* All rights reserved. 
* 檔名稱:father.cpp 
* 作    者:單昕昕 
* 完成日期:2016年1月19日 
* 版 本 號:v1.0 
*/ 
#include <stdio.h>
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
int set[50000+5];
int set_find(int p)
{
    if(set[p]==0)
        return p;
    return set[p]=set_find(set[p]);
}
void join(int p,int q)
{
    int p1,q1;
    p1=set_find(p);
    q1=set_find(q);
    if(p1!=q1)
        set[p1]=q1;
}
int main()
{
    int n, m, i, j,ans,cnt=0;
    while(scanf("%d%d", &n, &m)&&n&&m)
    {
        ans=0;
        memset(set,0,sizeof(set));
        while(m--)
        {
            scanf("%d%d", &i, &j);
            join(i,j);
        }
        for(int i=1; i<=n; i++)
            if(set[i]==0)
                ans++;
        printf( "Case %d: %d\n",++cnt, ans);
    }
    return 0;
}

參照啊哈演算法,初始化為i
/*
* Copyright (c) 2016, 煙臺大學計算機與控制工程學院
* All rights reserved.
* 檔名稱:father.cpp
* 作    者:單昕昕
* 完成日期:2016年1月19日
* 版 本 號:v2.0
*/
#include <stdio.h>
#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<vector>
#include<cmath>
using namespace std;
int set[50000+5];
int n;
void init()
{
    for(int i=1;i<=n;++i)
        set[i]=i;
}
int set_find(int p)
{
    if(set[p]==p)
        return p;
    set[p]=set_find(set[p]);
    //cout<<"set["<<p<<"]= "<<set[p]<<endl;
    return set[p];
}
void join(int p,int q)
{
    int p1,q1;
    p1=set_find(p);
    q1=set_find(q);
    if(p1!=q1)
      {
          set[p1]=q1;
          //cout<<"!!!";
      }
    //cout<<"set["<<p1<<"]= "<<set[p1]<<"join"<<endl;
}
int main()
{
    int m, i, j,ans,cnt=0;
    while(scanf("%d%d", &n, &m)&&n&&m)
    {
        init();
        ans=0;
        while(m--)
        {
            scanf("%d%d", &i, &j);
            join(i,j);
        }
        for(int i=1; i<=n; i++)
          {
              cout<<set[i]<<endl;
              if(set[i]==i)
                ans++;
          }
        printf( "Case %d: %d\n",++cnt, ans);
    }
    return 0;
}




相關文章