POJ 1995-Raising Modulo Numbers-整數快速冪
Raising Modulo Numbers
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 6012 | Accepted: 3515 |
Description
People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment
was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:
Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.
You should write a program that calculates the result and is able to find out who won the game.
Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.
You should write a program that calculates the result and is able to find out who won the game.
Input
The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be
divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.
Output
For each assingnement there is the only one line of output. On this line, there is a number, the result of expression
(A1B1+A2B2+ ... +AHBH)mod M.
Sample Input
3 16 4 2 3 3 4 4 5 5 6 36123 1 2374859 3029382 17 1 3 18132
Sample Output
2 13195 13
Source
題意:
先輸入Z表示有幾組測試資料,M表示每組資料要mod的模,H表示有幾對A和B。
求解下面這個公式的值:
(A1B1+A2B2+ ... +AHBH)mod M.
知識點:
整數快速冪,直接套函式模板。
這裡可以每輸入一組A和B的值就mod M一次,然後把這組的全部相加,輸入完畢時再次mod M,得到ans答案輸出。
#include <iostream>
#include <cstdio>
const int p=45005;
typedef long long ll;
using namespace std;
long long quick(ll a,ll b,ll m )
{
ll ans=1;
while(b)
{
if(b&1)
{
ans=(ans*a)%m;
--b;
}
b/=2;
a=a*a%m;
}
return ans;
}
int main()
{
int i,z,t,m;
ll ans,a,b;
scanf("%I64d",&z);
while(z--)
{
ans=0;
scanf("%d",&m);
scanf("%d",&t);
for(i=0; i<t; ++i)
{
scanf("%I64d%I64d",&a,&b);
ans=(ans+quick(a,b,m))%m;
}
printf("%lld\n",ans);
}
return 0;
}
相關文章
- Raising Modulo (快速冪取模)AI
- C 語言實現整數快速模除(modulo)和地板除(floordiv)
- POJ 3150 Cellular Automaton(矩陣快速冪)矩陣
- POJ 3233 Matrix Power Series (矩陣快速冪+等比數列二分求和)矩陣
- POJ 3613 Cow Relays 矩陣乘法Floyd+矩陣快速冪矩陣
- 快速冪
- poj--2778DNA Sequence+AC自動機+矩陣快速冪矩陣
- 費馬小定理 + 費馬大定理 + 勾股數的求解 + 快速冪 + 矩陣快速冪 【模板】矩陣
- 矩陣快速冪矩陣
- POJ 1465-Multiple(BFS-最小整倍數)
- POJ 3233-Matrix Power Series( S = A + A^2 + A^3 + … + A^k 矩陣快速冪取模)矩陣
- BZOJ 3329 Xorequ:數位dp + 矩陣快速冪矩陣
- POJ 2778-DNA Sequence(AC自動機+構建鄰接矩陣+矩陣快速冪)矩陣
- 演算法筆記01--歸納法之整數冪演算法筆記
- 矩陣快速冪(快忘了)矩陣
- 矩陣快速冪總結矩陣
- Quick Pow: 如何快速求冪UI
- C#快速入門教程(8)——整數C#
- 【矩陣乘法】【快速冪】遞推矩陣
- 快速冪的初步認識(Java)Java
- 矩陣快速冪加速最短路矩陣
- 別人家的面試題:一個整數是否是“4”的N次冪面試題
- HDU3221Brute-force Algorithm(矩陣快速冪&&指數降冪)Go矩陣
- 利用匯編語言指令求一個2的非負整數次冪的次數
- 快速冪演算法(二分思想減少連乘次數)演算法
- LightOJ 1070 Algebraic Problem:矩陣快速冪 + 數學推導AI矩陣
- ACM — Prepared for New Acmer 快速冪法ACM
- HDU 1575 Tr A(矩陣快速冪)矩陣
- 快速冪演算法及其擴充演算法
- HDU 4565 So Easy!(矩陣快速冪)矩陣
- HDU 4686 (推公式+矩陣快速冪)公式矩陣
- HDU 4549 M斐波那契數列(矩陣快速冪+費馬小定理)矩陣
- BZOJ3329: Xorequ(二進位制數位dp 矩陣快速冪)矩陣
- P3390 【模板】矩陣快速冪矩陣
- HDU 4965 Fast Matrix Calculation(矩陣快速冪)AST矩陣
- HDU 4549M斐波那契數列(矩陣快速冪+費馬小定理)矩陣
- poj 3468 區間更新 整個區間加一個數和區間求和操作
- HDU 2157 How many ways?? (矩陣快速冪)矩陣