POJ 1995-Raising Modulo Numbers-整數快速冪

kewlgrl發表於2016-03-09
Raising Modulo Numbers
Time Limit: 1000MS   Memory Limit: 30000K
Total Submissions: 6012   Accepted: 3515

Description

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow: 

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions AiBi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers. 

You should write a program that calculates the result and is able to find out who won the game. 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression 

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13

Source


題意:
先輸入Z表示有幾組測試資料,M表示每組資料要mod的模,H表示有幾對A和B。
求解下面這個公式的值:
(A1B1+A2B2+ ... +AHBH)mod M.

知識點:
整數快速冪,直接套函式模板。
這裡可以每輸入一組A和B的值就mod M一次,然後把這組的全部相加,輸入完畢時再次mod M,得到ans答案輸出。

#include <iostream>
#include <cstdio>
const int p=45005;
typedef long long ll;
using namespace std;
long long quick(ll a,ll b,ll m )
{
    ll ans=1;
    while(b)
    {
        if(b&1)
        {
            ans=(ans*a)%m;
            --b;
        }
        b/=2;
        a=a*a%m;
    }
    return ans;
}
int main()
{
    int i,z,t,m;
    ll ans,a,b;
    scanf("%I64d",&z);
    while(z--)
    {
        ans=0;
        scanf("%d",&m);
        scanf("%d",&t);
        for(i=0; i<t; ++i)
        {
            scanf("%I64d%I64d",&a,&b);
            ans=(ans+quick(a,b,m))%m;
        }
        printf("%lld\n",ans);
    }
    return 0;
}




相關文章