POJ 2478-Farey Sequence(尤拉函式)
Farey Sequence
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 14071 | Accepted: 5567 |
Description
The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}
You task is to calculate the number of terms in the Farey sequence Fn.
Input
There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.
Output
For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.
Sample Input
2 3 4 5 0
Sample Output
1 3 5 9
Source
POJ Contest,Author:Mathematica@ZSU
題意:
給定一個數n,求所有小於等於n的正整數中,有多少對是互質的。
知識點:
尤拉函式。
可以先套尤拉函式模板,然後從1-n列舉,依次使用尤拉函式求出值然後相加。
就像下面這樣:
#include<iostream>
using namespace std;
int oula(int n)
{
int i,ans=n;
for(i=2; i*i<=n; ++i)
if(n%i==0)
{
ans-=ans/i;
while(n%i==0)
n/=i;
}
if(n>1)
ans-=ans/n;
return ans;
}
int main()
{
int n,i;
while(cin>>n&&n)
{
int ans=0;
for(i=2; i<=n; ++i)
ans+=oula(i);
cout<<ans<<endl;
}
return 0;
}
但是!!!這種方法會超時!!
由於這種情況下頻繁的使用尤拉函式,所以需要預先打表。
所以,我們要使用遞推求尤拉函式的方法。
預先把所有數的尤拉函式值都置為它本身,定理:如果p是一個正整數而且滿足φ(p)=p-1,則這個數是素數。
在遍歷過程中如果遇到與自身相等的情況,那麼說明該數為素數,改變這個數的尤拉函式值,同時也能把該素因子整除的數改變。其複雜度為O(nlnn)。
AC程式碼如下:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const long long N=1000000;
long long a[N+5];
int main()
{
int n,i,j;
for(i=1; i<=N; ++i)
a[i]=i;
for(i=2; i<=N; i+=2)
a[i]/=2;
for(i=3; i<=N; i+=2)
if(a[i]==i)
for(j=i; j<=N; j+=i)
a[j]=a[j]/i*(i-1);
for(i=3; i<=N; ++i)
a[i]+=a[i-1];
while(~scanf("%d",&n)&&n)
printf("%lld\n",a[n]);
return 0;
}
相關文章
- POJ2487Farey Sequence(尤拉函式&&法雷級數)函式
- poj 2478 尤拉函式函式
- POJ 2407-Relatives-尤拉函式函式
- POJ 2048 Longge's problem (尤拉函式 積性函式)函式
- 尤拉函式φ函式
- 4939 尤拉函式函式
- 尤拉函式入門函式
- 尤拉函式詳解函式
- 淺談尤拉函式函式
- sequence 和索引函式呼叫索引函式
- 尤拉函式性質和模版函式
- HDU2588GCD(尤拉函式)GC函式
- 轉載:尤拉函式知識點總結及程式碼模板及尤拉函式表函式
- Note -「因數的尤拉函式求和」函式
- bzoj2818: Gcd(尤拉函式)GC函式
- B.日記和尤拉函式函式
- 尤拉計劃512題(冪的尤拉總計函式和)函式
- HDU 4002Find the maximum(尤拉函式)函式
- POJ 3581-Sequence(字尾陣列)陣列
- [藍橋杯][演算法提高VIP]尤拉函式演算法函式
- HDU 1695-GCD(容斥原理+尤拉函式)GC函式
- HDU 3501 Calculation 2 (尤拉函式應用)函式
- 51nod1262 扔球(尤拉函式)函式
- 尤拉函式、整除分塊和擴充套件歐幾里得函式套件
- §3. 復變數的指數函式·尤拉公式變數函式公式
- 尤拉計劃533題:卡邁克爾函式函式
- HDU3501 Calculation 2(尤拉函式推廣)函式
- 51nod1040 最大公約數之和 (尤拉函式 )函式
- BZOJ 2818 Gcd (莫比烏斯反演 或 尤拉函式)GC函式
- 【Ac自動機+矩陣加速】poj 2778 DNA Sequence矩陣
- POJ 1141 Brackets Sequence(記錄路徑的dp)Racket
- 紫書 例題 10-27 UVa 10214(尤拉函式)函式
- POJ1141 ZOJ1463 Brackets Sequence【區間dp】Racket
- bzoj2190: [SDOI2008]儀仗隊(尤拉函式)函式
- poj--2778DNA Sequence+AC自動機+矩陣快速冪矩陣
- POJ 2513-Colored Sticks(連線木棍-trie樹+並查集+尤拉通路)並查集
- sequence to sequence模型模型
- FZU 1969 && UVA 11426 GCD Extreme (尤拉函式 或 莫比烏斯反演)GCREM函式