POJ 2407-Relatives-尤拉函式

kewlgrl發表於2016-03-09
Relatives
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12903   Accepted: 6379

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

Source


題意:
給定一個數n,求所有小於等於n的正整數中,有多少個是與n互質的。

知識點:
尤拉函式,直接套模板。

#include<iostream>
using namespace std;

int oula(int n)//尤拉函式的函式模板
{
    int i,ans=n;
    for(i=2;i*i<=n;++i)
        if(n%i==0)
    {
        ans-=ans/i;
        while(n%i==0)
            n/=i;
    }
    if(n>1)
        ans-=ans/n;
    return ans;
}

int main()
{
	int n;
	while(cin>>n&&n)
        cout<<oula(n)<<endl;
	return 0;
}


相關文章