POJ 2407-Relatives-尤拉函式
Relatives
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 12903 | Accepted: 6379 |
Description
Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output
For each test case there should be single line of output answering the question posed above.
Sample Input
7 12 0
Sample Output
6 4
Source
題意:
給定一個數n,求所有小於等於n的正整數中,有多少個是與n互質的。
知識點:
尤拉函式,直接套模板。
#include<iostream>
using namespace std;
int oula(int n)//尤拉函式的函式模板
{
int i,ans=n;
for(i=2;i*i<=n;++i)
if(n%i==0)
{
ans-=ans/i;
while(n%i==0)
n/=i;
}
if(n>1)
ans-=ans/n;
return ans;
}
int main()
{
int n;
while(cin>>n&&n)
cout<<oula(n)<<endl;
return 0;
}
相關文章
- poj 2478 尤拉函式函式
- POJ 2478-Farey Sequence(尤拉函式)函式
- POJ 2048 Longge's problem (尤拉函式 積性函式)函式
- POJ2487Farey Sequence(尤拉函式&&法雷級數)函式
- 尤拉函式φ函式
- 4939 尤拉函式函式
- 尤拉函式入門函式
- 尤拉函式詳解函式
- 淺談尤拉函式函式
- 尤拉函式性質和模版函式
- HDU2588GCD(尤拉函式)GC函式
- 轉載:尤拉函式知識點總結及程式碼模板及尤拉函式表函式
- Note -「因數的尤拉函式求和」函式
- bzoj2818: Gcd(尤拉函式)GC函式
- B.日記和尤拉函式函式
- 尤拉計劃512題(冪的尤拉總計函式和)函式
- HDU 4002Find the maximum(尤拉函式)函式
- [藍橋杯][演算法提高VIP]尤拉函式演算法函式
- HDU 1695-GCD(容斥原理+尤拉函式)GC函式
- HDU 3501 Calculation 2 (尤拉函式應用)函式
- 51nod1262 扔球(尤拉函式)函式
- 尤拉函式、整除分塊和擴充套件歐幾里得函式套件
- §3. 復變數的指數函式·尤拉公式變數函式公式
- 尤拉計劃533題:卡邁克爾函式函式
- HDU3501 Calculation 2(尤拉函式推廣)函式
- 51nod1040 最大公約數之和 (尤拉函式 )函式
- BZOJ 2818 Gcd (莫比烏斯反演 或 尤拉函式)GC函式
- 紫書 例題 10-27 UVa 10214(尤拉函式)函式
- bzoj2190: [SDOI2008]儀仗隊(尤拉函式)函式
- POJ 2513-Colored Sticks(連線木棍-trie樹+並查集+尤拉通路)並查集
- FZU 1969 && UVA 11426 GCD Extreme (尤拉函式 或 莫比烏斯反演)GCREM函式
- 尤拉公式——真正的宇宙第一公式公式
- 數論線性篩總結 (素數篩,尤拉函式篩,莫比烏斯函式篩,前n個數的約數個數篩)函式
- MySQL函式大全(字串函式,數學函式,日期函式,系統級函式,聚合函式)MySql函式字串
- P2303 [SDOI2012] Longge 的問題(尤拉函式,推式子)函式
- HDU 4279 2012網路賽Number(數論 尤拉函式結論約數個數)函式
- Oracle 函式大全(字串函式,數學函式,日期函式,邏輯運算函式,其他函式)Oracle函式字串
- 【函式式 Swift】函式式思想函式Swift