POJ-1961 Period-KMP字首串重複次數
Period
Time Limit: 3000MS | Memory Limit: 30000K | |
Total Submissions: 14803 | Accepted: 7054 |
Description
For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know
the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK ,that is A concatenated K times, for some string A. Of course, we also want to know the period K.
Input
The input consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S.The second line contains the string S. The input file ends with a line, having
the
number zero on it.
number zero on it.
Output
For each test case, output "Test case #" and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space;
the prefix sizes must be in increasing order. Print a blank line after each test case.
Sample Input
3 aaa 12 aabaabaabaab 0
Sample Output
Test case #1 2 2 3 3 Test case #2 2 2 6 2 9 3 12 4
Source
Southeastern Europe 2004
/*
*Copyright (c)2015,煙臺大學計算機與控制工程學院
*All rights reserved.
*作 者:單昕昕
*完成日期:2015年8月25日
*版 本 號:v1.0
*/
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxw=1000000+10;
char a[maxw];
int next[maxw];
int main()
{
int n,i,t=1;
while(cin>>n&&n!=0)
{
scanf("%s",a);
next[0]=-1;
next[1]=0;
int p=0;
printf("Test case #%d\n",t++);
for(i=2; i<=n; i++)
{
while(p>=0&&a[p]!=a[i-1]) p=next[p];
next[i]=++p;
int count=i/(i-next[i]);
if(i%(i-next[i])==0&&next[i]!=0)//i-next[i]為迴圈節長度
{
printf("%d %d\n",i,count);
}
}
putchar('\n');
}
return 0;
}
相關文章
- 無重複字元的最長子串字元
- 獲取字串中重複次數最多的字元字串字元
- java無重複字元的最長子串Java字元
- 3 無重複字元的最長子串字元
- 3. 無重複字元的最長子串字元
- 前端 JavaScript 獲取字串中重複次數最多的字元前端JavaScript字串字元
- 生成14個可重複一次的隨機數隨機
- 求字串中不含重複字元的最長子串字串字元
- LeetCode——無重複字元的最長子串LeetCode字元
- 演算法-無重複字元的最長子串演算法字元
- 【每日一題】無重複字元的最長子串每日一題字元
- HDU 4055 Number String:字首和優化dp【增長趨勢——處理重複選數】優化
- js儘量減少程式碼重複執行的次數JS
- Python自動複製Excel資料:將各行分別重複指定次數PythonExcel
- 961. 重複 N 次的元素
- leetcode 之無重複字元的最長子串LeetCode字元
- 【LeetCode】3 無重複字元的最長子串LeetCode字元
- Python連線兩個字串並去除首尾重複子串Python字串
- 【leetcode】【java】【3、無重複字元的最長子串】LeetCodeJava字元
- leetcode-3無重複字元的最長子串LeetCode字元
- LeetCode-3. 無重複字元的最長子串LeetCode字元
- Leetcode 3. 無重複字元的最長子串LeetCode字元
- 無重複隨機數生成隨機
- 滑動視窗3.替換後最長重複字元子串字元
- 每日leetcode——3. 無重複字元的最長子串LeetCode字元
- SPOJ 687. Repeats(字尾陣列求最長重複子串)陣列
- LCR 016. 無重複字元的最長子串(中)字元
- LeetCode題集-3 - 無重複字元的最長子串LeetCode字元
- WPS Excel快速統計單列資料的重複次數的方法Excel
- python 如何一次隨機取出多條資料(能重複/不能重複)Python隨機
- 用滑動視窗來解決最長無重複子串問題
- 無重複字元的最長子串問題 (移動視窗法求解)字元
- 陣列中重複的數字陣列
- 數字查詢統計重複
- java 無重複取隨機數Java隨機
- 組合數字首和
- [LeetCode 刷題] 3. 無重複字元的最長子串 (Medium)LeetCode字元
- #leetcode刷題之路3-無重複字元的最長子串LeetCode字元