POJ-2299 Ultra-QuickSort-分治法排序求交換速度

kewlgrl發表於2015-08-25
Ultra-QuickSort
Time Limit: 7000MS   Memory Limit: 65536K
Total Submissions: 49132   Accepted: 17969

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source

Waterloo local 2005.02.05

//超時。。。
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const long long N=510000;
long long n,a[N],t[N],ans,r,i,j,k,now;
void Sort(long long l,long long r)
{
    if(l==r)
        return;
    long long mid=(l+r)/2;
    Sort(l,mid);
    Sort(mid+1,r);
    i=1;
    j=mid+1;
    now=0;
    while(i<=mid&&j<=r)
    {
        if(a[i]>a[j])
        {
            ans+=mid-i+1;
            t[++now]=a[j++];
        }
        else
            t[++now]=a[i++];
    }
    while(i<=mid)
        t[++now]=a[i++];
    while(j<=r)
        t[++now]=a[j++];
    now=0;
    for(k=1; k<=r; ++k)
        a[k]=t[++now];
}
int main()
{
    std::ios::sync_with_stdio(false);
    cin>>n;
    while(n)
    {
        for(i=1; i<=n; ++i)
            cin>>a[i];
        ans=0;
        Sort(0,n);
        cout<<ans<<endl;
        cin>>n;
    }
    return 0;
}

AC程式碼:
#include <iostream>
#include <algorithm>
using namespace std;
long long a[500010],t[500010],ans;
void Sort(long long l,long long r)
{
    if(r-l>1)
    {
        long long m=l+(r-l)/2;  //取中間點
        long long p=l,q=m,i=l;
        Sort(l,m);
        Sort(m,r);     //左右子區間遞迴求解
        while(p<m || q<r)    //若合併未完成繼續迴圈
        {
            if(q>=r || (p<m && a[p]<=a[q]) )
                t[i++]=a[p++];    //合併a[p]到t[i]中
            else
            {
                t[i++]=a[q++];    //合併a[q]到t[i]中
                ans+=m-p;   //a[p]到中間點都與a[q]形成逆序對
            }
        }
        for(i=l; i<r; ++i)a[i]=t[i];
        //把合併區間t再賦值回給a;
    }
}

int main()
{
    long long N;
    cin>>N;
    while(N)
    {
        for(long long i=0; i<N; ++i)
            cin>>a[i];
        ans=0;
        Sort(0,N);
        cout<<ans<<endl;
        cin>>N;
    }
    return 0;
}


相關文章