POJ-2141 Message Decowding-奶牛密碼

kewlgrl發表於2015-08-22
Message Decowding
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12242   Accepted: 6844

Description

The cows are thrilled because they've just learned about encrypting messages. They think they will be able to use secret messages to plot meetings with cows on other farms.

Cows are not known for their intelligence. Their encryption method is nothing like DES or BlowFish or any of those really good secret coding methods. No, they are using a simple substitution cipher.

The cows have a decryption key and a secret message. Help them decode it. The key looks like this:
        yrwhsoujgcxqbativndfezmlpk

Which means that an 'a' in the secret message really means 'y'; a 'b' in the secret message really means 'r'; a 'c' decrypts to 'w'; and so on. Blanks are not encrypted; they are simply kept in place.

Input text is in upper or lower case, both decrypt using the same decryption key, keeping the appropriate case, of course.

Input

* Line 1: 26 lower case characters representing the decryption key

* Line 2: As many as 80 characters that are the message to be decoded

Output

* Line 1: A single line that is the decoded message. It should have the same length as the second line of input.

Sample Input

eydbkmiqugjxlvtzpnwohracsf
Kifq oua zarxa suar bti yaagrj fa xtfgrj

Sample Output

Jump the fence when you seeing me coming

Source

USACO 2003 March Orange

/*    
*Copyright (c)2015,煙臺大學計算機與控制工程學院    
*All rights reserved.      
*作    者:單昕昕    
*完成日期:2015年8月22日    
*版 本 號:v1.0        
*/ 
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

int main()
{
    char k[26],c;
    int i;
    for(i=0; i<26; ++i)
        cin>>k[i];
    getchar();
    while((c=getchar()))//用cin不能接受到空格
    {
        if(c>='A'&&c<='Z')
            cout<<char(k[c-'A']-'a'+'A');
        else if(c>='a'&&c<='z')
            cout<<k[c-'a'];
        else if(c=='\n')
            break;
        else
            cout<<c;
    }
    return 0;
}

getchar()每次用的時候都覺得好危險。。可能自己還是掌握的不夠好

相關文章