POJ-3461 Oulipo-匹配的字元有幾個(KMP演算法)
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 29308 | Accepted: 11749 |
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A','B', 'C', …, 'Z'} and two finite strings over that alphabet, a wordW and a text T, count the number of occurrences of W inT. All the consecutive characters of W must exactly match consecutive characters ofT. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
- One line with the word W, a string over {'A', 'B','C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the stringW).
- One line with the text T, a string over {'A', 'B','C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the wordW in the text T.
Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
Sample Output
1 3 0
Source
/*
*Copyright (c)2015,煙臺大學計算機與控制工程學院
*All rights reserved.
*作 者:單昕昕
*完成日期:2015年8月16日
*版 本 號:v1.0
*/
//nextval陣列
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxw=10000+10;
const int maxt=1000000+10;
int match(char w[],char s[],int next [])
{
int cnt=0,p=0,cur=0,slen,wlen;
slen=strlen(s);
wlen=strlen(w);
while(cur<slen)
{
if(s[cur]==w[p])
{
++cur;
++p;
}
else if(p>=0)
{
p=next[p];
}
else
{
++cur;
p=0;
}
if(p==wlen)
{
++cnt;
p=next[p];
}
}
return cnt;
}
int main()
{
int loop;
scanf("%d",&loop);
while(loop--)
{
char w[maxw],t[maxt];
scanf("%s%s",w,t);
int next[maxw],p=0,cur;
next[0]=-1;
next[1]=0;
for(cur=2; cur<=strlen(w); ++cur)
{
while(p>=0&&w[p]!=w[cur-1])
p=next[p];
next[cur]=++p;
}
printf("%d\n",match(w,t,next));
}
return 0;
}
/*
*Copyright (c)2015,煙臺大學計算機與控制工程學院
*All rights reserved.
*作 者:單昕昕
*完成日期:2015年8月16日
*版 本 號:v1.0
*/
//nextval陣列
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxw=10000+10;
const int maxt=1000000+10;
int match(char w[],char s[],int next [])
{
int cnt=0,p=0,i=0,slen,wlen;
slen=strlen(s);
wlen=strlen(w);
while(i<slen)
{
if(s[i]==w[p])
{
++i;
++p;
}
else if(p>=0)
{
p=next[p];
}
else
{
++i;
p=0;
}
if(p==wlen)
{
++cnt;
p=next[p];
}
}
return cnt;
}
int main()
{
int loop;
scanf("%d",&loop);
while(loop--)
{
char w[maxw],t[maxt];
scanf("%s%s",w,t);
int nextval[maxw],i,j;
i=0;
nextval[0]=-1;
j=-1;
while(i<strlen(w))
{
if(j==-1||w[i]==w[j])
{
++i;
++j;
if (w[i]!=w[j])
nextval[i]=j;
else
nextval[i]=nextval[j];
}
else
j=nextval[j];
}
printf("%d\n",match(w,t,nextval));
}
return 0;
}
參見→KMP演算法的next、next value陣列程式碼實現及POJ3461
相關文章
- 模式匹配-KMP演算法模式KMP演算法
- KMP模式匹配演算法KMP模式演算法
- 字串匹配演算法:KMP字串匹配演算法KMP
- KMP字串匹配演算法KMP字串匹配演算法
- 字串匹配KMP演算法初探字串匹配KMP演算法
- KMP Algorithm 字串匹配演算法KMP小結KMPGo字串匹配演算法
- 模式匹配kmp演算法(c++)模式KMP演算法C++
- 字串匹配之KMP《演算法很美》字串匹配KMP演算法
- 字串匹配問題——KMP演算法字串匹配KMP演算法
- 字串匹配-BF演算法和KMP演算法字串匹配演算法KMP
- 字串匹配演算法(三)-KMP演算法字串匹配演算法KMP
- kmp字串匹配,A星尋路演算法KMP字串匹配演算法
- 字串匹配基礎下——KMP 演算法字串匹配KMP演算法
- KMP字串匹配演算法 通俗理解KMP字串匹配演算法
- 神奇的字串匹配:擴充套件KMP演算法字串匹配套件KMP演算法
- 【字串匹配】KMP字串匹配KMP
- 快速字串匹配一: 看毛片演算法(KMP)字串匹配演算法KMP
- 匹配字串之——KMP演算法深入理解字串KMP演算法
- KMP字串匹配演算法理解(轉)KMP字串匹配演算法
- C#中幾個正規表示式匹配輸入字元的函式C#字元函式
- 字串匹配演算法之 BF 和 KMP 講解字串匹配演算法KMP
- 圖解KMP字串匹配演算法+程式碼實現圖解KMP字串匹配演算法
- KMP字串模式匹配詳解KMP字串模式
- 第五章 字串專題 ---------------- 字串匹配(二)----KMP演算法字串匹配KMP演算法
- 單模式匹配 KMP 演算法 簡易版學習筆記模式KMP演算法筆記
- 【KMP求字串第一個匹配位置】hdu 1711KMP字串
- KMP字串匹配學習筆記KMP字串匹配筆記
- LeetCode_0028. 找出字串第一個匹配項的下標,KMP演算法的實現LeetCode字串KMP演算法
- 【資料結構與演算法】字串匹配(Rabin-Karp 演算法和KMP 演算法)資料結構演算法字串匹配KMP
- KMP演算法KMP演算法
- KMP 演算法KMP演算法
- Authorization Value 用到的幾個字元:冒號字元
- 【大話資料結構C語言】22 串的快速模式匹配演算法(KMP演算法)資料結構C語言模式演算法KMP
- 【KMP求字串匹配次數】 hdu 1686KMP字串匹配
- 一個需求引發的演算法及優化(KMP演算法)演算法優化KMP
- 【演算法】KMP演算法演算法KMP
- 我理解的 KMP 演算法KMP演算法
- 【資料結構與演算法】模式匹配——從BF演算法到KMP演算法(附完整原始碼)資料結構演算法模式KMP原始碼