POJ-1008 Maya Calendar-兩種曆法轉換
Maya Calendar
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 70835 | Accepted: 21783 |
Description
During his last sabbatical, professor M. A. Ya made a surprising discovery about the old Maya calendar. From an old knotted message, professor discovered that the Maya civilization used a 365 day long year, called Haab, which had
19 months. Each of the first 18 months was 20 days long, and the names of the months were pop, no, zip, zotz, tzec, xul, yoxkin, mol, chen, yax, zac, ceh, mac, kankin, muan, pax, koyab, cumhu. Instead of having names, the days of the months were denoted by
numbers starting from 0 to 19. The last month of Haab was called uayet and had 5 days denoted by numbers 0, 1, 2, 3, 4. The Maya believed that this month was unlucky, the court of justice was not in session, the trade stopped, people did not even sweep the
floor.
For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.
Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:
1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .
Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:
Haab: 0. pop 0
Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.
For religious purposes, the Maya used another calendar in which the year was called Tzolkin (holly year). The year was divided into thirteen periods, each 20 days long. Each day was denoted by a pair consisting of a number and the name of the day. They used 20 names: imix, ik, akbal, kan, chicchan, cimi, manik, lamat, muluk, ok, chuen, eb, ben, ix, mem, cib, caban, eznab, canac, ahau and 13 numbers; both in cycles.
Notice that each day has an unambiguous description. For example, at the beginning of the year the days were described as follows:
1 imix, 2 ik, 3 akbal, 4 kan, 5 chicchan, 6 cimi, 7 manik, 8 lamat, 9 muluk, 10 ok, 11 chuen, 12 eb, 13 ben, 1 ix, 2 mem, 3 cib, 4 caban, 5 eznab, 6 canac, 7 ahau, and again in the next period 8 imix, 9 ik, 10 akbal . . .
Years (both Haab and Tzolkin) were denoted by numbers 0, 1, : : : , where the number 0 was the beginning of the world. Thus, the first day was:
Haab: 0. pop 0
Tzolkin: 1 imix 0
Help professor M. A. Ya and write a program for him to convert the dates from the Haab calendar to the Tzolkin calendar.
Input
The date in Haab is given in the following format:
NumberOfTheDay. Month Year
The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.
NumberOfTheDay. Month Year
The first line of the input file contains the number of the input dates in the file. The next n lines contain n dates in the Haab calendar format, each in separate line. The year is smaller then 5000.
Output
The date in Tzolkin should be in the following format:
Number NameOfTheDay Year
The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.
Number NameOfTheDay Year
The first line of the output file contains the number of the output dates. In the next n lines, there are dates in the Tzolkin calendar format, in the order corresponding to the input dates.
Sample Input
3 10. zac 0 0. pop 0 10. zac 1995
Sample Output
3 3 chuen 0 1 imix 0 9 cimi 2801
Source
Central Europe 1995
/*
*Copyright (c)2015,煙臺大學計算機與控制工程學院
*All rights reserved.
*作 者:單昕昕
*完成日期:2015年8月16日
*版 本 號:v1.0
*/
#include <iostream>
using namespace std;
const char a[][20]= {"pop", "no", "zip", "zotz", "tzec", "xul", "yoxkin", "mol", "chen", "yax", "zac", "ceh", "mac", "kankin", "muan", "pax", "koyab", "cumhu","uayet"};
const char b[][20]= {"imix", "ik", "akbal", "kan", "chicchan", "cimi", "manik", "lamat", "muluk", "ok", "chuen", "eb", "ben", "ix", "mem", "cib", "caban", "eznab", "canac", "ahau"};
int main()
{
int t,days,day,year,i,num,word;
string month;
int aa;
char c;
cin>>t;
cout<<t<<endl;
while(t--)
{
cin>>day>>c>>month>>year;
for(i=0; i<19; ++i)
if(month==a[i])
aa=i;
++aa;
days=365*year+(aa-1)*20+day+1;
if(days%260==0)
{
year=days/260-1;
num=13;
word=20;
}
else
{
year=days/260;
num=(days%13==0?13:days%13);
word=(days-1)%20+1;
}
/*cout<<aa<<endl;
cout<<days<<endl;*/
cout<<num<<" "<<b[--word]<<" "<<year<<endl;
}
return 0;
}
相關文章
- 陽曆到陰曆的轉換 (轉)
- Java中將XML轉換為PDF的兩種辦法JavaXML
- Drawable轉換為Bitmap兩種方法
- 用Delphi處理公曆到農曆的轉換 (轉)
- Oracle和JDE日曆轉換Oracle
- heic轉換格式的兩種方法:你get到了嗎
- ABAP和XML資料格式互相轉換的兩種方式XML
- Java中將Excel轉換為JSON的兩種方法JavaExcelJSON
- Windows中兩種多字元與寬字元的轉換方法薦Windows字元
- MySQL普通錶轉換成分割槽表的兩種方法舉例MySql
- PHP獲取農曆、陽曆轉陰曆PHP
- IPv6轉換技術是什麼?淺談IPv6轉換的兩種技術方式
- 公曆日期轉農曆日期
- ISNULL 兩種寫法,得到兩種結果,返回空記錄與nullNull
- 生信分析預處理:plink兩種格式識別與轉換
- [Python] 各種轉換Python
- vue 跳轉的兩種方法Vue
- sparkrdd轉dataframe的兩種方式Spark
- 兩個數換值四種方法實現
- Python實現"數字轉換為十六進位制"的兩種方法
- 學習筆記 ProgressBar三種style 水平兩種寫法筆記
- 談談曆法知識
- 單例模式常用的的兩種寫法單例模式
- 藍橋杯-迴文日期(兩種寫法)
- heic格式轉換jpg怎麼轉?兩步搞定
- 用兩種方法把JSON資料格式轉換為Python的類物件JSONPython物件
- html兩種方法來實現tab切換效果HTML
- 【中科三方】IPv6轉換技術是什麼?淺談IPv6轉換的兩種技術方式
- 建立安裝程式的兩種方法 (轉)
- PHP呼叫java類的兩種方法(轉)PHPJava
- jsp語法轉換為thyemleafJS
- C#將Word轉換成PDF方法總結(基於Office和WPS兩種方案)C#
- DDR3 APP介面的兩種時序寫法APP
- maya採坑
- 【隱式轉換】注意隱式轉換將導致索引無法使用索引
- VB中檔案操作的兩種方式 (轉)
- 兩種Delphi實現Singleton模式方法 (轉)模式
- AJAX 開發的兩種不同的方法(轉)