HDU-OJ-1017 A Mathematical Curiosity-整數對
A Mathematical Curiosity
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 32002 Accepted Submission(s): 10254
Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
Sample Input
1
10 1
20 3
30 4
0 0
Sample Output
Case 1: 2
Case 2: 4
Case 3: 5
Source
Recommend
JGShining
#include<iostream>
using namespace std;
int main()
{
int m,n,t,j,i,k,ans,count;
cin>>t;
for(k=0; k<t; k++)
{
count=0;
if(k)
cout<<endl;
while(cin>>n>>m&&(m||n))
{
ans=0;
for(i=1; i<n; i++)
for(j=i+1; j<n; j++)
{
if((i*i+j*j+m)%(i*j)==0)
ans++;
}
cout<<"Case "<<++count<<": "<<ans<<endl;
}
}
return 0;
}
奇坑無比的一道題!!!
WA了好多次,看了好幾遍題目才整明白!!!
前面那個“1”表示下面有0 0 之前的一個大組測試資料。
所以,一大組測試資料之前的一個整數表示有幾個大組包含若干小組。
還要注意,輸出空行。
相關文章
- Mathematical Problem
- Mathematical算術和聚合操作
- JVM 引數調整對 sortx 的影響JVM
- Problems in Mathematical Analysis (American First Edition)
- Python如何對浮點數進行取整操作?Python
- 整數排序排序
- 在Java中,整數的絕對值不一定是正數Java
- 輸入一個整數,返回這個整數的位數
- PHP操作MongoDB時的整數問題及對策UQPHPMongoDB
- js小數轉整數JS
- 大整數操作
- 整數型別型別
- 求正整數
- 整數溢位
- 【C語言】編寫一個函式,將一個數字字串轉換成該字串對應的數字(包括正整數、負整數)。C語言函式字串
- alanwang[GDOU] 用選擇排序法對10個整數排序排序
- python整數和變數Python變數
- 2034 整數的個數
- MySQL引數調整MySql
- 06:整數奇偶排序排序
- 整數型別(轉)型別
- JavaScript判斷整數或者小數JavaScript
- 四位整數位數拆分
- true--按了整數鍵, false--按了非整數鍵False
- 如何查詢總和等於給定數字的整數陣列中的所有對陣列
- 有一組整數資料,全部除以一個整數a,使得餘數是同n種數字,如何計算出這個整數a的全部可能。
- PHP取整,四捨五入取整、向上取整、向下取整、小數擷取PHP
- JQuery 判斷 正整數jQuery
- 字串轉換整數(atoi)字串
- Java整數緩衝區Java
- 轉換成為整數
- 1487 大批整數排序排序
- Hack Python 整數物件Python物件
- 生成隨機整數方法隨機
- AIX fsfastpath 引數調整AIAST
- 長整數的基本操作
- 7.整數反轉
- 調整陣列順序使奇數位於偶數前面,偶數和偶數之間的相對位置不變陣列