HDU-OJ-1017 A Mathematical Curiosity-整數對

kewlgrl發表於2015-08-08

A Mathematical Curiosity

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32002    Accepted Submission(s): 10254


Problem Description
Given two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.
 

Input
You will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.
 

Output
For each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.
 

Sample Input
1 10 1 20 3 30 4 0 0
 

Sample Output
Case 1: 2 Case 2: 4 Case 3: 5
 

Source
 

Recommend
JGShining

#include<iostream>
using namespace std;
int main()
{
    int m,n,t,j,i,k,ans,count;
    cin>>t;
    for(k=0; k<t; k++)
    {
        count=0;
        if(k)
            cout<<endl;
        while(cin>>n>>m&&(m||n))
        {
            ans=0;
            for(i=1; i<n; i++)
                for(j=i+1; j<n; j++)
                {
                    if((i*i+j*j+m)%(i*j)==0)
                        ans++;
                }
            cout<<"Case "<<++count<<": "<<ans<<endl;
        }
    }
    return 0;
}

奇坑無比的一道題!!!
WA了好多次,看了好幾遍題目才整明白!!!
前面那個“1”表示下面有0 0 之前的一個大組測試資料。
所以,一大組測試資料之前的一個整數表示有幾個大組包含若干小組。
還要注意,輸出空行。

相關文章