POJ- 3094 Quicksum-給規律求字元值

kewlgrl發表於2015-08-07
Quicksum
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 15043   Accepted: 10505

Description

A checksum is an algorithm that scans a packet of data and returns a single number. The idea is that if the packet is changed, the checksum will also change, so checksums are often used for detecting transmission errors, validating document contents, and in many other situations where it is necessary to detect undesirable changes in data.

For this problem, you will implement a checksum algorithm called Quicksum. A Quicksum packet allows only uppercase letters and spaces. It always begins and ends with an uppercase letter. Otherwise, spaces and letters can occur in any combination, including consecutive spaces.

A Quicksum is the sum of the products of each character's position in the packet times the character's value. A space has a value of zero, while letters have a value equal to their position in the alphabet. So, A=1, B=2, etc., through Z=26. Here are example Quicksum calculations for the packets "ACM" and "MID CENTRAL":

        ACM: 1*1  + 2*3 + 3*13 = 46

MID CENTRAL: 1*13 + 2*9 + 3*4 + 4*0 + 5*3 + 6*5 + 7*14 + 8*20 + 9*18 + 10*1 + 11*12 = 650

Input

The input consists of one or more packets followed by a line containing only # that signals the end of the input. Each packet is on a line by itself, does not begin or end with a space, and contains from 1 to 255 characters.

Output

For each packet, output its Quicksum on a separate line in the output.

Sample Input

ACM
MID CENTRAL
REGIONAL PROGRAMMING CONTEST
ACN
A C M
ABC
BBC
#

Sample Output

46
650
4690
49
75
14
15

Source


下面給出兩種方法,一種是不開陣列的,一種是開陣列的。

#include <iostream>
#include <cstring>
#include <stdio.h>
#include <cmath>
using namespace std;

int main()
{
    int i,sum;
    char c[256];
    while(gets(c),c[0]!='#')
    {
        sum=0;
        for(i=0; c[i]!='\0'; ++i)
            if(c[i]!=' ')
                sum+=((i+1)*(c[i]-'A'+1));
        cout<<sum<<endl;
    }
    return 0;
}




#include <iostream>
#include <cstring>
#include <stdio.h>
#include <cmath>
using namespace std;

int main()
{
    int i=1,sum=0;
    char c;
    while(1)
    {
        c=getchar();
        if(c=='#')
            return 0;
        if(c=='\n')
        {
            cout<<sum<<endl;
            i=1,sum=0;
            continue;
        }
        if(c!=' ')
            sum+=(i*(c-'A'+1));
        ++i;
    }
    return 0;
}


相關文章