POJ-1552 Doubles-二倍關係

kewlgrl發表於2015-08-07
Doubles
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 20109   Accepted: 11669

Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list 
1 4 3 2 9 7 18 22

your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9. 

Input

The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.

Output

The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output

3
2
0

Source


//就是找在每一組內,有幾個數對滿足一個數是另一個數的二倍
#include <iostream>
using namespace std;
int main()
{
    int a[20],count,i,j,n;
    cin>>a[0];
    while(a[0]!=-1)
    {
        for(n=1;; ++n)
        {
            cin>>a[n];
            if(a[n]==0)
                break;
        }
        count=0;
        for(i=0; i<n-1; ++i)
        {
            for(j=i+1; j<n; ++j)
            {
                if((a[i]*2==a[j])||a[j]*2==a[i])
                    ++count;
            }
        }
        cout<<count<< endl;
        cin>>a[0];
    }
    return 0;
}


相關文章