POJ-1552 Doubles-二倍關係
Doubles
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 20109 | Accepted: 11669 |
Description
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program
to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list
your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.
1 4 3 2 9 7 18 22
your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.
Input
The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with the integer 0, which is not
considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
Output
The output will consist of one line per input list, containing a count of the items that are double some other item.
Sample Input
1 4 3 2 9 7 18 22 0 2 4 8 10 0 7 5 11 13 1 3 0 -1
Sample Output
3 2 0
Source
//就是找在每一組內,有幾個數對滿足一個數是另一個數的二倍
#include <iostream>
using namespace std;
int main()
{
int a[20],count,i,j,n;
cin>>a[0];
while(a[0]!=-1)
{
for(n=1;; ++n)
{
cin>>a[n];
if(a[n]==0)
break;
}
count=0;
for(i=0; i<n-1; ++i)
{
for(j=i+1; j<n; ++j)
{
if((a[i]*2==a[j])||a[j]*2==a[i])
++count;
}
}
cout<<count<< endl;
cin>>a[0];
}
return 0;
}
相關文章
- 關係
- 關聯關係與依賴關係的區別
- 【集合論】序關係 ( 哈斯圖示例 | 整除關係哈斯圖 | 包含關係哈斯圖 | 加細關係哈斯圖 )
- FAILGROUP和REDUNDANCY之間的關係關係!AI
- 關係模型模型
- 資料關係比較:相關性 vs 因果關係
- 關係型資料庫,何以稱為“關係”資料庫
- 矩陣:橫向關係和縱向關係矩陣
- 【集合論】二元關係 ( 二元關係記法 | A 到 B 的二元關係 | 二元關係個數 | 二元關係示例 )
- 物件導向程式設計程式碼詳解(依賴關係,關聯關係,組合關係)物件程式設計
- 統計學三大相關係數之Pearson相關係數、Spearman相關係數
- 表的關聯關係
- Hibernate關聯關係
- 資料庫 - 關係代數與關係運算資料庫
- Elasticsearch 父子關係Elasticsearch
- 也說關係
- 企業關係
- 與if的關係
- sqlalchemy關係操作SQL
- 集合類關係
- 【集合論】關係閉包 ( 關係閉包求法 | 關係圖求閉包 | 關係矩陣求閉包 | 閉包運算與關係性質 | 閉包複合運算 )矩陣
- CRM客戶關係管理系統管理良好業務關係
- Windows系統中owner owned 關係和 parent child關係Windows
- mybatis關聯關係對映MyBatis
- python 類關聯關係Python
- 關於PR 和PO關係
- 關於CMP的關係,求教...
- “光棍合娶老婆”教授反擊:男女關係就是交易關係
- Linux程式關係Linux
- Cookie與Session 關係CookieSession
- session和cookie關係SessionCookie
- Maven 依賴關係Maven
- Future,FutureTaskCallable關係
- MongoDB 關係實現MongoDB
- ORM建立表關係ORM
- ElasticSearch系列--父子關係Elasticsearch
- 職場人際關係
- 互動與關係