長期的物種進化使自然界出現了生活在陸地上的陸生動物和生活在水中的水生動物。根據已有主函式編寫動物類,陸生動物類和水生動物類。
YTU-OJ-Problem H: 虛擬函式練習:動物2
Problem H: 虛擬函式練習:動物2
Time Limit: 1 Sec Memory Limit: 128 MBSubmit: 425 Solved: 289
[Submit][Status][Web Board]
Description
Input
動物的體長,體重,性別;
水生動物的體長,體重,性別,游泳速度;
陸生動物的體長,體重,性別,奔跑速度;
Output
動物的體長,體重,性別;
水生動物的體長,體重,性別,游泳速度;
陸生動物的體長,體重,性別,奔跑速度;
Sample Input
52 22 f
62 32 m 122
72 42 m 102
Sample Output
height:52
weight:22
sex:f
height:62
weight:32
sex:m
swimming_speed:122
height:72
weight:42
sex:m
running_speed:102
HINT
主函式已給定如下,提交時不需要包含,會自動新增到程式尾部
/*c++程式碼*/
int main()
{
int a,b,s,r;
char c;
animal *p;
cin>>a>>b>>c;
animal pa(a,b,c);
p=&pa;
p->display();
cin>>a>>b>>c>>s;
aqu_animal pb(a,b,c,s);
p=&pb;
p->display();
cin>>a>>b>>c>>r;
ter_animal pc(a,b,c,r);
p=&pc;
p->display();
return 0;
}
#include <iostream>
using namespace std;
class animal
{
protected:
int height;
int weight;
char sex;
public:
animal() {}
animal(int h,int w,char s):
height(h),weight(w),sex(s) {}
void virtual display()
{
cout<<"height:"<<height<<endl;
cout<<"weight:"<<weight<<endl;
cout<<"sex:"<<sex<<endl;
}
};
class aqu_animal:public animal
{
protected:
int swimming_speed;
public:
aqu_animal() {}
aqu_animal(int h,int w,char s,int s_p):
animal(h,w,s),swimming_speed(s_p) {}
void display()
{
cout<<"height:"<<height<<endl;
cout<<"weight:"<<weight<<endl;
cout<<"sex:"<<sex<<endl;
cout<<"swimming_speed:"<<swimming_speed<<endl;
}
};
class ter_animal:public animal //陸生動物
{
protected:
int running_speed; //游泳速度
public:
ter_animal() {}
ter_animal(int h,int w,char s,int r_p):
animal(h,w,s),running_speed(r_p) {}
void display()
{
cout<<"height:"<<height<<endl;
cout<<"weight:"<<weight<<endl;
cout<<"sex:"<<sex<<endl;
cout<<"running_speed:"<<running_speed<<endl;
}
};
int main()
{
int a,b,s,r;
char c;
animal *p;
cin>>a>>b>>c;
animal pa(a,b,c);
p=&pa;
p->display();
cin>>a>>b>>c>>s;
aqu_animal pb(a,b,c,s);
p=&pb;
p->display();
cin>>a>>b>>c>>r;
ter_animal pc(a,b,c,r);
p=&pc;
p->display();
return 0;
}
相關文章
- 虛擬函式,虛擬函式表函式
- 虛擬函式 純虛擬函式函式
- YTU-OJ-Problem D: C++習題 虛擬函式-計算圖形面積C++函式
- 介面、虛擬函式、純虛擬函式、抽象類函式抽象
- 虛擬函式函式
- [Lang] 虛擬函式函式
- C++中抽象類、虛擬函式和純虛擬函式C++抽象函式
- C++中的虛擬函式與虛擬函式表 (轉)C++函式
- C++虛擬函式學習總結C++函式
- 【C++筆記】虛擬函式(從虛擬函式表來解析)C++筆記函式
- 【C++筆記】虛擬函式(從虛擬函式概念來解析)C++筆記函式
- C++ 虛擬函式C++函式
- C++虛擬函式C++函式
- 虛擬函式釋義函式
- 用虛擬函式實現事件驅動! (轉)函式事件
- c++虛擬函式表C++函式
- 虛擬函式的呼叫原理函式
- C++虛擬函式bugC++函式
- 虛擬函式與多型函式多型
- mysql函式練習題MySql函式
- 虛擬函式的實現原理函式
- C++ 介面(純虛擬函式)C++函式
- C++ 中的虛擬函式C++函式
- C++ 虛擬函式表剖析C++函式
- const修飾虛擬函式函式
- 虛擬函式實現原理(轉)函式
- [CareerCup] 13.3 Virtual Functions 虛擬函式Function函式
- C++ 虛擬函式表解析C++函式
- C++多型(上)——虛擬函式、虛表C++多型函式
- 深入C++成員函式及虛擬函式表C++函式
- C++箴言:避免解構函式呼叫虛擬函式C++箴言函式
- Python函式練習題Python函式
- 函式指標練習題函式指標
- 抽象基類和純虛擬函式抽象函式
- C++多型之虛擬函式C++多型函式
- C++中虛擬函式的作用C++函式
- C++虛擬函式解析(轉載)C++函式
- C++ 虛擬函式和虛繼承淺析C++函式繼承