YT05-動態歸劃求解課堂題目-1003—數塔-(6.21日-煙臺大學ACM預備隊解題報告)

kewlgrl發表於2015-07-15

Humble Numbers

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 30   Accepted Submission(s) : 13

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence

Input

The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.

Sample Input

1
2
3
4
11
12
13
21
22
23
100
1000
5842
0

Sample Output

The 1st humble number is 1.
The 2nd humble number is 2.
The 3rd humble number is 3.
The 4th humble number is 4.
The 11th humble number is 12.
The 12th humble number is 14.
The 13th humble number is 15.
The 21st humble number is 28.
The 22nd humble number is 30.
The 23rd humble number is 32.
The 100th humble number is 450.
The 1000th humble number is 385875.
The 5842nd humble number is 2000000000.

Source

University of Ulm Local Contest 1996 



•找出N以內含有質因子2,3,5,7的數字並且從小到大排序,注意,“1”為預設值。
•看輸出資訊,存在另一個小陷阱
•The1sthumble number is 1.
•The2ndhumble number is 2.
•The3rdhumble number is 3.
•The4thhumble number is 4.
•The11thhumble number is 12.
•The 12thhumble number is 14.
•The13thhumble number is 15.

#include<iostream>
using namespace std;
int max(int a,int b)
{
    if(b>a)return a;
    else return b;
}
int main()
{
    int num[6000];
    int i,j,k,l,q,n;
    i=j=k=l=1;
    num[1]=1;
    for(q=2;q<=5845;q++)
    {
        num[q]=max(num[i]*2,max(num[j]*3,max(num[k]*5,num[l]*7)));
        if(num[q]==num[i]*2)
            i++;
        if(num[q]==num[j]*3)
            j++;
        if(num[q]==num[k]*5)
            k++;
        if(num[q]==num[l]*7)
            l++;
    }
while(cin>>n&&n!=0)
    {
        cout<<"The "<<n;
        if(n%10==1&&n%100!=11)cout<<"st ";
        else if(n%10==2&&n%100!=12)cout<<"nd ";
        else if(n%10==3&&n%100!=13)cout<<"rd ";
        else  cout<<"th ";
        cout<<"humble number is "<<num[n]<<"."<<endl;
    }
    return 0;
}



相關文章