YT04-貪心課後練習-1002—Repair the Wall-(6.14日-煙臺大學ACM預備隊解題報告)

kewlgrl發表於2015-06-21

Repair the Wall

Time Limit : 5000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 33   Accepted Submission(s) : 14

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.

When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty's walls were made of wood.

One day, Kitty found that there was a crack in the wall. The shape of the crack is 
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(鋸子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.

Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?

Input

The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).

Output

For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print "impossible" instead.

Sample Input

5 3
3 2 1
5 2
2 1

Sample Output

2
impossible

Author

linle

Source

HDU 2007-10 Programming Contest

143—1  徐海超

題意是說修補屋子的1*n矩形漏洞,給定一些木塊用最少的木塊修補好裂縫,可使用鋸子裁掉多餘部分,應該算是簡單的貪心演算法,從大到小排序後累加,大於就可以跳出迴圈。

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int main()
{
    int L,N,a[100],i,j,temp;
    while(cin>>L>>N && L!=EOF)
    {
        for(i=0; i<N; i++)
            cin>>a[i];
        for(i=0; i<N; i++)
        {
            for(j=0; j<N-1; j++)
                if(a[j]<a[j+1])
                {
                    temp=a[j];
                    a[j]=a[j+1];
                    a[j+1]=temp;
                }
        }
        int d=0;
        for(i=0; i<N; i++)
        {
            d=d+a[i];
            if(L<=d)
            {
                cout<<i+1<<endl;
                break;
            }
        }
        if(L>d)
            cout<<"impossible"<<endl;
    }
    return 0;
}
bool cmp(int a,int b)
{
    return a>b;
}



相關文章