N個數到一個數的距離和最小。這個數一定是他們的中位數。
dp[i][j]=前i個點,j個office的距離。
dp[i][j]=min(dp[k-1][j-1]+w[k][i]) w[k][i]是k..i 修一個office的距離。
Post Office
Description
There is a straight highway with villages alongside the highway. The highway is represented as an integer axis, and the position of each village is identified with a single integer coordinate. There are no two villages in the same position. The distance between
two positions is the absolute value of the difference of their integer coordinates.
Post offices will be built in some, but not necessarily all of the villages. A village and the post office in it have the same position. For building the post offices, their positions should be chosen so that the total sum of all distances between each village and its nearest post office is minimum. You are to write a program which, given the positions of the villages and the number of post offices, computes the least possible sum of all distances between each village and its nearest post office. Input
Your program is to read from standard input. The first line contains two integers: the first is the number of villages V, 1 <= V <= 300, and the second is the number of post offices P, 1 <= P <= 30, P <= V. The second line contains V integers in increasing
order. These V integers are the positions of the villages. For each position X it holds that 1 <= X <= 10000.
Output
The first line contains one integer S, which is the sum of all distances between each village and its nearest post office.
Sample Input 10 5 1 2 3 6 7 9 11 22 44 50 Sample Output 9 Source |
[Submit] [Go Back] [Status] [Discuss]
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=500;
const int INF=0x3f3f3f3f;
int dp[maxn][maxn/10],w[maxn][maxn];
int n,m,a[maxn];
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=1;i<=n;i++)
{
scanf("%d",a+i);
}
memset(w,63,sizeof(w));
for(int i=1;i<=n;i++)
{
for(int j=i;j<=n;j++)
{
int mid=(i+j)/2,temp=0;
for(int k=i;k<=j;k++)
{
temp+=abs(a[k]-a[mid]);
}
w[i][j]=temp;
}
}
memset(dp,63,sizeof(dp));
for(int i=1;i<=n;i++)
{
dp[i][1]=w[1][i];
}
for(int i=2;i<=n;i++)
{
for(int j=2;j<=m;j++)
{
if(j>=i)
{
dp[i][j]=0;
continue;
}
for(int k=1;k<i;k++)
{
dp[i][j]=min(dp[i][j],dp[k][j-1]+w[k+1][i]);
}
}
}
printf("%d\n",dp[n][m]);
}
return 0;
}