ZOJ 1048 Financial Management
Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.
Input Format:
The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
Output Format:
The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters
in the output.
Sample Input:
100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75
Sample Output:
$1581.42
中文題意:統計某人12個月的銀行帳戶餘額的平均數
中文翻譯:
題目大意:
解題思路:只要輸出一組資料
難點詳解:
關鍵點:sum的型別是實型
解題人:lingnichong
解題時間:2014/7/30 11:09
*/
#include<stdio.h>
int main()
{
int i;
float n,sum=0;
for(i=0;i<12;i++)
{
scanf("%f",&n);
sum+=n;
}
printf("$%.2f\n",sum/12);
}
相關文章
- POJ-1004 Financial Management-計算平均工資NaN
- 【PAT乙級】1048 數字加密加密
- 1048 數字加密(字首和思想)加密
- 洛谷p1048 採藥
- Financial Crisis(HDU-3749)NaN
- ZOJ First Digit(瞎搞)Git
- Diablo III ZOJ - 3769
- PAT-B 1048 數字加密【字串】加密字串
- ZOJ 3732 Graph ReconstructionStruct
- PAT1048數字加密(java實現)加密Java
- oracle segment space management and extent management幾則Oracle
- AC050--Introduction to Financial AccountingNaN
- ZOJ 3789 Gears(並查集)並查集
- ZOJ 1013 Great Equipment(DP)UI
- AC010--Preparing Financial StatementsNaN
- Memory Management in RustRust
- PostgreSQL Role ManagementSQL
- SQL management baseSQL
- Credit Management(SD)
- SQL Plan ManagementSQL
- ZOJ 3875 Lunch Time(結構體排序)結構體排序
- ZOJ 2745 01-K Code(DP)(轉)
- ZOJ Problem Set - 1094 Matrix Chain MultiplicationAI
- ZOJ Problem Set - 1016 ParencodingsEncoding
- 動態規劃-ZOJ 1 163 THE STAIRCASES動態規劃AI
- ZOJ 4846 GCD Reduce (數學分析題)GC
- ZOJ Consecutive Blocks(左右指標移動)BloC指標
- zoj 1093 dp Monkey and BananaNaN
- Oracle Cluster Time ManagementOracle
- memory management unit (MMU)
- Linux Memory ManagementLinux
- SQL Plan Management(SPM)SQL
- dispute management and new ES
- Management on database linkDatabase
- Management of Remote Dependencies (252)REM
- Master Data Management UpdateAST
- Management of Materials With Shelf Life
- ZOJ Problem Set - 3708 Density of Power Network