HDU 1039 Easier Done Than Said?
Easier Done Than Said?
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 7554 Accepted Submission(s): 3737
Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them
and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.
FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:
It must contain at least one vowel.
It cannot contain three consecutive vowels or three consecutive consonants.
It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.
(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:
It must contain at least one vowel.
It cannot contain three consecutive vowels or three consecutive consonants.
It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.
(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.
Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.
Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.
Sample Input
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end
Sample Output
<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.
本來沒什麼的題,被我的忽略,搞了一下午才搞出來!!!真的無語了。。。下次小心點,繼續加油。。。
#include<stdio.h>
#include<string.h>
char str[25];
int main()
{
int i,len,b[5],c[30]={0};
c[1]=1;c[5]=1;c[9]=1;c[15]=1;c[21]=1;
while(gets(str),strcmp(str,"end"))
{
b[0]=0;
b[1]=b[2]=1;
len=strlen(str);
for(i=0;i<len;i++)
{
if(str[i]=='a'||str[i]=='e'||str[i]=='i'||str[i]=='o'||str[i]=='u')
b[0]=1;
if(str[i]==str[i+1]&&str[i]!='e'&&str[i]!='o')
{
b[1]=0;
break;
}
}
for(i=0;i<len;i++)
{
//if(str[i]==str[i+1]&&str[i+1]==str[i+2])
if(c[str[i]-96]==c[str[i+1]-96]&&c[str[i+1]-96]==c[str[i+2]-96]) // 等 價 條 件 搞 錯了
{
b[2]=0;
break;
}
}
if(b[0]&&b[1]&&b[2])
printf("<%s> is acceptable.\n",str);
else
printf("<%s> is not acceptable.\n",str);
}
return 0;
}
相關文章
- HDU 1039 Easier Done Than Said?AI
- SAP Spartacus Definition of Done
- coca would have done 搭配
- The Buy fifa coins Xbox is saidAI
- Mourinho said Chelsea are not even close winningAI
- hihocoder 1039 字元消除 (列舉+模擬)字元
- jscalpel A small feature library that makes it easier to manipulate objectsJSObject
- deferred中done和then的區別
- wireshark error: There are no interfaces on which a capture can be done.ErrorAPT
- Alert Dialog "Done"按鈕定義.
- DNS: More than just namesDNS
- Why Java is better than .NETJava
- 20 compliments that needs to be said to my girl from time to timeAI
- Ubuntu:make: Nothing to be done for `all' 解決方法Ubuntu
- 2-AP-14: Create procedures with parameters to organize code and make it easier to reuse.
- 12.27 He noted down everything i saidAI
- 專案實踐-進度遊戲(2):90% Done遊戲
- Centering HTML elements larger than their parentsHTML
- 什麼是產品經理的“Jobs to Be Done”框架?框架
- Freetype 安裝時提示 make: Nothing to be done for `unix'
- linux shell之do done及for 迴圈指令碼Linux指令碼
- 企業與開源社群的合作策略...[done:0%]
- 21行滿分程式碼:1039 到底買不買 (20分)
- kafka 錯誤: larger than available brokersKafkaAI
- CTF-safer-than-rot13-writeup
- More than one file was found with OS independent path
- which situation IN is better than exist, and vice versa.
- Why should we copy blocks rather than retain?BloCAI
- POJ 1039-Pipe(計算幾何-線段相交、求交點)
- CF1039D You Are Given a Tree (樹形 dp + 貪心 + 根號分治)
- 隨筆:MYSQL_BIN_LOG::COND_done 是什麼MySql
- Better than better,白山EC2.0釋出
- Archived redolog is (significant) smaller than the redologfileHiveNifi
- gem5 CPU ISA level is lower than requiredUI
- SG 函式初步 HDU 1536 && HDU 1944函式
- Shape of HDU
- HDU4787
- hdu5532