[PAT]1027. Colors in Mars (20)@Java實現

JacobGo發表於2017-10-26

1027. Colors in Mars (20)

時間限制
400 ms
記憶體限制
65536 kB
程式碼長度限制
16000 B
判題程式
Standard
作者
CHEN, Yue

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input

Each input file contains one test case which occupies a line containing the three decimal color values.

Output

For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.

Sample Input
15 43 71
Sample Output
#123456




package go.jacob.day1026;

import java.util.Scanner;

/**
 * 簡單題,但要注意,輸出的時候每一個顏色固定兩位
 * @author Administrator
 *
 */
public class Demo1 {
	static char[] c = new char[] { 'A', 'B', 'C' };

	public static void main(String[] args) {
		Scanner sc = new Scanner(System.in);
		String[] color = new String[3];
		for (int i = 0; i < 3; i++) {
			color[i] = solve(sc.nextInt());
		}
		System.out.println("#" + color[0] + color[1] + color[2]);
		sc.close();
	}

	// 十進位制轉十三進位制
	private static String solve(int num) {
		StringBuilder res = new StringBuilder();
		if (num == 0)
			return "00";
		while (num != 0) {
			int t = num % 13;
			if (t < 10)
				res.append(t);
			else
				res.append(c[t - 10]);
			num /= 13;
		}
		String r = res.reverse().toString();
		if (r.length() == 1)
			return "0" + r;
		else
			return r;
	}
}



相關文章