[PAT]1027. Colors in Mars (20)@Java實現
1027. Colors in Mars (20)
People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.
Input
Each input file contains one test case which occupies a line containing the three decimal color values.
Output
For each test case you should output the Mars RGB value in the following format: first output "#", then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a "0" to the left.
Sample Input15 43 71Sample Output
#123456
package go.jacob.day1026;
import java.util.Scanner;
/**
* 簡單題,但要注意,輸出的時候每一個顏色固定兩位
* @author Administrator
*
*/
public class Demo1 {
static char[] c = new char[] { 'A', 'B', 'C' };
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
String[] color = new String[3];
for (int i = 0; i < 3; i++) {
color[i] = solve(sc.nextInt());
}
System.out.println("#" + color[0] + color[1] + color[2]);
sc.close();
}
// 十進位制轉十三進位制
private static String solve(int num) {
StringBuilder res = new StringBuilder();
if (num == 0)
return "00";
while (num != 0) {
int t = num % 13;
if (t < 10)
res.append(t);
else
res.append(c[t - 10]);
num /= 13;
}
String r = res.reverse().toString();
if (r.length() == 1)
return "0" + r;
else
return r;
}
}
相關文章
- PAT-A Java實現Java
- [PAT]Table Tennis (30)Java實現Java
- PAT1044火星數字(java實現)Java
- PAT1043 輸出PATest(java實現)Java
- PAT1048數字加密(java實現)加密Java
- PAT1029 舊鍵盤(java實現)Java
- PAT1076 WiFi密碼(java實現)WiFi密碼Java
- PAT1004成績排名(java實現)Java
- PAT乙級——1093(字串匹配)Java實現字串匹配Java
- Mars Chen影片XML程式碼實現XML
- PAT1019 數字黑洞(java實現)Java
- PAT1033 舊鍵盤打字(java實現)Java
- [PAT]1028. List Sorting (25)@Java實現Java
- PAT1078字串壓縮與解壓(java實現)字串Java
- Sort Colors leetcode javaLeetCodeJava
- PAT Basic 1057. 數零壹(20)(C語言實現)C語言
- PAT1077互評成績計算(java實現)Java
- PAT乙級——1092(陣列排序 自定義sort)Java實現陣列排序Java
- PAT1008 陣列元素迴圈右移問題(java實現)陣列Java
- What time is it on Mars?
- HTML 21 - ColorsHTML
- [b01lers2020]Life on Mars 1
- Mars演算法實踐——人臉識別演算法
- PAT甲級1126~1130|C++實現C++
- CSS border-colorsCSS
- The Colors OF IOS7iOS
- T422088 「LAOI-4」Colors
- PAT甲級1154 Vertex Coloring (25分)|C++實現C++
- Leetcode Sort ColorsLeetCode
- PAT甲級1122 Hamiltonian Cycle (25分)|C++實現C++
- Six Colors:2016年蘋果表現報告 家居/物聯網得分較低蘋果
- MaxCompute Mars開發指南
- CSS3 border-colorsCSSS3
- Leetcode-Sort ColorsLeetCode
- css12 CSS HEX ColorsCSS
- 2017搜狐筆試題(Java實現)筆試Java
- java實現樹Java
- Java實現-子集Java