hdu 1792 A New Change Problem(數論)

acm_cxq發表於2016-06-17

A New Change Problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1236    Accepted Submission(s): 737


Problem Description
Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.
 

Input
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line. 
 

Output
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.
 

Sample Input
2 3 3 4
 

Sample Output
1 1 5 3
題意:求a和b的最大不能組合數和不能組合數的個數

思路:a和b的最大不能組合數為(a-1)*b-a,不能組合數的個數為(a-1)*(b-1)/2

程式碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;

int main()
{
    int n,m;
    while(~scanf("%d %d",&m,&n))
    {
        printf("%d %d\n",(m-1)*n-m,(n-1)*(m-1)/2);
    }
    return 0;
}



相關文章