AIX常用命令集錦

lpwebnet發表於2013-11-21
命令:
telnet ip        連線到小型機
login: team08 password:   登陸  
passwd           更改口令
logout           退出(直接退出系統)
exit             退出/ctrl + d(退出當前的shell)
date             列出當前日期時間(加引數改變輸出格式)
cal              察看年月日資訊
clear            清屏
echo             回顯
banner           大字元回顯(超過10個只顯示前10個)
who              檢視已登陸的使用者
who am i         檢視當前使用者
finger teamxx    返回使用者相關資訊(不加引數指所有使用者包括未登陸的)
mail teamxx      傳送郵件 (詳見2-22)
write teamxx     傳送訊息給其他使用者
wall             廣播
talk  teamxx     與其他使用者聊天
mesg  n/y        是否允許其他使用者向當前使用者傳送訊息
man              幫助(詳見3-4)
pwd              檢視當前目錄
ls               列出當前目錄下的內容-a察看隱藏檔案 -R遞迴檢視 -l檢視詳細資訊 -i檢視i節點號 -d目錄本身資訊(4-19)
cd               轉到指定目錄 預設$HOME目錄
mkdir            建立目錄 -p建立多級目錄
rmdir            刪除目錄(不能刪除當前目錄或父目錄且必須為空) -p刪除多級目錄
istat            檢視檔案i_node表的資訊
touch            更新檔案的訪問和修改時間;建立空檔案
cp source target 複製檔案
mv source target 移動檔案或重新命名
cat              檢視檔案內容(如果多個檔案內容首尾相連)
pg               分屏察看檔案內容 回車換屏
more             分屏察看檔案內容 空格換屏回車換行
wc               統計檔案內容 -c位元組數 -l行數 -w詞數(5-17)
ln source target 連結檔案(相當於另起一個名字。i-node相同,一改都改,一刪其他不刪)
rm               刪除檔案 -i確認刪除 -r遞迴刪除
Qprt             排隊檔案(5-26)
qchk             顯示當前佇列狀態
qcan             取消列印
chmod mod file   更改檔案許可權(6)
Vi file          建立/編輯檔案(7)
ksh              進入一個shell
set              檢視變數
tee              讀到標準輸入並儲存到特定檔案(8-35)
echo $$          檢視當前程式號 變數$代表程式號
ps -u teamxx            檢視程式資訊 -f詳細資訊
export variable=value   定義全域性變數
ksh hello               執行指令碼(hello)另起一個shell (10-23)
hello                   執行指令碼(hello)hello必須在PATH變數中設定好
. hello                 執行指令碼(hello)
 kill -x pid             終止程式/ctrl-c(前臺) 後臺只能用kill -9必殺 -15預設 後跟檔案的PID號 (11-11)
nohup + commond         程式不因使用者退出而終止
Jobs                    列出所有後臺執行或前臺暫停的程式(11-20)
fg %         後臺程式轉成前臺
bg %jobnumber           前臺程式轉成後臺
alias p='ps -ef'        定義別名(alias 顯示所有定義的別名)
unalias p               取消別名
fc -l n                 列出最後執行的n條命令/$history n 預設16條
r m                     執行最後執行的以m開頭的命令
r n                     執行第n條命令(快取區中的)
18 find path expression    從指定目錄開始查詢具有某一特徵的檔案,並作處理。(13-4)
grep -x expression file 從檔案中查詢特定模式的字串,並顯示輸出相應行。-v顯示不匹配的 -c顯示匹配行數
sort -x + .             對檔案內容排序(預設安各行第一個字元排)  (13-42)
head -n file            顯示檔案內容的前n行
tail -n file            顯示檔案內容的最後n行
tail +n file            顯示檔案內容的第n行直到最後
ftp teamxx              檔案傳輸(13-54)
xargs                   為後續命令組建引數列表(14-4)
which find grep         從PATH中找可執行檔案(14-15)
whereis find grep       從標準目錄中找
whence -pv find grep    從PATH中找(可進行別名查詢)shell內建命令
file                    判斷檔案型別 -f判斷目錄下的檔案的型別
diff -x file1 file2     比較文字檔案的不同並顯示 (14-25)
cmp file1 file2         比較文字/非文字檔案的不同並顯示 -l
cut                     從標準輸入或檔案中剪下指定範圍的字元 (中文書153)
dircmp -d dir1 dir2     比較目錄的不同 (14-30)
compress -v file        壓縮檔案
uncompress file.z       解壓檔案
zcat file.z             不解壓檢視
cat -vte file           檢視包含特殊符號的檔案(14-36)
expr                    運算(15-11)

系統和網路命令:

邏輯卷有否 "stale" 的狀態
# lsvg -l rootvg


記憶體交換區的使用率是否超過 70%
# lsps -a

系統效能是否有瓶頸
# topas
# vmstat 1 10

# iostat 1 10

網路與通訊檢查
# ifconfig -a
# netstat -in


#lsattr -El inet0 //路由的檢測


ls -l /image.data //看看系統有沒有備份的 image 檔案,記錄最後備份日期


lsvg -l rootvg //察看有否符合要求的資料備份和保護

如何察看資料保護方式 RAID10/RAID5,RAID 的Hotspare 屬性是否開啟

#smitty ssaraid? Change/Show Attributes of an SSA RAID Array
檢查Enable Use of Hot Spares屬性是否為YES


系統 Dump 設定是否正確
# sysdumpdev -l

HACMP 測試
# /usr/sbin/cluster/diag/clconfig -v '-tr'  // Cluster Verification 輸出結果無Fail
# /lssrc -g cluster


1、機器型號
# uname -uM
IBM,7029-6E3 IBM,01100550A

2、檢查系統硬體裝置故障燈是否有亮

3、系統錯誤報告
# errpt -d H -T PERM //硬體的錯誤報告
IDENTIFIER TIMESTAMP  T C RESOURCE_NAME  DESCRIPTION
BFE4C025   0530085308 P H sysplanar0     UNDETERMINED ERROR
BFE4C025   0529091308 P H sysplanar0     UNDETERMINED ERROR

# errpt -d S -T PERM //軟體的錯誤報告
# errpt -aj *******|more //具體的錯誤資訊
# errpt -d H -T PERM>/tmp/hwerror.log //可以把錯誤的報告存成一個檔案

4、有否給 root 使用者的錯誤報告
# mail
Mail [5.2 UCB] [AIX 5.X]  Type ? for help.
"/var/spool/mail/root": 5 messages 3 new 5 unread
 U  1 root              Thu May 15 09:53  24/884  "diagela message from p615"
 U  2 root              Fri May 16 04:07  24/884  "diagela message from p615"
>N  3 root              Sat May 24 13:08  23/874  "diagela message from p615"

5、檢查 hacmp.out, smit.log, bootlog 等
# lssrc -g cluster/#>lssrc -g cluster
Subsystem         Group            PID          Status
 clstrmgrES       cluster          16334        active

一般上 hacmp.out 的位置: /usr/sbin/cluster/ 或者 /tmp/
然後找到最近的 hacmp.out 檔案,察看有沒有錯誤資訊

6、檔案系統檢查
# df -k
Filesystem    1024-blocks      Free %Used    Iused %Iused Mounted on
/dev/hd4           131072    101568   23%     2268     4% /
/dev/hd2          1441792     31256   98%    36056    11% /usr
/dev/hd9var        131072    117048   11%      418     2% /var

看看有沒有超過 90% 使用率的,建議使用者改善

7、邏輯卷有否 "stale" 的狀態
# lsvg -l rootvg
LV NAME             TYPE       LPs   PPs   PVs  LV STATE      MOUNT POINT
hd5                 boot       1     1     1    closed/syncd  N/A
hd6                 paging     4     4     1    open/syncd    N/A
hd8                 jfslog     1     1     1    open/syncd    N/A
hd4                 jfs        1     1     1    open/syncd    /
hd2                 jfs        11    11    1    open/syncd    /usr
hd9var              jfs        1     1     1    open/syncd    /var

如果系統還有其他卷組,也需要察看

8、記憶體交換區的使用率是否超過 70%
# lsps -a
Page Space      Physical Volume   Volume Group    Size %Used Active  Auto  Type
hd6             hdisk0            rootvg         512MB     1   yes   yes    lv


9、系統效能是否有瓶頸
# topas
# vmstat 1 10
kthr    memory              page              faults        cpu
----- ----------- ------------------------ ------------ -----------
 r  b   avm   fre  re  pi  po  fr   sr  cy  in   sy  cs us sy id wa
 0  0 110029 408618   0   0   0   0    0   0   4  602  75  0  1 99  0
 0  0 110031 408616   0   0   0   0    0   0   1  562  54  1  0 99  0
 0  0 110031 408616   0   0   0   0    0   0   3  628  84  0  0 99  0

# iostat 1 10
tty:      tin         tout    avg-cpu: % user % sys % idle % iowait
          0.0        394.0                0.0   0.0  100.0      0.0

Disks:        % tm_act     Kbps      tps    Kb_read   Kb_wrtn
hdisk0           0.0       0.0       0.0          0         0
hdisk1           0.0       0.0       0.0          0         0
cd0              0.0       0.0       0.0          0         0

10、網路與通訊檢查
# ifconfig -a


# netstat -in
Name  Mtu   Network     Address            Ipkts Ierrs    Opkts Oerrs  Coll
en0   1500  link#2      0.9.6b.3e.6.ac        1964     0      534     0     0
en0   1500  192.168.0   192.168.0.11          1964     0      534     0     0
lo0   16896 link#1                             267     0      413     0     0
lo0   16896 127         127.0.0.1              267     0      413     0     0

# netstat -rn //察看路由情況
Routing tables
Destination      Gateway           Flags   Refs     Use  If   Exp  Groups

Route Tree for Protocol Family 2 (Internet):
127/8            127.0.0.1         U         7       142 lo0      -      -
192.168.0.0      192.168.0.11      UHSb      0         0 en0      -      -   =>

# vi /etc/hosts //察看 hosts 檔案有否特殊的定義
# ping ****

#lsattr -El inet0 //路由的檢測
authm         65536               Authentication Methods           True
hostname      h24                 Host Name                        True
gateway                           Gateway                          True
route         net,,0,172.16.23.81 Route                            True
bootup_option no                  Serial Optical Network Interface True
rout6                             FDDI Network Interface           True

11、有否符合要求的系統備份
第一次去可以先詢問客戶關於備份的策略
# ls -l /image.data //看看系統有沒有備份的 image 檔案,記錄最後備份日期
-rw-r--r--   1 root     system         9600 May 19 17:31 /image.data


# lsvg -l rootvg //察看有否符合要求的資料備份和保護
LV NAME             TYPE       LPs   PPs   PVs  LV STATE      MOUNT POINT
hd4                 jfs        1     1     1    open/syncd    /
hd2                 jfs        11    11    1    open/syncd    /usr
hd10opt             jfs        1     1     1    open/syncd    /opt
oraclelv            jfs2       80    160   1    open/syncd    /oracle
loglv00             jfs2log    1     1     1    open/syncd    N/A
testlv              jfs        10    20    1    closed/syncd  /tmp/test

如何察看資料保護方式 RAID10/RAID5,RAID 的Hotspare 屬性是否開啟

#smitty ssaraid? Change/Show Attributes of an SSA RAID Array
檢查Enable Use of Hot Spares屬性是否為YES

12、系統 Dump 設定是否正確
# sysdumpdev -l
primary              /dev/hd6
secondary            /dev/sysdumpnull
copy directory       /var/adm/ras
forced copy flag     TRUE
always allow dump    FALSE
dump compression     OFF

# sysdumpdev P p /dev/hd6 s /dev/sysdumpnull
# sysdumpdev -P -c

13、HACMP 測試
# /usr/sbin/cluster/diag/clconfig -v '-tr'  // Cluster Verification 輸出結果無Fail
# /lssrc -g cluster

14、maxpout, minpout 系統引數
如果系統中執行了HACMP
smitty chgsysy,將High/Low water mark從0/0修改為33/24

# lsattr -El sys0|grep maxpout
//maxpout 用途: 對檔案指定未決 I/O 的最大數目
值: 預設值:0(不檢查);範圍:0 到 n(n 應該是 4 的倍數加 1)

# lsattr -El sys0|grep minpout
//指定一個基點,在該基點處,已達到 maxpout 的程式可以繼續寫入檔案
值: 預設值:0(不檢查);範圍:0 到 n(n 應該是 4 的倍數,且大於或等於 4 小於 maxpout)

15、syncd 引數
# grep syncd /sbin/rc.boot //sync() 被 syncd 呼叫的間隔時間
nohup /usr/sbin/syncd 10 > /dev/null 2>&1 &

值: 預設值:60;範圍:1 到任何正整數
顯示: grep syncd /sbin/rc.boot 或 vi /sbin/rc.boot
更改: 更改在下次引導後有效,而且是永久有效。備用方法是使用命令 kill 來終止守護程式

syncd 並用命令 /usr/sbin/syncd interval 從命令列重新啟動它。
診斷: 當 syncd 正在執行時,檔案的 I/O 被阻塞了。
調整: 在預設級別上,這個引數幾乎不影響效能。不推薦對這個引數進行更改。為了保持資料完整

性對於 HACMP而使 syncd interval 明顯縮小,會導致效能下降。

更改命令為:
#vi /sbin/rc.boot

16、aio 引數 //非同步 I/O 可調引數
# lsdev -C|grep aio
察看狀態是否是 available

# lsattr -El aio0
minservers 1         MINIMUM number of servers                True
maxservers 10        MAXIMUM number of servers                True
maxreqs    4096      Maximum number of REQUESTS               True
kprocprio  39        Server PRIORITY                          True
autoconfig available STATE to be configured at system restart True
fastpath   enable    State of fast path                       True

# smit aio  //可以更改引數

17、檢查 errdaemon, srcmstr 是否正常執行
# ps -ef|grep err
# ps -ef|grep src

18、 系統硬體診斷
# diag
-> Diagnostic Routines
-> System Verification
-> All Resources
-> F7 或者 Esc+7

19、補丁程式 PTF 是否滿足要求,當前系統補丁版本
#oslevel -r
5300-04

#instfix -i|grep
    All filesets for 5.3.0.0_AIX_ML were found.
    All filesets for 5300-01_AIX_ML were found.
    All filesets for 5300-02_AIX_ML were found.
    All filesets for 5300-03_AIX_ML were found.
    All filesets for 5300-04_AIX_ML were found.
    All filesets for 5300-05_AIX_ML were found.

# lscfg -vp //檢查所有裝置的微碼

20、收集系統資訊放到/tmp/ibmsupt
# snap -ac //執行#snap -ac,生成檔案snap+s/n.pax.Z



 (1)顯示10個消耗cpu最多的程式
  # ps aux |head -1 ;ps aux |sort -rn +2 |head -10

  (2)顯示10個消耗記憶體最多的程式

  #ps vx |head -1 ;ps vx |grep -v PID |sort -rn +6 |head -10

  (3)顯示10個換頁最多的程式

  #ps vx |head -1 ;ps vx |grep -v PID |sort -rn +4 |head -10

  (4)顯示10個消耗儲存空間最多的程式

  #ps aux |head -1 ;ps aux |sort -rn +3 |head -10



21:修改AIX系統的連線數:(預設的是128)
 
  #smitty  chgsys

來自 “ ITPUB部落格 ” ,連結:http://blog.itpub.net/17172228/viewspace-777240/,如需轉載,請註明出處,否則將追究法律責任。

相關文章