這個練習的來源是 Routing TCP/IP Volume I, 2nd Edition 的 Page 29 7~ 299. 利用 Dynamips/Dynagen 的方式來進行基本的 EIGRP Configuration 練習。要進行這個 Lab, 必須要在自己的電腦上安裝 Dynamips/Dynagen. 詳細的安裝方式請參考網上的資料!

Dynamips/Dynagen 的設定檔如下:

配置:
# Another simple dynagen configuration file
#

autostart = false
ghostios = true

[localhost]

    `7200`
    p_w_picpath = Program FilesDynamipsp_w_picpathsc7200-jk9o3s-mz.124-12.bin
    npe = npe-400
    ram = 160
   
    `ROUTER Earhart`
    console = 2001
    s1/0 = Lindbergh s1/0
    s1/1 = Cochran s1/0

    `ROUTER Lindbergh`
    console = 2002
   
    `ROUTER Cochran`
    console = 2003

其中的 IOS 檔案,請尋找正常管道取得。

三個 Routers 的 Initial configuration 如下:

配置:
hostname Earhart
!
interface Loopback0
 ip address 172.20.10.1 255.255.255.0
!
interface Serial1/0
 description “Connect to Router Lindbergh S1/0”
 ip address 172.20.15.1 255.255.255.252
!
interface Serial1/1
 description “Connect to Router Cochran S1/0”
 ip address 172.20.15.5 255.255.255.252
!

配置:
hostname Lindbergh
!
interface Loopback0
 ip address 192.168.16.1 255.255.255.0
!
interface Serial1/0
 description “Connect to Router Earhart S1/0
 ip address 172.20.15.2 255.255.255.252
!

配置:
hostname Cochran
!
interface Loopback0
 ip address 192.168.17.1 255.255.255.0
!
interface Serial1/0
 description “Connect to Router Earhart S1/1”
 ip address 172.20.15.6 255.255.255.0
!

需要輸入的指令如下:

配置:
Earhart(config)# router eigrp 15
Earhart(config-router)# network 172.20.0.0
Earhart(config-router)# exit
Earhart(config)#

配置:
Lindbergh(config)# router eigrp 15
Lindbergh(config-router)# network 172.20.0.0
Lindbergh(config-router)# network 192.168.16.0
Lindbergh(config-router)# exit
Lindbergh(config)#

配置:
Cochran(config)# router eigrp 15
Cochran(config-router)# network 172.20.0.0
Cochran(config-router)# network 192.168.17.0
Cochran(config-router)# exit
Cochran(config)#

當所有的設定做完之後,結果如下:

配置:
Earhart#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     172.20.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.20.10.0/24 is directly connected, Loopback0
C       172.20.15.4/30 is directly connected, Serial1/1
C       172.20.15.0/30 is directly connected, Serial1/0
D    192.168.17.0/24 [90/2297856] via 172.20.15.6, 00:00:13, Serial1/1
D    192.168.16.0/24 [90/2297856] via 172.20.15.2, 00:00:50, Serial1/0
Earhart#

配置:
Lindbergh#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     172.20.0.0/16 is variably subnetted, 4 subnets, 3 masks
D       172.20.10.0/24 [90/2297856] via 172.20.15.1, 00:02:19, Serial1/0
D       172.20.15.4/30 [90/2681856] via 172.20.15.1, 00:02:19, Serial1/0
C       172.20.15.0/30 is directly connected, Serial1/0
D       172.20.0.0/16 is a summary, 00:02:09, Null0
D    192.168.17.0/24 [90/2809856] via 172.20.15.1, 00:01:31, Serial1/0
C    192.168.16.0/24 is directly connected, Loopback0
Lindbergh#

配置:
Cochran#show ip route
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
       D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
       N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
       E1 – OSPF external type 1, E2 – OSPF external type 2
       i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
       ia – IS-IS inter area, * – candidate default, U – per-user static route
       o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

     172.20.0.0/16 is variably subnetted, 4 subnets, 3 masks
D       172.20.10.0/24 [90/2297856] via 172.20.15.5, 00:02:26, Serial1/0
D       172.20.15.0/30 [90/2681856] via 172.20.15.5, 00:02:26, Serial1/0
C       172.20.15.0/24 is directly connected, Serial1/0
D       172.20.0.0/16 is a summary, 00:02:12, Null0
C    192.168.17.0/24 is directly connected, Loopback0
D    192.168.16.0/24 [90/2809856] via 172.20.15.5, 00:02:26, Serial1/0
Cochran#

Kuo…

PS: 這個 Lab 基本上很簡單。但是,對完全沒有設定過 Cisco 路由器的人來說,還是會有點困難的。所以,通過這樣的方式,讓沒有機會碰到路由器的人,也可以在自己的家裡練習。

另外,也希望大家可以說出自己的想法與意見。