YT14-HDU-求N^N的個位數(暴力破解版)
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2 3 4
Sample Output
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
程式碼如下:
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
#include <iostream>
using namespace std;
int main()
{
int n,T,m,a;
cin>>T;
while (T--)
{
cin>>n;
a=n%10;
if (a==0||a==1||a==5||a==6||a==9)
m=a;
else if (a==2)
{
if(n%4==0)
m=6;
else
m=4;
}
else if (a==3)
{
if (n%4==1)
m=3;
else
m=7;
}
else if (a==4)
{
m=6;
}
else if (a==7)
{
if (n%4==1)
m=7;
else
m=3;
}
else
{
if (n%4==0)
m=6;
else
m=4;
}
cout<<m<<endl;
}
return 0;
}
網上看到的解題步驟,很HUANG很暴力。。。偏偏我想不出更好的方法了。T.T差距果然還是很大啊
相關文章
- 3069 求n個整數的和
- ACM n-1位數ACM
- 階乘之和 輸入n,計算S=1!+2!+3!+…+n!的末6位(不含前導0)。n≤10 6 ,n!表示 前n個正整數之積。
- 杭電OJ 2028求n個數的最小公倍數
- 求n個排序連結串列的交集排序
- 指標-n個數的排序指標排序
- POJ 2442-Sequence(優先佇列-m組n個數每組取一個求n個最小值)佇列
- 求無序陣列總第n大的數陣列
- 計算2的N次冪n 可輸入,n為自然數
- .C++整數的N進位制字串表示C++字串
- 對N個數進行排序排序
- 3516 求n個整數的最小值 迴圈結構
- 定義一個求n的階乘的函式函式
- Codeforces 27E Number With The Given Amount Of Divisors (求約數個數為n的最小數)
- Java語言非遞迴求第n個斐波那契數Java遞迴
- 查詢數N二進位制中1的個數(JS版 和 Java版)JSJava
- 2022-07-11:給定n位長的數字字串和正數k,求該子符串能被k整除的子串個數。 (n<=1000,k<=100)字串
- 7-7 求n以內最大的k個素數以及它們的和
- 用q實現篩法求1-n的質數
- Nth Digit 第N個數字Git
- poj3252 數位dp(所有比n小的二進位制位0的個數不少於1的個數)記憶化搜尋
- N進位制漫談
- 小於n的最大數
- 分組求TOP N記錄
- 【演算法詳解】列印1到最大的n位數演算法
- css如何匹配倒數第n個元素CSS
- 3070 n個整數“打擂臺”
- L1-009 N個數求和
- linux echo命令的-n、-e兩個引數Linux
- MySQL中資料型別(char(n)、varchar(n)、nchar(n)、nvarchar(n)的區別)MySql資料型別
- 從面試題中學演算法(2)---求陣列中唯一n個出現1次的數字(n=1,2,3)面試題演算法陣列
- n進位制轉十進位制
- 集合的前N個元素
- N位二進位制數加減法運算圖靈機圖靈
- 劍指offer面試題12 列印1到最大的n位數面試題
- 求1+2+...+n(Java實現)Java
- 【python初學者日記】讀入正整數m、n和k,求m、n之間能被k整除的所有整數Python
- CSS 倒數第n個li元素樣式CSS