YT14-HDU-求N^N的個位數(暴力破解版)
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2 3 4
Sample Output
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
程式碼如下:
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
#include <iostream>
using namespace std;
int main()
{
int n,T,m,a;
cin>>T;
while (T--)
{
cin>>n;
a=n%10;
if (a==0||a==1||a==5||a==6||a==9)
m=a;
else if (a==2)
{
if(n%4==0)
m=6;
else
m=4;
}
else if (a==3)
{
if (n%4==1)
m=3;
else
m=7;
}
else if (a==4)
{
m=6;
}
else if (a==7)
{
if (n%4==1)
m=7;
else
m=3;
}
else
{
if (n%4==0)
m=6;
else
m=4;
}
cout<<m<<endl;
}
return 0;
}
網上看到的解題步驟,很HUANG很暴力。。。偏偏我想不出更好的方法了。T.T差距果然還是很大啊
相關文章
- 3069 求n個整數的和
- 輸入N,再輸入N個數,N
- 拆解N的5位質數
- 求N!
- 杭電OJ 2028求n個數的最小公倍數
- n個骰子的點數
- 指標-n個數的排序指標排序
- 3516 求n個整數的最小值 迴圈結構
- 2022-07-11:給定n位長的數字字串和正數k,求該子符串能被k整除的子串個數。 (n<=1000,k<=100)字串
- 給定一個n,輸出從1到n的整數
- 2022-07-17:1、2、3...n-1、n、n、n+1、n+2... 在這個序列中,只有一個數字有重複(n)。 這
- .C++整數的N進位制字串表示C++字串
- 計算2的N次冪n 可輸入,n為自然數
- 定義一個求n的階乘的函式函式
- 快排思想O(N)求第k大數
- Nth Digit 第N個數字Git
- 3070 n個整數“打擂臺”
- JZ-074-n 個骰子的點數
- 匹配至少n位整數正規表示式
- 匹配n位正整數正規表示式
- Java語言非遞迴求第n個斐波那契數Java遞迴
- JZ-068-列印從 1 到最大的 n 位數
- 求n以內的所有質素
- 求1到n範圍內能被5或6或8 整除的數的個數.
- 7-7 求n以內最大的k個素數以及它們的和
- FBL5N、FBL3N、 FBL1N ALV新增欄位顯示
- 統計整數區間[N,M](N,M<100000)中所以非偶數的合數個數,並輸出這個數。
- L1-009 N個數求和
- linux echo命令的-n、-e兩個引數Linux
- 小於n的最大數
- n進位制轉十進位制
- PAT-L1-009 N個數求和
- n*n的乘法口訣表
- 【劍指 Offer 】17. 列印從1到最大的n位數
- 劍指offer | 17. 列印從1到最大的n位數
- MySQL中資料型別(char(n)、varchar(n)、nchar(n)、nvarchar(n)的區別)MySql資料型別
- # 2024_8_4 求單調上升總和為n的數列的方案數
- 找出N以內的偶數
- 【python初學者日記】讀入正整數m、n和k,求m、n之間能被k整除的所有整數Python