(UVA - 10048) Audiophobia(floyd演算法)

feng_zhiyu發表於2017-08-11

Consider yourself lucky! Consider yourself lucky to be still breathing and having fun participating in
this contest. But we apprehend that many of your descendants may not have this luxury. For, as you
know, we are the dwellers of one of the most polluted cities on earth. Pollution is everywhere, both in
the environment and in society and our lack of consciousness is simply aggravating the situation.
However, for the time being, we will consider only one type of pollution - the sound pollution. The
loudness or intensity level of sound is usually measured in decibels and sound having intensity level 130
decibels or higher is considered painful. The intensity level of normal conversation is 6065 decibels and
that of heavy traffic is 7080 decibels.
Consider the following city map where the edges refer to streets and the nodes refer to crossings.
The integer on each edge is the average intensity level of sound (in decibels) in the corresponding street.
To get from crossing A to crossing G you may follow the following path: A-C-F-G. In that case
you must be capable of tolerating sound intensity as high as 140 decibels. For the paths A-B-E-G,
A-B-D-G and A-C-F-D-G you must tolerate respectively 90, 120 and 80 decibels of sound intensity.
There are other paths, too. However, it is clear that A-C-F-D-G is the most comfortable path since
it does not demand you to tolerate more than 80 decibels.
In this problem, given a city map you are required to determiine the minimum sound intensity level
you must be able to tolerate in order to get from a given crossing to another.
Input
The input may contain multiple test cases.
The first line of each test case contains three integers C(≤ 100), S(≤ 1000) and Q(≤ 10000) where
C indicates the number of crossings (crossings are numbered using distinct integers ranging from 1 to
C), S represents the number of streets and Q is the number of queries.
Each of the next S lines contains three integers: c1, c2 and d indicating that the average sound
intensity level on the street connecting the crossings c1 and c2 (c1 ̸= c2) is d decibels.
Each of the next Q lines contains two integers c1 and c2 (c1 ̸= c2) asking for the minimum sound
intensity level you must be able to tolerate in order to get from crossing c1 to crossing c2.
The input will terminate with three zeros form C, S and Q.
Output
For each test case in the input first output the test case number (starting from 1) as shown in the
sample output. Then for each query in the input print a line giving the minimum sound intensity level
(in decibels) you must be able to tolerate in order to get from the first to the second crossing in the
query. If there exists no path between them just print the line “no path”.
Print a blank line between two consecutive test cases.
Sample Input
7 9 3
1 2 50
1 3 60
2 4 120
2 5 90
3 6 50
4 6 80
4 7 70
5 7 40
6 7 140
1 7
2 6
6 2
7 6 3
1 2 50
1 3 60
2 4 120
3 6 50
4 6 80
5 7 40
7 5
1 7
2 4
0 0 0
Sample Output
Case #1
80
60
60
Case #2
40
no path
80

題意:給定一個C個點S條邊(C<=100,S<=1000)的無向邊帶權圖,權值代表該路徑上的噪值。當你取從某點到另一點時,希望路過的最大噪聲值最小。
輸入q次詢問,輸出兩個點之間的最大噪聲值最小的路徑。

分析:兩個點之間的最短路問題,題目的c資料不大,採用floyd演算法,對其稍微變形即可

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define mem(a,n) memset(a,n,sizeof(a))
const int INF=0x3f3f3f3f;
const int N=105;
int d[N][N];
int c,s,q;
void floyd()
{
    for(int k=1; k<=c; k++)
        for(int i=1; i<=c; i++)
            for(int j=1; j<=c; j++)
                d[i][j]=min(d[i][j],max(d[i][k],d[k][j]));
}
int main()
{
    int cas=1;
    while(~scanf("%d%d%d",&c,&s,&q))
    {
        mem(d,INF);
        if(!c&&!s&&!q) break;
        if(cas!=1) puts("");
        printf("Case #%d\n",cas++);
        for(int i=0; i<s; i++)
        {
            int x,y,w;
            scanf("%d%d%d",&x,&y,&w);
            d[x][y]=w;
            d[y][x]=w;
        }
        floyd();
        for(int i=0; i<q; i++)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(d[x][y]!=INF)
                printf("%d\n",d[x][y]);
            else puts("no path");
        }
    }
    return 0;
}

相關文章