(poj3468)A Simple Problem with Integers(區間更新)

feng_zhiyu發表於2017-08-10

Description

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output

4
55
9
15
Hint

The sums may exceed the range of 32-bit integers.
Source

POJ Monthly–2007.11.25, Yang Yi

分析:區間更新

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
typedef long long LL;
const LL N=2e5+5;
LL sum[N<<2],a[N],MAX[N<<2],ad[N<<2];
void pushup(LL rt)
{
    sum[rt]=sum[rt<<1]+sum[rt<<1|1];
    // MAX[rt]=max(MAX[rt<<1],MAX[rt<<1|1]);
}
void pushdown(int rt,int m)
{
    if(ad[rt])
    {
        ad[rt<<1]+=ad[rt];
        ad[rt<<1|1]+=ad[rt];
        sum[rt<<1]+=ad[rt]*(m-(m>>1));
        sum[rt<<1|1]+=ad[rt]*(m>>1);
        ad[rt]=0; ///標記清除!!!
    }
}
void build(LL l,LL r,LL rt)
{
    ad[rt]=0;
    if(l==r)
    {
        scanf("%lld",&sum[rt]);
        return ;
    }
    LL m=(l+r)>>1;
    build(lson);
    build(rson);
    pushup(rt);
}
void update(LL L,LL R,LL c,LL l,LL r,LL rt)
{
    if(L<=l&&R>=r)
    {
        ad[rt]+=c;
        sum[rt]+=c*(r-l+1);
        return ;
    }
    pushdown(rt,r-l+1);
    LL m=(l+r)>>1;
    if(L<=m) update(L,R,c,lson);
    if(R>m) update(L,R,c,rson);
    pushup(rt);
}
LL query(LL L,LL R,LL l,LL r,LL rt)
{
    if(L<=l&&R>=r)
    {
        return sum[rt];
    }
    pushdown(rt,r-l+1);
    LL m=(l+r)>>1;
    LL ret=0;
    if(L<=m) ret+=query(L,R,lson);
    if(R>m) ret+=query(L,R,rson);
    return ret;
}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        build(1,n,1);
        for(int i=0; i<m; i++)
        {
            char op;
            LL a,b,c;
            scanf(" %c",&op);
            if(op=='Q')
            {
                scanf("%lld%lld",&a,&b);
                printf("%lld\n",query(a,b,1,n,1));

            }
            else
            {
                scanf("%lld%lld%lld",&a,&b,&c);
                update(a,b,c,1,n,1);
            }
        }
    }
    return 0;
}

相關文章